Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Plugins & Atahualpa (http://forum.bytesforall.com/forumdisplay.php?f=16)
-   -   [SOLVED] Creating a new page template (http://forum.bytesforall.com/showthread.php?t=19545)

emanuel1969 Feb 3, 2013 10:10 AM

[SOLVED] Creating a new page template
 
Hi. I've been having problems with the comment box appearing on pages created with a certain plugin. These pages do not have the typical "allow comments" checkbox in the dashboard. I asked the plugin author how to remove this box and at first he told me to make a copy of my theme's "sinlge.php" file (or "page.php") and rename the new copy this specific name that will then serve as a template for the plugin pages. However, in Atahualpa, there are no files with such names. At least I cannot find them.

So then the plugin author responded with this: "Then you have to ask the theme developer how to create a page template without the comment form."

I've never created a page template before. Can someone help me?

Thanks!
Emanuel

juggledad Feb 3, 2013 12:28 PM

what is the plugin?

emanuel1969 Feb 3, 2013 12:59 PM

The plugin is called Download Manager. Here is the link:

http://wordpress.org/extend/plugins/download-manager/

When you create, edit or display a download package, it works just like a regular wordpress "page" except the page is called a "package." Kind of like All-in-one-events-calendar, the way you create an "event" and in the dashboard you have a list of events that work just like pages except they are events instead.

Anyway, in the dashboard, when you are on the create/edit download package page, the usual check-boxes that say, "allow comments" and "allow pingbacks" are not there. So I cannot uncheck them. Hence the comments box appears on each download page I create.

juggledad Feb 3, 2013 01:12 PM

I just instaled it, created a package, added teh short codet to a post. In the post I shut off comments (unchecked the 'allow comments in the 'Dicuession' section)

how are you putting the package into a post/page?

lmilesw Feb 3, 2013 01:16 PM

Do you have discussion enabled in screen options? I installed the plugin and the allow comments checkbox shows.

emanuel1969 Feb 3, 2013 01:25 PM

Oh right I forgot to mention... I have the Pro version. In the standard version you put short-code into a post. In the Pro version you *can* do it this way, but you lose a lot of the features. The Pro version creates pages (called "packages" but they display as their own page).

Here is one of them. (Keep in mind this site has not been launched yet, so it is on my personal server at the moment. When I launch it for my client it will move to its own domain.)

http://www.sferios.com/intuitivecall...e-pattern-mp3/

lmilesw Feb 3, 2013 01:36 PM

You could just use CSS to not display the comment forms.

emanuel1969 Feb 3, 2013 01:57 PM

Really? CSS? Not some PHP file that calls up the comments box? (I could not find the php file to edit.)

Which files should I edit? Is it in the plugin folder or somewhere else? Also, I *do* want the comment form to be displayed on my client's posts.

juggledad Feb 3, 2013 03:58 PM

use CSS to target that page and set the element to 'display: none;' and it won't show.
HTML Code:

div.wpdmpro div#respond {display:none;}

emanuel1969 Feb 3, 2013 04:16 PM

Ooooo. That looks like a good idea. The comment box, currently, looks like it is utilizing the styles set from within Atahualpa. So would I put this line of code somewhere in one of the Atahualpa css files?

Thanks.

lmilesw Feb 3, 2013 04:34 PM

That CSS would go in the CSS Inserts box in the theme options.

emanuel1969 Feb 3, 2013 04:57 PM

I just did it and it didn't work. :(

emanuel1969 Feb 3, 2013 05:08 PM

Can you break down what these elements mean of the code you gave me? That might help me understand. I get the display:none; part but not sure what the first two elements mean...

div.wpdmpro div#respond

Thanks,

lmilesw Feb 3, 2013 05:25 PM

As it turns out that CSS won't work in this situation but the following should
HTML Code:

#post-3780 + #respond {
    display: none;
}

The first part or selector is indicating to look for the item with an ID of respond that follows the post with an ID of post-3780.

If you want to hide the comment form on other pages you just need to determine the ID of that particular page. I use the Firebug extension for Firefox to do that.

emanuel1969 Feb 3, 2013 05:48 PM

Oh wow! That worked. Thanks!!!!

So I will need to use a Firefox extension to determine the WP post ID? Is there another way?

juggledad Feb 3, 2013 06:53 PM

if you change the CSS selector to
HTML Code:

body.single-wpdmpro #response {display: none;}
it should work for all single pages.

emanuel1969 Feb 3, 2013 07:40 PM

That didn't work, but this did:

body.single-wpdmpro + #respond {display: none;}

Thanks so much!! Are you with Bytesforall? I'd like to donate some money to both byteforall.com and you specifically. :)

juggledad Feb 3, 2013 08:36 PM

both Larry (lmilesw) and I are just moderators but Flynn (the developer) has donate buttons setup for us. If you press the 'Click here to DONATE' you will see our buttons.

go back and recheck and remove the
HTML Code:

#post-3780 + #respond{ display:none}
you put in and you will see if fail until you remove the '+'

Using
HTML Code:

body.single-wpdmpro #response {display: none;}
or
HTML Code:

body.single-wpdmpro div#response {display: none;}
should work all the time unless something is more specific

emanuel1969 Feb 3, 2013 09:15 PM

I swear it's working now for all my download pages. Without the + it did not work. Here, see for yourself:

http://www.sferios.com/intuitivecall...backwards-mp3/
http://www.sferios.com/intuitivecall...an-anchor-mp3/
http://www.sferios.com/intuitivecall...e-pattern-mp3/

But please let me know if I am risking something here by doing this. You seem to think it should not be working so that concerns me.

emanuel1969 Feb 3, 2013 09:41 PM

Wow it's been a long night. Ok, after lots of typos and false alarms, it appears like each of these pieces of code works. I have settled on this one:

body.single-wpdmpro #response {display: none;}

Thank you very much, both of you!

:)

Emanuel


All times are GMT -6. The time now is 09:18 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.