Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Center area post/pages (http://forum.bytesforall.com/forumdisplay.php?f=32)
-   -   Permalink for posts without title (http://forum.bytesforall.com/showthread.php?t=12368)

Wyro Jan 21, 2011 03:06 AM

Permalink for posts without title
 
RE: ATA Ver. 3.6.1 Change: * Permalink for posts without title: Instead of the title the word 'Permalink' is displayed and linked to the full post.

QUESTION: Can you please tell me if there is a way to disable the new 3.6.1 feature where "Permalink" shows when a post does not have a title? I want nothing to show, and no vertical space left in it's place, like before.

Thanks guys!

lmilesw Jan 21, 2011 10:17 AM

Go to ATO>Configure SEO and turn on Post/Page Options. You will then have a box in each post to not show the title.

Wyro Jan 21, 2011 06:08 PM

2 Attachment(s)
Thanks but that did not work.

Here's my thing: I want to eliminate the (blank 'Permalink') title on my top article (it's a sticky) in my loop. The options in ATA SEO Post/Page Options seem to control showing/not showing the title on Single Post or Static Page titles only.

What I want is to have a post that's on my homepage as a sticky (which contains a slider) and I don't want the blank title to show as 'Permalink' (see attached "361wrong.jpg"). I want nothing to show. It worked that way in 3.5.3 and 3.5.1 without having to mess with any setting. I just have nothing in the title field in the post, and that space disappears (see attached "353right.jpg").

I would wire up the slider some other way if I could - but can't figure out how to get it on the top of the middle column on (important) the first page of the loop only.

Perhaps if you can't offer a solution to blank out the 'Permalink' on my post without a title, you could suggest how I could wire up the PHP for my slider (I know the code) so that it only shows on loop page 1 -- that would also solve me.

Help? Thank you!!! :)

lmilesw Jan 21, 2011 07:47 PM

Along with having the "Check to NOT display the Body Title on Single Post or Static Pages" box checked and make sure you have a title entered for the page or post.
If the title is left blank the Permalink will be seen.

Wyro Jan 21, 2011 07:51 PM

Larry thanks -- no dice. It does in fact perform the suppress when you click through to the post, but it still shows the title of that post in the loop, even after chacking "NOT to display" and entering a title.

Other ideas? Thank you so much...

Steve

lmilesw Jan 21, 2011 08:07 PM

I suspect if you set the boxes in ATO>Configure Excerpts to "Full Posts" the title will not show. Alternatively you could use the following in ATO>Add HTML/CSS Inserts>CSS Inserts but it will not show the title on any post.
HTML Code:

.post-headline {
 display: none;
}

If you only want the title not to show on certain posts you would have to add the page id to that selector as in the example below which would hide post titles on the home page.
HTML Code:

body.home .post-headline {
display: none;
}


Tollota Feb 4, 2011 05:29 PM

Hi Wyro,
Try to do this....
In the folder "functions" open and edit the file "bfa_post_parts.php".
It can also be done from the edit item of theme options menu in Wordpress.
Lines 44 and 45 shows the following:

Code:

        // Since 3.6.1: Display a link to the full post if there is no post title and the post is too short
        // for a read more link.
        if ( get_the_title() == '' ) { ?>
                <a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link">Permalink</a><?php
               
        } else if ( (!is_single() AND !is_page()) OR $bfa_ata_display_body_title == '' ) {

Modify the end of line 44 ("?>") joining to the begining of line 45 and "comment" the entire line 45 EXACTLY as below !!! :

Code:

        // Since 3.6.1: Display a link to the full post if there is no post title and the post is too short
        // for a read more link.
        if ( get_the_title() == '' ) {
                /* ?><a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link">Permalink</a><?php */
               
        } else if ( (!is_single() AND !is_page()) OR $bfa_ata_display_body_title == '' ) {

Is VERY IMPORTANT to open and close the comment with "/*" and "*/" as shown !!!
Save the changes.
That disables completely the function of add the word "Permalink" for posts without title.
For undo the change, simply edit again and delete the "comment" marks "/*" and "*/".
Like as you, I have in my homepage a static page with no title.
Hope this is useful to you as it is for me!

Best Regards,
Gabriel

juggledad Feb 21, 2011 03:52 PM

see BUGFIX 364-05: No link to the full post shown on excerpt when post has no title

Wyro Feb 21, 2011 04:38 PM

Thank you Juggledad!

apienovi Sep 20, 2011 03:24 PM

What can I do to fix this issue with 3.6.7? WP 3.2.1

lmilesw Sep 20, 2011 03:52 PM

The first thing to do with 3.6.7 is to apply ALL the patches.
  • PATCH 367-01: Odd effects when 'CSS: Compress' = 'Yes'
  • PATCH 367-02 is incorporated in PATCH 367-04
  • PATCH 367-03: PHP errors when adding widget areas in index.php
  • PATCH 367-04: Hovering over a Post/Page title only shows "Permanent Link to"
  • PATCH 367-05: Site Title appended after the 'WordPress SEO by Yoast' title

juggledad Sep 20, 2011 04:49 PM

are you having a problem?

GA Anderson Jan 6, 2012 11:21 AM

To Tollota

Great help for a new comer. I posted a similar problem and then found this solution, it worked, thanks but....

the "permalink" is gone, but there is still 50-70px of blank white space. is it possible to remove this and move the center content closer to the bottom of the page header?

GA

lmilesw Jan 6, 2012 12:06 PM

Check to make sure there is not code in that post at the top that is causing the space. Or perhaps there is a plugin that is adding code to the top. To test that you can temporarily deactivate all plugins to see if the problem goes away.


All times are GMT -6. The time now is 04:56 PM.

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.