Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Sidebars & Widgets (http://forum.bytesforall.com/forumdisplay.php?f=14)
-   -   Local backup: looks fine, but text widgets are gone (http://forum.bytesforall.com/showthread.php?t=15824)

EnricoWP Nov 1, 2011 10:06 AM

Local backup: looks fine, but text widgets are gone
 
I made local backup of my blog (I use xampp in my desktop), it looks fine, but I have to rebuild my text widgets (desappeared), it's normal?

juggledad Nov 1, 2011 01:08 PM

are you saying after you did a backup, you site is messed up
or are you saying you did a backup, then restored it and there is an issue?

EnricoWP Nov 2, 2011 02:59 AM

I'm saying i did a backup and restored in my local server. It works fine, but my text widgets are gone.

juggledad Nov 2, 2011 06:05 AM

how did you do the backup and restore? step by step
where were the text widgets? sidebars? in a new widget area?

EnricoWP Nov 2, 2011 11:55 AM

I did the backup as usually, it works perfectly, but the text widgets in sidebars are gone.

1) Backup datatabase
2) Backup data
3) Export Atahualpa settings
4) Create local database empty
5) Modify db backup with Notepad++ (sobstitution www.mysite.tld with 127.0.0.1/mysite)
6) Import db backup modified
7) Restore data folders
8) Modify wp-config.php

Result: all works perfectly, but everytime I have to restore text widgets in sidebars manually. Any idea?

juggledad Nov 2, 2011 12:53 PM

when you changed the url, wordpress resets things(according to my experience).
you would have to change the wordpress url and site address before doing the export.

this is not a backup/restore it is a backup from one location and a restore to another, since teh url changes, 'stuff' happens.

it's like you create a custom menu, then update the theme and you have to go back and reset the custom menu because WordPress reset it. It looks like Wordpress thinks a theme update is a new theme so it changes things.

EnricoWP Nov 2, 2011 04:25 PM

I never had this problem, with other themes...so it is an Atahualpa's problem, i think. But no problem, it isn't a tragedy, just a bit boring because i have to remake text widgets everytime. :)


All times are GMT -6. The time now is 03:40 AM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.