Wordpress Themes - WP Forum at BFA

Wordpress Themes - WP Forum at BFA (http://forum.bytesforall.com/index.php)
-   Plugins & Atahualpa (http://forum.bytesforall.com/forumdisplay.php?f=16)
-   -   Catchable fatal error: Object of class WP_Error could not be converted (http://forum.bytesforall.com/showthread.php?t=14606)

dazzle Jun 12, 2011 12:34 PM

Catchable fatal error: Object of class WP_Error could not be converted
 
Hi...love the theme. Thank you. But I'm getting the following when I search for terms (tags/words in the title) associated with 1 of the 3 test posts:

Catchable fatal error: Object of class WP_Error could not be converted to string in /home1/unlocki3/public_html/continuumscience/wp-content/themes/atahualpa/functions/bfa_postinfo.php on line 271

I'm using WP version 3.0.1 and the latest version of Atahualpa, which I think is 3.6.7. I'm using a search widget in sidebar, but it also happens when I use search that already comes with Atahualpa. Would someone please help me...I appreciate it. Thanks.

juggledad Jun 12, 2011 02:24 PM

First I suggest you update your WP install to 3.1.3
second do you have all BUGFIX's for your version applied? (they can be found in the 'New Version & Updates' forum and sub forum)
--if not, apply them before we go any further and re-test

dazzle Jun 12, 2011 02:44 PM

Thank you for responding. 1. I was afraid of upgrading WP because when I did, the plugins I use to organize info didn't work anymore; but, I'll try again. 2. I don't know what bugfix I'm looking for. Do you have a direct link to what is needed to solve this specific problem? Thank you.

dazzle Jun 12, 2011 04:50 PM

Is there any way to fix this problem without upgrading WP to 3.1.3. Plugins I use to structure content are said to NOT be compatible with WP 3.1.3. Are there any bugfixes that will deal with this specific problem...I'm assuming the problem is with bfa_postinfo.php, since this file is mentioned in the error message. Thank you.

juggledad Jun 12, 2011 05:55 PM

Look in the 'new version & updates' forum for the threads starting with 'BUGFIX 367-........' and apply them all and we will go from there.

dazzle Jun 12, 2011 06:04 PM

Yes, I have applied them all, but there is no change. As far as I can tell, when I change the permalink structure to only use post id, the problem seems to go away. But I don't want to just use the post id in permalink; I'd like to also use the post title.

juggledad Jun 12, 2011 07:02 PM

Are you on an apache server?
Try swapping to the twenty ten theme and see if you have a issue. That will tell if it is a theme issue

dazzle Jun 12, 2011 07:16 PM

I'm sorry, all I know is that my hosting company is BlueHost; whether it's Apache server, I don't know. I guess I should find out, huh? Anyhoooo, when I switched to Twenty Ten, the search function worked. I got no 'catchable fatal error" messages and the sidebar didn't disappear, so it looks like it's an Atahualpa theme issue. I hope I don't have to change themes; so far I've liked this theme, but of course, the search function is crucial. By the way, I have another site where the same problem is occurring; Atahualpa is used there also. Sure hope you can help us (I noticed other posts with the same kind of issue). Thank you kindly.

juggledad Jun 12, 2011 07:39 PM

Next temporally disable all your plugins to see if there is a conflict.

in WP 3.1.3 and Atahualpa 3.6.7 I have no problems with search.

dazzle Jun 12, 2011 07:53 PM

I already did the plugins; still the same problem. The reason I'm nervous about upgrading to WP 3.1.3 is because, most likely, there will be conflicts with the plugins I use, then I'll either have to wait 'til the plugins are updated, or look for a different plugin. I know for sure that at least one of the plugins I need is only compatible with WP up to version 3.0.5. Should I use an earlier version of Atahualpa with the wordpress version I have now (3.0.1)?

juggledad Jun 12, 2011 08:10 PM

Don't you have a playground site for testing? Let's say you have a site called dazzleme.com and you have wordpress installed in the www folder on your host.

You could create a subfolder, call it 'playroom' in the www folder and install a second copy of WP in it. You want to create a new database which you could also call 'playroom' and now get to it by typing dazzleme.com/playroom and you could test out upgrades, plugins and theme changes before you used them in your main site.

dazzle Jun 12, 2011 08:20 PM

No...no playground site for testing. I thought that Ata 3.6.7 would be compatible with WP 3.0.1, otherwise, I wouldn't have downloaded it. Are you saying there's no resolution to the error problem in Atahualpa theme?

juggledad Jun 12, 2011 08:38 PM

I'm saying, I don't experience the issue and I can't recreate it with what I tried. This means, I'm not doing the same thing or your environment is different and something in your environment is causing it.

Btw a google search shows several other people with this issue all across the board...in plugins wordpress code etc. One person said it was a host security issue another said it was a database issue but it maybe fixed in a later release than you have

dazzle Jun 12, 2011 10:17 PM

I've solved the problem (which was with Atahualpa). A German website offered insight into what the problem may be: Edit Post/Page Info Items > Kicker: Multi Post Pages. Even though the default is blank, you should be able to cusomize it...I can't customize this section with %category_linked%...it causes the 'catchable fatal error' message. However, I can customize Kicker:Homepage and Kicker:Single Post Pages with %category_linked%.

juggledad Jun 13, 2011 04:41 AM

interesting, I still don't get the error.

please go to ato->export/import settings, export your settings and attach them to a reply

couple other questions
- have you ever edited or deleted any category?
- do you still have an 'Uncategorized' category?

dazzle Jun 13, 2011 09:30 AM

1 Attachment(s)
I attached the settings as requested. Yes, I have edited and deleted categories. And, yes, I still have an uncategorized category. Actually, what is the best way to do this: if I want to change the category name, should I just create a new category, and delete the previous one?

juggledad Jun 13, 2011 11:44 AM

well I can not reproduce this with your settings. the statement reporting the error is calling a wordpress function dealing with categories. The only things I can think of are its an error in WP and you should upgrade or possibly your database has a problem.

I would do a database backup and then upgrade to wp 3.1.3 and see what happens.


All times are GMT -6. The time now is 10:31 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.