Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

Catchable fatal error: Object of class WP_Error could not be converted


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jun 12, 2011, 11:34 AM
dazzle
 
9 posts · Jun 2011
Hi...love the theme. Thank you. But I'm getting the following when I search for terms (tags/words in the title) associated with 1 of the 3 test posts:

Catchable fatal error: Object of class WP_Error could not be converted to string in /home1/unlocki3/public_html/continuumscience/wp-content/themes/atahualpa/functions/bfa_postinfo.php on line 271

I'm using WP version 3.0.1 and the latest version of Atahualpa, which I think is 3.6.7. I'm using a search widget in sidebar, but it also happens when I use search that already comes with Atahualpa. Would someone please help me...I appreciate it. Thanks.
  #2  
Old Jun 12, 2011, 01:24 PM
juggledad's Avatar
juggledad
 
21,705 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
First I suggest you update your WP install to 3.1.3
second do you have all BUGFIX's for your version applied? (they can be found in the 'New Version & Updates' forum and sub forum)
--if not, apply them before we go any further and re-test
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #3  
Old Jun 12, 2011, 01:44 PM
dazzle
 
9 posts · Jun 2011
Thank you for responding. 1. I was afraid of upgrading WP because when I did, the plugins I use to organize info didn't work anymore; but, I'll try again. 2. I don't know what bugfix I'm looking for. Do you have a direct link to what is needed to solve this specific problem? Thank you.

Last edited by dazzle; Jun 12, 2011 at 02:07 PM.
  #4  
Old Jun 12, 2011, 03:50 PM
dazzle
 
9 posts · Jun 2011
Is there any way to fix this problem without upgrading WP to 3.1.3. Plugins I use to structure content are said to NOT be compatible with WP 3.1.3. Are there any bugfixes that will deal with this specific problem...I'm assuming the problem is with bfa_postinfo.php, since this file is mentioned in the error message. Thank you.
  #5  
Old Jun 12, 2011, 04:55 PM
juggledad's Avatar
juggledad
 
21,705 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Look in the 'new version & updates' forum for the threads starting with 'BUGFIX 367-........' and apply them all and we will go from there.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #6  
Old Jun 12, 2011, 05:04 PM
dazzle
 
9 posts · Jun 2011
Yes, I have applied them all, but there is no change. As far as I can tell, when I change the permalink structure to only use post id, the problem seems to go away. But I don't want to just use the post id in permalink; I'd like to also use the post title.
  #7  
Old Jun 12, 2011, 06:02 PM
juggledad's Avatar
juggledad
 
21,705 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Are you on an apache server?
Try swapping to the twenty ten theme and see if you have a issue. That will tell if it is a theme issue
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #8  
Old Jun 12, 2011, 06:16 PM
dazzle
 
9 posts · Jun 2011
I'm sorry, all I know is that my hosting company is BlueHost; whether it's Apache server, I don't know. I guess I should find out, huh? Anyhoooo, when I switched to Twenty Ten, the search function worked. I got no 'catchable fatal error" messages and the sidebar didn't disappear, so it looks like it's an Atahualpa theme issue. I hope I don't have to change themes; so far I've liked this theme, but of course, the search function is crucial. By the way, I have another site where the same problem is occurring; Atahualpa is used there also. Sure hope you can help us (I noticed other posts with the same kind of issue). Thank you kindly.

Last edited by dazzle; Jun 12, 2011 at 06:22 PM.
  #9  
Old Jun 12, 2011, 06:39 PM
juggledad's Avatar
juggledad
 
21,705 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Next temporally disable all your plugins to see if there is a conflict.

in WP 3.1.3 and Atahualpa 3.6.7 I have no problems with search.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #10  
Old Jun 12, 2011, 06:53 PM
dazzle
 
9 posts · Jun 2011
I already did the plugins; still the same problem. The reason I'm nervous about upgrading to WP 3.1.3 is because, most likely, there will be conflicts with the plugins I use, then I'll either have to wait 'til the plugins are updated, or look for a different plugin. I know for sure that at least one of the plugins I need is only compatible with WP up to version 3.0.5. Should I use an earlier version of Atahualpa with the wordpress version I have now (3.0.1)?

Last edited by dazzle; Jun 12, 2011 at 07:10 PM.
  #11  
Old Jun 12, 2011, 07:10 PM
juggledad's Avatar
juggledad
 
21,705 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
Don't you have a playground site for testing? Let's say you have a site called dazzleme.com and you have wordpress installed in the www folder on your host.

You could create a subfolder, call it 'playroom' in the www folder and install a second copy of WP in it. You want to create a new database which you could also call 'playroom' and now get to it by typing dazzleme.com/playroom and you could test out upgrades, plugins and theme changes before you used them in your main site.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #12  
Old Jun 12, 2011, 07:20 PM
dazzle
 
9 posts · Jun 2011
No...no playground site for testing. I thought that Ata 3.6.7 would be compatible with WP 3.0.1, otherwise, I wouldn't have downloaded it. Are you saying there's no resolution to the error problem in Atahualpa theme?

Last edited by dazzle; Jun 12, 2011 at 07:29 PM.
  #13  
Old Jun 12, 2011, 07:38 PM
juggledad's Avatar
juggledad
 
21,705 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I'm saying, I don't experience the issue and I can't recreate it with what I tried. This means, I'm not doing the same thing or your environment is different and something in your environment is causing it.

Btw a google search shows several other people with this issue all across the board...in plugins wordpress code etc. One person said it was a host security issue another said it was a database issue but it maybe fixed in a later release than you have
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jun 12, 2011 at 07:46 PM.
  #14  
Old Jun 12, 2011, 09:17 PM
dazzle
 
9 posts · Jun 2011
I've solved the problem (which was with Atahualpa). A German website offered insight into what the problem may be: Edit Post/Page Info Items > Kicker: Multi Post Pages. Even though the default is blank, you should be able to cusomize it...I can't customize this section with %category_linked%...it causes the 'catchable fatal error' message. However, I can customize Kicker:Homepage and Kicker:Single Post Pages with %category_linked%.

Last edited by dazzle; Jun 12, 2011 at 09:37 PM.
  #15  
Old Jun 13, 2011, 03:41 AM
juggledad's Avatar
juggledad
 
21,705 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
interesting, I still don't get the error.

please go to ato->export/import settings, export your settings and attach them to a reply

couple other questions
- have you ever edited or deleted any category?
- do you still have an 'Uncategorized' category?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jun 13, 2011 at 04:30 AM.
  #16  
Old Jun 13, 2011, 08:30 AM
dazzle
 
9 posts · Jun 2011
I attached the settings as requested. Yes, I have edited and deleted categories. And, yes, I still have an uncategorized category. Actually, what is the best way to do this: if I want to change the category name, should I just create a new category, and delete the previous one?
Attached Files
File Type: txt ata-wwwcontinuumsciencecom-20110613.txt (14.1 KB, 284 views)
  #17  
Old Jun 13, 2011, 10:44 AM
juggledad's Avatar
juggledad
 
21,705 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
well I can not reproduce this with your settings. the statement reporting the error is calling a wordpress function dealing with categories. The only things I can think of are its an error in WP and you should upgrade or possibly your database has a problem.

I would do a database backup and then upgrade to wp 3.1.3 and see what happens.
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support

Bookmarks

Tags
bfa_postinfo.php, error

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Catchable fatal error: Object of class WP_Error bfa_postinfo.php on line 308 lickorish Center area post/pages 1 Sep 17, 2010 02:32 PM
Permalinks causing Catchable fatal error on image load courtnee Atahualpa 3 Wordpress theme 2 Sep 2, 2010 02:34 AM
SEARCH ERROR: Catchable fatal error:Object of class WP_Error could not be converted angelarose Plugins & Atahualpa 3 Jul 8, 2010 05:05 PM
Catchable fatal error: Object of class stdClass could not be converted to string in / mathmojo Atahualpa 3 Wordpress theme 7 May 16, 2010 10:45 PM
Catchable fatal error: Object of class stdClass could not be converted to string !? neocratus Atahualpa 3 Wordpress theme 11 Dec 13, 2008 06:47 PM


All times are GMT -6. The time now is 06:09 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.