Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » RSS, Feeds & Subscribing »

[SOLVED] HOW to fix my Comments feed?


  #1  
Old Mar 27, 2009, 08:14 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
One of my customers let me know that the main RSS feed was not updating. I realized that this was probably due to my having changed access to the wp site from the /wp/ subdirectory to the main/root directory. I still have all the WP and Atahualpa files in the subdir /wp -- it's just index.php that's out in the root dir.
explanation: you used to have to enter "http://www.hatchtown.com/wp/" to see our WP/Atahualpa site -- I changed that when I took the new site live and it is now accessed at "http://www.hatchtown.com"
I went to "My Feeds"/"Edit Feed Details" at Feedburner and deleted the wp/ from the "Original Feed" -- saved the change and all seemed okay.

But, then I tried to do the same thing to the comments feed's "Original Feed" address and I keep getting a 404 error???


UPDATE: I got frustrated and deleted the old Comments Feed and tried to burn a new one. I put in http://www.hatchtown.com as the blog address and received this message:

Identify Feed Source

The feed URL you entered is:

http://www.hatchtown.com

FeedBurner discovered more than one feed at that address. Please select one to use as your source:

1) Hatchtown Farm RSS Feed: http://hatchtown.com/feed
2) Hatchtown Farm Atom Feed: http://hatchtown.com/feed/atom
At that point I chickened out -- cancelled without activating.

So, I have a main RSS feed that appears to be working and NO comments feed, working or not. What is the "step-by-step" to get a comments feed working.

(sidebar: should I be asking at this point about cooment feeds just for specific posts?)

Is there some change(s) that I must make at "this end"?? ..to the Atahualpa options??

Help! Why is Feedburner SO user UNfriendly? You'd think Google would have sorted them out by now!

Last edited by Shepherd Jim; Mar 27, 2009 at 12:05 PM. Reason: to update Feedburner status
  #2  
Old Mar 27, 2009, 02:34 PM
BradBrown's Avatar
BradBrown
 
54 posts · Mar 2009
I'm assuming you're using the FD Feedburner Plugin or something similar. Here's what I'd try.

Go into the feedburner plugin settings. If you're using the same one I am, it's under Plugins>Feedburner Configuration. Delete the feed from the "Redirect my comments feed" box. Save that and see if you can acess your feed at http://hatchtown.com/comments/feed

If it works, reburn it with Feedburner and reset it in the plugin. If not, then at least you'll have eliminated the Feedburner plugin as being the culprit.

-Brad
  #3  
Old Mar 28, 2009, 06:41 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Still no joy here! I'm using the Feedburner Feedsmith plugin authored by Steve Smith. When I click on a "setup your comments feed" link IN that plugin's config area I get this failuer notice:
Error getting URL: 404 - null http://hatchtown.com/wp-commentsrss2.php/comments/feed {Set-Cookie=[PHPSESSID=57ab7c936ac30f8ecfd5617411f5717f; path=/], ETag=["e8d25582214c67523c5fbd2f35004686"], Date=[Sat, 28 Mar 2009 12:37:03 GMT], Pragma=[no-cache], Content-Type=[text/xml; charset=UTF-8], Cache-Control=[no-cache, must-revalidate, max-age=0], Connection=[Keep-Alive], Expires=[Wed, 11 Jan 1984 05:00:00 GMT], Keep-Alive=[timeout=15, max=100], Server=[Apache], null=[HTTP/1.1 404], Transfer-Encoding=[chunked], Last-Modified=[Sat, 28 Mar 2009 12:37:04 GMT], X-Pingback=[http://hatchtown.com/wp/xmlrpc.php]} GET
Identify Feed Source
Back to FeedBurner Home

The feed URL you entered is:

http://hatchtown.com/wp-commentsrss2.php

We could not find a valid feed at that address. Here are some possible reasons this might have happened:
I've tried to completely undo the WHOLE OLD comments feeds so that I can start completely afresh.

I need to know what to do STEP BY STEP.

TTFN Jim
  #4  
Old Mar 28, 2009, 02:48 PM
BradBrown's Avatar
BradBrown
 
54 posts · Mar 2009
The good news is your comment feed seems to be working at http://hatchtown.com/comments/feed, it just isn't going through Feedburner.

I'd say the problem is with the plugin. Since I'm not using the same one, I can't give you step by step instructions. The "FD Feedburner" plugin is working for me. So, you might want to deactivate yours and try that one.

If you want to stick with the one you are using, you might try uninstalling it and then reinstalling it from scratch. My guess is it is somehow got confused when you changed the main page address, so reinstalling it might straighten it out--but that's just a guess.

-Brad
  #5  
Old Mar 29, 2009, 07:32 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Yeah, I know I've discovered that the comments feed "chiclet" in the header on my website is "working". It's working so much that I am receiving notices on my RSS reader on my "My Yahoo" page.

http://hatchtown.com/

BUT, as you've figured out, the comments feed seems to be functioning outside of/without Feedburner. The comments feed still does not show up in the "My Feeds"? listing in Feedburner account.

AND, the main RSS posts feed is still working.
AND, this feed IS still showing up in my Google/Feedburner account.

I'm hesitant about messing with plugins, etc in my WP/Atahualpa installation before I'm sure what I' doing. I don't want to chance losing or dis-connecting the main posts feed that IS working and IS Feedburnerised properly.

Jim

PS - the folks at Feedburner seem ESPECIALLY BAD at both explaining how to do things and then answering the questions generated. A search in their help/support areas mostly provides links to message after message posted by people having the same problems with never any response ...month after month after month.
  #6  
Old Mar 29, 2009, 01:15 PM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Okay! You guys are too slow! I *think* I solved this prob myself.
1) I subscribed to the working comments feed at my webiste. I then went to my RSS feedreader, right-clicked on the comments feed and viewed its properties/details/whatever. I Ctrl-C copied the feed name.

2) I then logged into my acount over at Google Feedburner and Ctrl-V pasted the comments feed name right into the "Burn a Feed Right Now" box right there on my main account page. Clicked "next" a few times and the feed was "acquired" into Feedburner.
I only understand half of the whys and wherefores, but all seems good now.

SJim Rant: I still feel that someone needs to sit down and arrange the whole "feed thing". When everyone is super blasť about something and seems reluctant to discuss it in much detail I always figure it's because they don't have any real understanding of what they're talking about and are just bluffing their way through. If anyone out there has a full handle on feeds they're all 16 yearold male geeks and are completely incapable of expressing their thoughts in sentences intelligible to the rest of us.

There is not any sign that its happening, but I'd be hoping that now that Google owns Feedburner they'll be going in there and getting things organized. There's no reason that Feedburner must be completely non-intuitive, user-unfriendly, obtuse and mysterious.

Last edited by Shepherd Jim; Mar 29, 2009 at 01:21 PM.

Bookmarks

Tags
comments, feed, feedburner, rss

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fix Background? Antsliedown Atahualpa 3 Wordpress theme 0 May 7, 2009 08:44 AM
How do I exclude Comments feed from Widget dave925 RSS, Feeds & Subscribing 2 Apr 6, 2009 07:42 PM
[SOLVED] How do I fix the width of the center column? weightlosscoach Sidebars & Widgets 3 Mar 23, 2009 03:01 PM
Can I put HOME, POSTS and COMMENTS Feed links in sidebar? HalfWayThere RSS, Feeds & Subscribing 2 Feb 7, 2009 11:40 AM
Default Comments Feed not working Navi RSS, Feeds & Subscribing 3 Jan 28, 2009 05:02 PM


All times are GMT -6. The time now is 01:37 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.