Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Excerpts, Read more, Pagination »

Pagination link on home page ("Older Entries") is broken


  #1  
Old Sep 11, 2010, 09:20 PM
aking10
 
3 posts · Sep 2010
We're using Ata 3.5.1 on Wordpress 2.9.0. At the bottom of the posts on the home page of the website (www.maplegroveunitedchurch.org) the Older Entries link is broken.

This is what the href says: "http://www.maplegroveunitedchurch.org/index.php/Index.php/page/2" -- note that second "Index.php", with its odd uppercase I. Where is that coming from?

Needless to say, all we get when we click on this is a "cannot be found" error message.

Any help fixing this would be greatly appreciated!!
  #2  
Old Sep 12, 2010, 08:21 PM
juggledad's Avatar
juggledad
 
23,554 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What happens if you switch to the default permalinks?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Sep 13, 2010, 09:32 AM
aking10
 
3 posts · Sep 2010
Well, the default permalink structure (?p=123) allows the pagination to work. But I have two issues with that: First, the "pretty" permalink structure works fine on all other navigation on the site -- posts, pages, etc. and therefore I think the pagination link ought to be fixable as a "prettified" link to work as well. And second, the default permalinks are not SEO friendly, which is why we went to the non-default structure, and seem to have good results with everything but the pagination from the home page.

We are hosted on an IIS platform, which I know makes this problematic, but I can't help but feeling there should be a way to fix the insertion of that second "Index.php" in code. I can handle coding PHP, I just need to know where to look inside the ATA files for the code to revise.
  #4  
Old Sep 13, 2010, 02:45 PM
juggledad's Avatar
juggledad
 
23,554 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What is your custom permalink?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Sep 13, 2010, 02:59 PM
juggledad's Avatar
juggledad
 
23,554 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Atahualpa is just calling the wordpress function next_posts_link() which...
Quote:
Prints a link to the next set of posts within the current query.
so atahualpa doesn't do anything to the link, it is all wordpress and the htaccess file and the rewrite rules.

you may want to take a look at http://codex.wordpress.org/Using_Per...ut_mod_rewrite
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Sep 13, 2010, 03:14 PM
aking10
 
3 posts · Sep 2010
The custom permalink was:
/index.php/%year%/%monthnum%/%day%/%postname%/
and then we changed it to:
/index.php/%postname% to see if that would help (didn't).

Which is not the way the way the pagination link is output to the browser anyway, which is "(domainname)/index.php/Index.php/page/2". Two "index.php"s in a row, and the second one given an uppercase I for some reason. Weird.

So it looks from the link you suggested for me to check out is that I am going to have get my webhost to install an IIS module for allowing pretty permalinks.

I will try that. Thanks for the replies so far.

Last edited by aking10; Sep 13, 2010 at 03:19 PM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Separate "home" page and "blog" page jasonnorco Page & Category Menu Bars 4 Jul 18, 2010 02:53 PM
[SOLVED] next page link not working when "home category" is set? WesleyTack Page & Category Menu Bars 3 May 22, 2010 06:42 AM
[SOLVED] How to add additional link beside the "home" page above logo? cordi Other BFA WordPress Themes 2 Apr 8, 2010 12:21 PM
[SOLVED] "Older Posts" Navigation to Page 2 Not Working clintonfitchdotcom Page & Category Menu Bars 2 Feb 4, 2010 11:24 AM
Can I get rid of the word "Home" below menu bar on the home page? nasu Page & Category Menu Bars 1 Jun 30, 2009 03:36 PM


All times are GMT -6. The time now is 09:37 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.