Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

Top and Middle Prev/Next navigation doesn't match


  #1  
Old Sep 9, 2010, 01:33 PM
studiohanson
 
27 posts · Apr 2010
On my site, summitsips.com I had the prev/next navigation turned on for both the top and middle locations. I like it that way, but today I had to turn off the TOP and go with Middle only because they didn't match! I know, it sounds crazy, but I think I know why--I just don't know how to fix it.

I added a widget called Featured Tag on the left sidebar. Basically, this is letting me display thumbs of posts in the sidebar. the LAST POST of that widget's list seems to affect the TOP located Prev/Next navigation links on single post pages. Then, when ATA displays the single posts in the center column, the TOP-located Prev/Next navigation links correspond to the widget, not the actual single post on that page. In fact, EVERY single post now has TOP located navigation corresponding to that last thumbnail on the widget. It doesn't affect the Middle (or Bottom) located navigation links though.

I am guessing this has something to do with what is effectively a double "loop", one in my widget corresponding to certain tags I feature there, and the main loop. Both must use some kind of "current post" variable and that is confusing ATA when it builds the Top navigation links. It's getting the "current post" from the last item in my widget. Then, when it actually displays a single post in the center column, it gets that post right, and of course, the Middle (or Bottom) Prev/Next nav links are fine.

If this is unclear, go to summitsips.com and click the last thumbnail on the left sidebar in the widget that has the title "Kentucky Bourbon Trail". This takes you to a post from 2/13. It's this post that seems to be referenced for the Top located Prev/Next navigation links (when I turn them on) for all single post pages. Is there a way to fix this by maybe walling off my widget so that it doesn't rob the theme of what it thinks is the current post? Maybe some surrounding code that puts the current post in a placeholder beforehand, then returns it after the widget is done? Just thinking "out loud". I'd rather not abandon my widget, but I suspect it's confusing ATA with a second "loop" on the page.
  #2  
Old Sep 10, 2010, 04:01 AM
juggledad's Avatar
juggledad
 
23,647 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you take the widget out, does it fix the issue?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Sep 10, 2010, 06:55 AM
studiohanson
 
27 posts · Apr 2010
Yes, it does. Sloppy plugin coding?
  #4  
Old Sep 12, 2010, 07:22 PM
juggledad's Avatar
juggledad
 
23,647 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Possibly or just a conflict that means you won't be able to use it with Atahualpa.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Top and Bottom Widget Images With Widgets in Middle and Two Side by Side littlered03 Sidebars & Widgets 2 Jul 18, 2010 08:10 AM
My sidebar color doesn't match my menu or header. How do I make it? jakeyt Sidebars & Widgets 7 Mar 17, 2010 02:27 PM
Parent Pages Top Navigation Bar, Subpages coastal Page & Category Menu Bars 4 Jan 11, 2010 10:16 PM
How to have a space before top menu navigation UKTS Header configuration & styling 1 Sep 20, 2009 12:09 PM
[SOLVED] Navigation OK at bottom but erroneous at top ardee New Versions, & Updating 2 Jul 15, 2009 03:03 PM


All times are GMT -6. The time now is 10:46 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.