Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Oh no! I've lost my foot!


  #1  
Old Mar 21, 2009, 06:10 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
I'm putting this here instead of the footer area so more people will see it. I have a feeling this could affect other people who try to modify the theme's files instead of just using the theme options.

I just looked at the bottom of my front page, and the footer is gone! The source code shows this as the last bit on the page:
Code:
<!-- Footer -->
		<td id="footer" colspan="3">	
<center>
That's it. Nothing after the center tag, yet the page displays fine except for the copyright and powered-by text.

I must have somehow ruined this while modifying index.php or bfa_header, at some point. I can't easily find out what I did. Flynn, does the missing part give you a clue as to where I should look? I suppose I could just overwrite the modified files with the clean originials, but I would really like to know what I did wrong.
  #2  
Old Mar 21, 2009, 10:31 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
You should have

PHP Code:
<?php get_footer(); ?>
as the very last thing in index.php
  #3  
Old Mar 21, 2009, 11:05 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Thanks, but no! That was fine.

I went and looked at footer.php. I found this:

Code:
<!-- Footer -->
		<td id="footer" colspan="<?php echo $cols; ?>">	
<center><?php echo adrotate_banner('1'); ?></center>
		<p>
		<?php echo bfa_footer($bfa_ata_footer_style_content); ?>
		</p>
		<?php if ($bfa_ata_footer_show_queries == "Yes - visible") { ?>
		<p>
		<?php echo $wpdb->num_queries; ?><?php _e(' queries. ','atahualpa'); ?><?php timer_stop(1); ?><?php _e(' seconds.','atahualpa'); ?>
I compared the file to the original footer.php, and that's not there, of course. Wow. I had installed adrotate, a plugin, and I guess I was told to put that code in footer.php. I had deactivated the plugin a while back, but of course didn't remember to change footer.php back. Whew! All is well now.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lost the ability to post Kathy Griswold Sidebars & Widgets 1 Jul 12, 2009 07:11 PM
Lost settings jim New Versions, & Updating 12 May 28, 2009 08:18 AM
Lost Right Sidebar crashley1784 Sidebars & Widgets 2 May 23, 2009 10:54 AM
I've lot my foot again, because of a bad widget? paulae Sidebars & Widgets 10 May 6, 2009 07:05 PM
Can this theme get hacked? lost all my traffic in one day! Trish Atahualpa 3 Wordpress theme 2 Apr 6, 2009 04:06 PM


All times are GMT -6. The time now is 07:45 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.