Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

Positioning the header icon (?)


  #1  
Old Aug 8, 2010, 09:00 AM
GrahamW
 
101 posts · Jul 2010
I apologise. I can't believe that this hasn't been asked before, but I can't actually find it in a search of the forums.

I have a draft site (http://www.gbw247.info/rlsssurrey2/) and have managed to get the title and strapline to appear in the middle of the header images area. However, I can't seem to find a way of getting the header icon (wp-content/themes/atahualpa/images/lsavers2.gif) to display itself in the same box but to the left of the title and inside the block framed 'box'.

Any help would be hugely appreciated.

Many thanks
Graham.
  #2  
Old Aug 8, 2010, 09:25 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
put your image name at ato->Style & edit HEADER AREA->Style & edit HEADER AREA then make sure to add %logo to ato->Style & edit HEADER AREA->Configure Header Area

There is a thread - HOWTO: overlay the LOGO on the Header Image - in the 'Gold Forums Tutorials' you may be interested in.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Aug 8, 2010, 05:33 PM
GrahamW
 
101 posts · Jul 2010
Thanks, but I did all of those things, and ended up pulling them again because the logo seemed to go everywhere but where I wanted it. I've added them in again, so you can see what I mean.

I really have been trying all kinds of options for two days and still have no success.

Any advice much appreciated. Cheers, Graham.
  #4  
Old Aug 8, 2010, 07:49 PM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I think the tutorial is just what you need
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Aug 9, 2010, 06:12 AM
GrahamW
 
101 posts · Jul 2010
Quote:
Originally Posted by juggledad
I think the tutorial is just what you need
Thank you. I think you are assuming that people have arrived here via a specific route that might make them aware of the 'tutorial'. I got here through a Google search - there were no intermediate steps. When I visit the homepage for the theme there is no reference to 'gold' or 'tutorials'. I realise it must be frustrating to you to have to answer questions from people who don't appear to have done their own research, but if resources are hidden from them it isn't surprising that they don't know anything about them.

Please provide a link to the 'tutorial' and I will gladly visit and experiment.

Regards, Graham.
  #6  
Old Aug 9, 2010, 08:18 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
This site is broken into several sub forums to make it easier for people to find information/solutions to an issue in a particular area they may have with the Atahualpa theme.

One of the additional forums is the Gold Forums, where members who have donated $20 or more can ask questions and get prompter response. In addition, gold members have access to some tutorials that have been written on a number of topics.

In addition there is a Diamond forum for members who have donated $100 or more. Donations help encourage the continued development and support of this theme.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Aug 9, 2010, 05:13 PM
GrahamW
 
101 posts · Jul 2010
Thank you. Donation made. Best wishes, Graham.
  #8  
Old Aug 10, 2010, 07:12 PM
GrahamW
 
101 posts · Jul 2010
I'm afraid I am still having trouble getting this fairly simple layout to work....

www.life-saving.net

The logo (header icon) isn't in the header titles box.
The logo and the box aren't aligned.
I can't seem to split the title text into two lines.
I can't seem to lengthen the title box

As before, any help would be much appreciated.

Many thanks, Graham.
  #9  
Old Aug 11, 2010, 05:43 PM
GrahamW
 
101 posts · Jul 2010
Don't suppose anyone can help can they? I followed the tutorial and it had some effect, but there's still several things not working as I'd expect them to.

Many thanks
Graham.
  #10  
Old Aug 11, 2010, 09:01 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
This should give you a start. Just put all of this in the Style box at the bottom of ATO>Header Image.
HTML Code:
margin-top: 30px;
margin-left: 30px;
width: 460px;
height:80px;
padding: 7px 7px 7px 80px;
border: solid 2px #000000;
-moz-border-radius: 7px;
-khtml-border-radius: 7px;
-webkit-border-radius: 7px;
border-radius: 7px;
background: #fff url(http://www.life-saving.net/wp-content/themes/atahualpa/images/lsavers2.gif) no-repeat 5px center;
If you set opacity to this your image will be affected. That may work OK if you don't have the opacity set to high. For this example I just have a white background. You will have to play with the width depending on your text. You can get the text to wrap my just reducing the width of the box.

I forgot to add that you probably should set the width of your layout to 980px in ATO>Style & Configure Layout for a better look to your header.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #11  
Old Aug 12, 2010, 05:01 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Graham, I don't think Larry noticed you are using the 'overlay logo on header image' tutorial, so ignore his post -

The CSS inserts you copied from the tutorial has to be tweaked fur each situation, depending on where you want the logo to be. You have added a
HTML Code:
div.logooverlay {
	z-index: 4;
	position: relative;
	float: left;
	width: auto;
	margin-top: 35px;
	margin-left: 10px;
	}
now you want to change teh margin-top and margin-left values to re-position your logo where you want it. Try changing the margin-top to '12px'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Aug 12, 2010, 07:01 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Sorry about that. The overlay logo on header image works great.

I did have to use a negative left margin for the Title overlay CSS in ATO>Header Image and a z-index of at least 5 on the logo overlay CSS in ATO>Add HTML/CSS Inserts>CSS Inserts but now you can have the opacity.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #13  
Old Aug 12, 2010, 08:13 AM
GrahamW
 
101 posts · Jul 2010
Ah ha! Thank you both very much. I've obviously learned a lot both about this superb theme and also about the support process which will hopefully mean I don't need to ask as many silly questions in the future.

In the end, I stripped out all the changes made by following the Tutorial and, instead, implemented the settings given by Miles. It works perfectly.

Out of interest, is there a way of forcing line-breaks at all, other than changing the space available to them by shortening boxes etc? It might be a useful trick for the future.

Many thanks again.
Graham.
  #14  
Old Aug 12, 2010, 08:28 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I know of no way to do that for the blog title short of creating a logo with text and turning off the display of the Blog Title and Tagline.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Positioning widget onto logo area creates extra spacing in the overall header area cab262 Header configuration & styling 1 May 20, 2010 01:14 PM
header and positioning elements (absloute vs relative) lambdaka Header configuration & styling 6 Apr 14, 2010 08:51 AM
Overlaying & Positioning the ATA Search Bar over a replacement header YOU created? rhythm Header configuration & styling 8 Mar 9, 2010 11:12 AM
CSS Positioning sleizure Center area post/pages 0 Dec 27, 2009 02:40 PM
If I Leave The Logo Image Field Blank, It Displays Broken Image Icon in Header psaltriparus Header configuration & styling 1 Oct 20, 2009 09:30 AM


All times are GMT -6. The time now is 12:15 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.