Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Comments, trackbacks & pings »

[SOLVED] Comments: date and time completely messed up ...


  #1  
Old Jul 28, 2010, 04:12 AM
hlietz
 
45 posts · Jan 2010
I'm using Atahualpa 3.5.3 and WP 3.0
In the comments date and time are completely messed up (see attached file).
Could it be a problem with qTranslate? Is there a fix for that?
Attached Thumbnails
Click image for larger version

Name:	Comments_messed_up.png
Views:	863
Size:	28.6 KB
ID:	640  
  #2  
Old Jul 28, 2010, 06:33 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I just installed qTranslate and got the same results so I started poking through the settings an found if you go to Advanced Setting and set Date / Time Conversion to "Use strftime instead of date" the problem goes away. I'm not sure what else this will affect but it's a start.

In situations where a particular plugin may be at fault:
  1. Deactivate the plugin
  2. Test - if problem is still there you know it's not the plugin. If problem is not there go to step 3
  3. Reactivate the plulgin and start playing with the settings.
If you can't eliminate the problem within the setting you may have to use another plugin.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #3  
Old Jul 28, 2010, 08:24 AM
hlietz
 
45 posts · Jan 2010
Thanks for the hint. It's definitely a qTranslate issue.

The problem ist that, when settings in qTranslate are changed as proposed by you, the comment area is showing correctly, but in the blog itself the date is not showing any more (see attached file).

So it's not a solution ...

The problem is (or might be) that in Atahualpa in "edit post/page info items" many things (footer multi post pages, footer single post pages etc.) can be styled but NOT the footer of comments where the date appears. I'm not a specialist at all, but that could be a "missing feature".
Attached Thumbnails
Click image for larger version

Name:	Blog_wrong_date.png
Views:	617
Size:	19.8 KB
ID:	642  
  #4  
Old Jul 28, 2010, 08:53 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I saw the same thing so I just changed that same setting to:
Use strftime instead of date and replace formats with the predefined formats for each language.
and the date is now good in both places for me.

Addendum: I just saw that all I get now is the time.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Last edited by lmilesw; Jul 28, 2010 at 09:00 AM. Reason: Update
  #5  
Old Jul 28, 2010, 09:12 AM
hlietz
 
45 posts · Jan 2010
Yes, I tried all these settings, too. As you mentioned the setting "Use strftime instead of date and replace formats with the predefined formats for each language" results in showing the time only (no date).

So, no perfect solution yet ...

Other ideas?
  #6  
Old Jul 28, 2010, 09:29 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I found a thread on this forum with a solution. I just edited the English Language and deleted the content of the Date and Time fields and all started working.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old Jul 28, 2010, 09:36 AM
hlietz
 
45 posts · Jan 2010
Sounds great! What exactly do I have to "edit" and "delete"? I'm not so familiar with coding ...
  #8  
Old Jul 28, 2010, 09:55 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You go into the qTranslate settings and click on edit next to the language in question and delete anything in the Date Format or Time Format fields.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #9  
Old Jul 28, 2010, 11:27 AM
hlietz
 
45 posts · Jan 2010
Works! Perfect. Thank you!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
date / time link in comments janey73 Comments, trackbacks & pings 15 May 7, 2010 06:38 PM
How do I correct the date and time on my page? lmt Center area post/pages 1 Feb 11, 2010 06:13 AM
Date is all messed up in comment section using Dutch locale! Taquoriaan Languages & Translations 6 Feb 3, 2010 06:26 AM
[SOLVED] Messed-up Date jdtfk Languages & Translations 2 Feb 2, 2010 07:46 AM
Help! Posts and Fonts completely messed up NDN Installing & running WordPress 3 May 15, 2009 08:06 PM


All times are GMT -6. The time now is 02:21 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.