Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Why not X-UA-Compatible : IE=8?


  #1  
Old Jul 17, 2010, 12:37 PM
mdmower's Avatar
mdmower
 
76 posts · Jul 2010
Missouri, USA
Why is X-UA-Compatible set to EmulateIE7? At least one widget I use with this theme renders ugly unless I change the meta tag in header.php to use IE8 rendering. As it doesn't harm backwards compatibility with IE7, why not specify IE8 instead?

header.php
Code:
<meta http-equiv="X-UA-Compatible" content="IE=IE8" />
  #2  
Old Aug 9, 2010, 06:37 PM
Eric Bobrow
 
70 posts · Jan 2009
I had the same question. I substituted IE8 based on what you wrote, and all seems well. It would be good to hear from Flynn or Juggledad if there is some reason why Atahualpa isn't set for IE8.
  #3  
Old Aug 13, 2010, 06:03 AM
Dark_Fox
 
7 posts · Aug 2010
Scotland
Quote:
Originally Posted by mdmower
Why is X-UA-Compatible set to EmulateIE7? At least one widget I use with this theme renders ugly unless I change the meta tag in header.php to use IE8 rendering. As it doesn't harm backwards compatibility with IE7, why not specify IE8 instead?

header.php
Code:
<meta http-equiv="X-UA-Compatible" content="IE=IE8" />
Why not just remove the code completely, it has the same effect as changing it.
  #4  
Old Aug 13, 2010, 06:45 AM
juggledad's Avatar
juggledad
 
23,571 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
That line is there because of the problems IE8 can (and has) cause(d) with sites. With the vast number of plugins and combinations of plugins, problems in IE8 crop up )if there weren't problems, why would MS have created it?) so Atahualpa puts that line in to prevent (some of) them.

Hopefully, someday MS will release a browser that works with the same standards as the other browsers (or get out of the browser business).

However, if your site renders properly with that line removed, then remove it.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Aug 13, 2010, 09:40 AM
mdmower's Avatar
mdmower
 
76 posts · Jul 2010
Missouri, USA
I promise not to turn this into a flame, but would like to express one point.

EmulateIE7 was introduced 2 years ago with the purpose that websites could temporarily allow their site to render as they expect in IE8. It was (and still is) expected that developers work towards making their sites IE8 compatible so the tag is no longer needed.

As developers for Wordpress plugins and themes have been working with IE8 for two years now, it seems that the default option should be for IE8 rendering, with EmulateIE7 being something that users of severely outdated plugins would need to add themselves.

EmulateIE7 actually does harm the rendering of some plugins written to be compatible with IE8, and so I'd venture to say that keeping this tag is hurting anyone who keeps their website up to date (even if only once to twice a year).
  #6  
Old Aug 13, 2010, 09:59 AM
juggledad's Avatar
juggledad
 
23,571 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you edit header.php, you can take it out. While I agree two years should be enough time for developers to have updated their plugins, it seems lots get abandoned, but still work and are used. And look at the number of users still using ie6 and ie7 - 17%!!!

I'll suggest to the developer, that an option be added to let you decide to remove it or not
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Sep 24, 2010, 07:35 AM
Faffe
 
22 posts · May 2010
Sweden
I would like that option very much. Found out today that NGG-imageflow breaks on IE8 because of that tag.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
WordPress 3.0 compatible? Ber|Art Atahualpa 3 Wordpress theme 2 Jun 15, 2010 06:04 PM
NOTE: 3.4.8 theme settings not backward compatible juggledad New Versions, & Updating 1 May 8, 2010 12:44 PM
Is the Facebook Like Box compatible with Atahualpa? adum Sidebars & Widgets 5 Apr 27, 2010 12:34 PM
What are the the best, most compatible plugins to use with atahualpha? zeppelin Plugins & Atahualpa 2 Nov 22, 2009 06:54 AM


All times are GMT -6. The time now is 01:09 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.