Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Removing page name from page body


  #1  
Old Jul 4, 2010, 08:47 AM
billmaya
 
1 posts · Jul 2010
Brand new Wordpress 2.9.2/Atahualpa v3.4.9 user. I'm trying to remove the page name from the body of my pages like this user but, due to my limited HTML/CSS/PGP experience, I don't know where to put the "body.page .post-headline {display:none;}" CSS.

If someone gets a minute, could you help me out by giving me some more detailed steps (1, 2, 3,...) for adding this CSS to my site via the Atahualpa Theme Options page (or whatever page you use).

Thanks in advance.

Update: Put "body.page .post-headline {display:none;}" into the style.css file but that didn't seem to work. Also read this page but I'm not sure where the PHP code should go.

Last edited by billmaya; Jul 4, 2010 at 10:02 AM.
  #2  
Old Jul 4, 2010, 01:37 PM
Velma
 
272 posts · Feb 2009
With Ata 3.49 you should be able to go into the post itself and make changes for that.

When you do a full edit of the page, below the text area you should see a check box "Check to NOT display the Body Title on Single Post or Static Pages".

Simply check that and your Page Title will not show anymore.

Hope that help!

Velma
  #3  
Old Jul 4, 2010, 05:28 PM
Craig Atkinson's Avatar
Craig Atkinson
 
53 posts · Mar 2009
Ata 3.5.1 Wp3.0
There is no box any more to tick to avoid the title. Is there a better way I can do this? I want static pages to be without a title.
  #4  
Old Jul 5, 2010, 10:51 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
That is now a selectable choice in ATO>Configure SEO>Use Post / Page Options but be aware you may see the "Auto Draft" bug show up. To fix that see below from another post on this forum. You may want to apply the fix before selecting yes to Use Post / Page Options. Before making the change below you might want to download a copy of the functions.php just in case you goof when putting in the changed code.

************************************************** ****************

To skip with save it as 'Auto Draft', you can make a little modification on the ata's function.php to remove that 'Auto Draft', the funny title will be gone as wished, but this data still create on the db table.

In template_dir/functions.php at about line 603 look for the line that begins the same as the following and change it to:

$title = ($post_id->post_title !== 'Auto Draft') ? $post_id->post_title : '';



The line you are changing is right after
$thePostID = $post->ID;
$post_id = get_post($thePostID);
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #5  
Old Sep 27, 2010, 11:13 AM
webanalytiker
 
1 posts · Sep 2010
Hi

I have tried getting ried of the page name as well, and still dont now how to do it. I am using 3.4.9 and the adjustment mentioned does not seem to remove the headline.

Please help me...
  #6  
Old Sep 27, 2010, 05:24 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I don't think 3.4.9 has the option of turning off the page title. You would have to upgrade to Atahualpa 3.5.3 to have that option. I recommend the manual method as outlined in the FAQ thread.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #7  
Old Oct 6, 2010, 11:21 AM
teraines
 
2 posts · Oct 2010
Not seeing that check box on the page editor. What version of wordpress has that? (I'm using 3.0.1) Under my text box for full page editing, there is only "Custom Fields", "Discussion", "Comments", "Authors" and "Revisions" areas... none have an option to turn off page name in the body of the page itself.
  #8  
Old Oct 6, 2010, 12:48 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
It's version 3.5.3 of Atahualpa and then you have to turn on the Post/Page Options in ATO>Configure SEO
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #9  
Old Oct 10, 2010, 03:15 PM
dhallowell19
 
1 posts · Oct 2010
In earlier versions of Atahualpa I have been able to remove the "Home" link/title in my Home page.
Now, in 3.5.3 I've tried both methods that I know about:
- Editing the code in the main loop in ATO>Syle and Edit Center Column ... as posted elsehwhere here... to
<?php if (!is_page()) {bfa_post_headline('<div class="post-headline">','</div>');


For some reason that didn't work.... so then I tried using turning on the SEO options and checking the box NOT to display the body title on the Home page -- and -- somehow THAT didn't work either.

I haven't been stuck like this before -- but something is going on ... and while I'm at it, I'd like to remove the date that shows on my home page by default as well.

This is a great forum -- my first post -- but hoping to find a fix on this one - I do appreciate any help.

Dave
  #10  
Old Oct 10, 2010, 05:17 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
Are you talking about removing the menu item called Home or removing the Title of the Post/Page?

To remove the date look in ATO>Edit Post/Page info items
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #11  
Old Dec 3, 2010, 12:21 PM
roamtech
 
8 posts · May 2010
London UK
Hi,
we too had been trying to remove the Page Title from the top of the Body of the Post and have found the following simple solutions.

Solution 1) Create a Category titled as you want, add to the Menu Bar, using the WP 3.0.1/2 Appearance>Menu Option. Here 'Categories' can be used in the same way as 'Pages' to create a MENU.

Solution 2) Better! Go to WP>Appearance>Atahualpa Theme Options>Post & Pages>Style POSTS & PAGES>HEADLINE Box: Text. Change to:= font-size: 0.0em and color:#ffffff (color change is due to some browsers showing "- -" in place of title.
(Have yet to try removing ALL style information.)

Result no Page Title at top of Pages.

roam
  #12  
Old Dec 3, 2010, 04:03 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
In Atahualpa 3.5.3 you can go to ATO>Configure SEO and select Yes of Use Post/Page Options. Then in each post or page there is a checkbox that allows you to not show the title.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing Page titles in single pages with out removing post titles robertbrand Atahualpa 3 Wordpress theme 7 Jun 21, 2011 11:33 AM
Removing page name from Body. Also, adding links into Footer OrganicAnalyticsNow Atahualpa 3 Wordpress theme 19 Feb 23, 2010 01:46 PM
[SOLVED] Removing Page title from top of page - using 3.4.1 Loungefly Post-Kicker, -Byline & -Footer 7 Dec 24, 2009 06:47 AM
Removing page title from static front page in 3.41 or 3.42? whomadewho New Versions, & Updating 2 Jul 13, 2009 11:54 PM
Removing a Page Title from the Displayed Page strangelove Atahualpa 3 Wordpress theme 1 Feb 25, 2009 11:32 AM


All times are GMT -6. The time now is 03:09 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.