Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

[SOLVED] Why do children items have parents hover color.


  #1  
Old Jun 27, 2010, 04:37 PM
FlippinSweet
 
5 posts · Jun 2010
Quote:
Originally Posted by Grum
It's in the page menu bar at the top - when you mouse over the two items that have sub-menus and run down the list, you get white space appearing to the right of some of the menu items.

**update - I just managed to solve this by increasing the width of the width of the sub menus from 11 to 14.
I agree, changing the width of the submenus (and of course replacing the bfa_hor_pages.php code provided by Juggledad) fixes this issue in Firefox but MSIE 8 still has an issue.

To Test: Using MSIE 8 try clicking on the main tab of a menu item with subcategories so that the main tab is selected. Wait for the page to refresh. Now mouse over that same menu item tab. All of the items in the submenu have changed to the mouseover color and even the mouseover color doesn't extend all the way to the right of the submenu, leaving a gap. This time the gap is not white but is the original non-moused-over submenu color.

If you mouseover the actual subitems it seems it works correctly and extends the mouseover color properly, it is just that the subitems are already the mouseover color!

SUMMARY: The animated menus seem to work fine in MSIE 8 as long as you are not mousing over submenu items in a selected tab.

I'm disappointed that MSIE isn't supported better (no rounding, the outer main box gray shading is missing, etc...) I know the general reasons why this is the case, but nonetheless it can't be disputed that MSIE more than triples Firefox in visitor hits (I have my own stats to prove it).

But in any case, this is a great theme and I hope to be able to solve some of these issues and make it work!
  #2  
Old Jun 27, 2010, 06:24 PM
juggledad's Avatar
juggledad
 
23,626 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
As soon as msie starts supporting the css3 you see lots of the issues like rounding corners go away. All other browsers support the CSS for rounding but IE which is why most (if not all) haye it because of the contortions needed to made sites look good in ie

It really has nothing to do with the theme
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jun 27, 2010, 09:35 PM
FlippinSweet
 
5 posts · Jun 2010
Quote:
Originally Posted by juggledad
As soon as msie starts supporting the css3 you see lots of the issues like rounding corners go away. All other browsers support the CSS for rounding but IE which is why most (if not all) haye it because of the contortions needed to made sites look good in ie

It really has nothing to do with the theme
Any thoughts on the MSIE 8 animated menu glitch I described? Are you able to reproduce it?

Thanks for your reply
  #4  
Old Jun 28, 2010, 08:13 AM
FlippinSweet
 
5 posts · Jun 2010
Quote:
Originally Posted by FlippinSweet
Any thoughts on the MSIE 8 animated menu glitch I described? Are you able to reproduce it?

Thanks for your reply
Actually, this is happening with FireFox 3.6.6 as well. If you click on a main tab that has submenu items, wait for the page to refresh, then mouse over the main tab again, all of the submenu items change to the mouseover color.

So the only difference between MSIE 8 and FireFox 3.6.6 is that with MSIE the color only extends to the right as far as the submenu text, on FireFox it extends fully to the right. Either way the entire submenu shouldn't be changing to the mouseover color when only mousing over the main tab.

Can anybody else confirm they are seeing this? This is with Juggledad's patch (1st message in this thread) installed.

Just to be clear:
WordPress 3.0 (only the Akismet plugin installed, nothing else)
Atahualpa 3.5.1
Apache 2.2.15
PHP 5.2.13

Thank you!

Last edited by FlippinSweet; Jun 28, 2010 at 11:32 AM. Reason: typo: changed should to shouldn't
  #5  
Old Jun 28, 2010, 08:42 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
That has been an something I've noticed for sometime even on earlier versions of Atahualpa and haven't been able to figure out the selectors to change. If you set the top level menu item to not be a link it is not an issue.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Jun 28, 2010, 10:27 AM
juggledad's Avatar
juggledad
 
23,626 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
FlippinSweet - please do an export of yout style (ATO->Export/Import Settings->Export) and attach them to a reply so I can test with your settings
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Jun 28, 2010, 11:36 AM
FlippinSweet
 
5 posts · Jun 2010
Quote:
Originally Posted by juggledad
FlippinSweet - please do an export of yout style (ATO->Export/Import Settings->Export) and attach them to a reply so I can test with your settings
I've attached. Renamed the file for privacy. Thank you!
Attached Files
File Type: txt ata-wwwwebsitecom-20100628.txt (27.7 KB, 492 views)
  #8  
Old Jun 28, 2010, 11:56 AM
juggledad's Avatar
juggledad
 
23,626 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
(this has nothing to do with the bugfix, so I've moved it to a new thread)

Oh, that's now a bug, that is the CASCADING in CASCASING STYLE SHEETS
a menu with sub pages looks like this
<ul>
<li class='menu1'> menu1 </li>
<li class='menu2'> menu2 </li>
<ul>
<li class='child1'> child1 </li>
<li class='child2'> child2 </li>
</ul>
<li class='menu3'> menu3 </li>
<li class='menu4'> menu4 </li>
</ul>

If you used the following css
HTML Code:
ul {background: red;}
all the menu items would be red. If you add
HTML Code:
ul {background: red;}
ul li.menu2 {background: blue;}
menu1, 3 and 4 would be red, but menu 2, child1 and child2 would be blue. If you wanted child1 and child 2 to be red, you would have to add
HTML Code:
ul {background: red;}
ul li.menu2 {background: blue;}
ul li ul {background: red;}
(you might have to add an !important to this last one.

so to change the children to th original hover color, you muse have more css at that level.

The menu CSS is the most complex of the page - over 400 lines of code.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jun 28, 2010 at 11:59 AM.
  #9  
Old Jun 28, 2010, 12:04 PM
FlippinSweet
 
5 posts · Jun 2010
Thanks Juggledad. That looks like something better left to the developer, but thank you for the explanation. For now I think I'll just set "Don't link first level parent items in Page Menu Bar?" to yes. This fixes everything other than the hover color extending all the way to the right on submenu items in MSIE 8.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Hover color not working properly in IE BradBrown Page & Category Menu Bars 5 Sep 23, 2009 09:10 PM
How to make Current page color different than Hover color? 25jai Page & Category Menu Bars 7 Jul 17, 2009 05:06 AM
Table changes color/highlights with mouse hover. How do I stop it? InviteStory Atahualpa 3 Wordpress theme 2 Apr 24, 2009 12:05 PM
Color of children of current page in menu BradBrown Page & Category Menu Bars 0 Mar 22, 2009 02:38 PM
Change hover color in body of post HalfWayThere Atahualpa 3 Wordpress theme 6 Feb 18, 2009 02:56 PM


All times are GMT -6. The time now is 09:41 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.