Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

Category Menu - posts don't display


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jun 15, 2010, 03:00 AM
qbuster's Avatar
qbuster
 
84 posts · Mar 2010
Alrewas, Staffordshire, UK
I have a live site and a test site. Both are running Atahualpa 3.5.1 and Buddypress on the latest build of WP 3.0-RC3 on a webhost running Linux.

The category menu on the test site http://waterwaywatch.org/wordpress/ displays the appropriate posts.

The same menu on the live site http://waterwaywatch.org invokes a 404.

On both sites the POSTS option on the page menu produces the correct result.

The wp-config.php, htaccess and permalinks on both sites are essentially the same. Can anyone give me some ideas as to what is preventing the live category menu from working?

Thanks in advance
  #2  
Old Jun 15, 2010, 03:21 AM
juggledad's Avatar
juggledad
 
22,104 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
it's your permalinks. if you look at the link for 'Waterway news'
on 'http://waterways.org/wordpress' the link is 'http://waterways.org/wordpress/category/waterway-news'
but on 'http://waterwaywatch.org' it shows as 'http://waterwaywatch.org/%20/watch-news'
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #3  
Old Jun 15, 2010, 06:26 PM
qbuster's Avatar
qbuster
 
84 posts · Mar 2010
Alrewas, Staffordshire, UK
Quote:
Originally Posted by juggledad
it's your permalinks. if you look at the link for 'Waterway news'
on 'http://waterways.org/wordpress' the link is 'http://waterways.org/wordpress/category/waterway-news'
but on 'http://waterwaywatch.org' it shows as 'http://waterwaywatch.org/%20/watch-news'
I'd wondered about that - I mean what is a space doing in there?

But I just double-checked and both sites are showing the same permalink settings, i.e. Day and Name.

As a test I changed both to Month and Name and added new posts - selecting options from the category menu on the test site http://waterways.org/wordpress shows all posts, but http://waterways.org invokes a 404.

Any other ideas?

Thanks for your input.

Will
  #4  
Old Jun 16, 2010, 04:00 AM
juggledad's Avatar
juggledad
 
22,104 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I assume that you meant http://waterwaywatch.org instead of http://waterways.org right?
http://waterwaywatch.org now returns a blank page
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #5  
Old Jun 16, 2010, 05:07 AM
qbuster's Avatar
qbuster
 
84 posts · Mar 2010
Alrewas, Staffordshire, UK
Quote:
Originally Posted by juggledad
I assume that you meant http://waterwaywatch.org instead of http://waterways.org right?
http://waterwaywatch.org now returns a blank page
Whoops! Sorry about that. The two sites are http://waterwaywatch.org/wordpress/ (the 'test site') and http://waterwaywatch.org ('live site').

The blank page was temporary whilst I did some tweaking. Should be live now.
  #6  
Old Jun 16, 2010, 05:27 AM
juggledad's Avatar
juggledad
 
22,104 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
What htaccess files exist in the site in each folder up to the root?
__________________
If you like my help, please consider donating. I am happy to provide greater detail on this and other topics if you hire me. Please send detailed support requests to me as a private message, thank you.
Juggledad | Forum Moderator/Support
  #7  
Old Jun 16, 2010, 07:10 AM
qbuster's Avatar
qbuster
 
84 posts · Mar 2010
Alrewas, Staffordshire, UK
Quote:
Originally Posted by juggledad
What htaccess files exist in the site in each folder up to the root?
In the roots we have:


Code:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wordpress/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpress/index.php [L]
</IfModule>
# END WordPress
Others deeper into the directory structure are related to backups, etc.

Bookmarks

Tags
buddypress, category menu, wp 3.0

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
%category-linked% bug? It don't display the first assigned category for a post. conon Post-Kicker, -Byline & -Footer 2 Mar 30, 2010 04:59 AM
[SOLVED] Links don't show up on Posts in Category view nick51 Center area post/pages 2 Mar 23, 2010 01:53 PM
[SOLVED] Category / Archive display problem with category menu bar madfab685 Page & Category Menu Bars 4 Jan 2, 2010 04:12 AM
how to horizontally display the Category Posts Widget ? bryan85 Plugins & Atahualpa 0 Sep 6, 2009 06:28 PM
Posts don't display in center column DUhlig Atahualpa 3 Wordpress theme 3 Aug 14, 2009 03:52 AM


All times are GMT -6. The time now is 01:00 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.