Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] Atahualpa 3.4.6 & Fancybox for Wordpress - does not display in IE


  #1  
Old Apr 19, 2010, 04:52 AM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
Hi JuggleDad et al...
I have been trying to sort this for sometime. Fancybox for Wordpress was working beautifully and then stopped displaying in Internet Explorer. It only shows a window of about 1inch high. Check it out on http://ibooknewzealand.com/2010/nort...ern-discovery/ and click 'Auckland' for the popup.

If anyone else has Fancybox for WP working with Atahualpa 346 in IE, I would be glad to know.

I thought about putting this post in the 'Plugins' area, but the problem has only become apparent in this latest version of Ata.

Here are the steps I've taken to sort it. I thought it was another plugin so I've disabled all of them, but I realise now that it is my current version of Atahualpa.

Other themes (eg mystique, swift, default, classic) work with the Fancybox popups. Atahualpa346 displays the popups in all browsers - but not IE.

I thought it was to do with the HTML Inserts (listed below) so I took them out (& turned off cache).

<script src="http://ibooknewzealand.com/wp-includes/js/jquery/jquery.tools.min.js"></script>
<script>$(function() {$("ul.css-tabs:first").tabs("div.css-panes:first > div");});</script>
<span id=ycclink style='display:none'><a href="http://www.yourcurrencyconverter.com">geolocation - multi currency</a></span><script language=javascript>var curdate = new Date(); var datenum= curdate.getMonth()+'-'+curdate.getDay()+'-'+curdate.getYear(); var scriptstart = '<SCR'+'IPT '; var jslink = 'SRC=//server2.YourCurrencyConverter.com/ConvertCurrency.ashx?id=2892xymxuk55ohpbmvno4f2lqh 45x4&spoofCountry=XX&date=' + datenum; var scriptend = ' LANGUAGE=Javascript></SCR'+'IPT>'; var jsinclude = scriptstart+jslink+scriptend; document.write(jsinclude);</script>`

I thought it was because of the custom code (listed below) for breadcrumbs in the ATA Index.php file so I took it out & turned off cache.

`<?php
/* Wordpress Breadcrumbs*/
if ( !is_home() ) {
if ( is_single() ) {
echo "<div class=\"breadcrumbs\"> &raquo; ";
echo "<a href=\" ".get_settings('home')." \">";
echo bloginfo('name')."</a> &raquo; ";
echo $_SESSION['mycat'];
echo "</div>";
}
elseif ( is_archive() && !is_category() ) {
echo "<li>Archives</li>"; }
elseif ( is_search() ) {
echo "<li>Search Results</li>"; }
elseif ( is_404() ) {
echo "<li>404 Not Found</li>"; }
/* elseif ( is_page() ) {
if ($post->post_parent) {
$children = $post->post_title;
$parent = get_page($post->post_parent);
echo $parent->post_title. " &raquo; " .$children;
}
}*/
}
?>`

I haven't changed anything else, so I presume it must be to do with the javascript loading order, or something.

Any thoughts ?

Last edited by joan; Apr 19, 2010 at 05:07 AM.
  #2  
Old Apr 19, 2010, 03:28 PM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
Hey forget it, problem solved... not sure how, but I'm not arguing! Sorry for the unnecessary airspace.
  #3  
Old Apr 19, 2010, 03:33 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
What did you do? The FancyBox still isn't working for me in IE.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #4  
Old Apr 19, 2010, 08:16 PM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
Bummer Larry, it isn't working again for me too. It seems that it only works when I turn on IE's "Compatibility View" (under Tools), in which case it works beautifully. Strange that the other themes work ok though. Any thoughts ?
  #5  
Old Apr 20, 2010, 06:44 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I don't have an answer for you other than IE is at time problematic. I don't know why but I tried several of the modal box plugins like FancyBox and for some reason I can't remember decided not to use it. I currently use Shadowbox JS for this purpose along with modal popups for videos. It automatically will configure many links or you can use rel=shadowbox. This does require a license for commercial use but it is only $20 for a single developer on unlimited domains. You could just try it out though at no cost to see if it works in IE.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #6  
Old Apr 20, 2010, 07:16 AM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
Thanks Larry I'll give it a try. Meantime I found this:
""The issue is with the jQuery Block UI plug-in, not Fancybox. Apparently, "setExpression" causes IE8 to flip out. However, it looks like the newest version of jQuery BlockUI Plugin fixes this problem. ""
There is a download at http://malsup.com/jquery/block/#download but I'm not sure where to put the JS file.
Also I found this re fancybox/Ie problem:
"I ended up using prettyPhoto. Not only does it work, but it provides a much better API." with this link
http://www.no-margin-for-errors.com/...ightbox-clone/
I'll be in touch when I've sorted it. Joan.
  #7  
Old Apr 20, 2010, 07:36 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
The PrettyPhoto plugin looks interesting. I'm going to give that a try as well.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #8  
Old May 3, 2010, 06:49 AM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
It sure is interesting; infact PrettyPhoto works great. Check it out on any of my popups. Atahualpa css is somehow mucking the display of the PrettyPhoto's navigation bar at the bottom of the popup, in Internet Explorer (only, FF & Chrome work well). Unfortunately IE doesn't have any "inspect" tools for me to de-bug. Larry if you try it with Iframes in IE, I'd like to know how you go.
  #9  
Old May 3, 2010, 08:08 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Joan, here is how I would play with this.

Go view the page in question, then view the page source and copy the source and paste it into a wordpad document and save it as txt. Now open that file in IE and you should see your page.

now you can edit the txt file and save it and refreshe the page to see the changes. You can rip out vast chunks of the HTML and CSS to see if you can find the cause.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old May 3, 2010, 08:16 AM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
You site works fine for me in IE 8. On one of my sites however I did have a conflict between WP-PrettyPhoto and another plugin so for now I've gone back to Shadowbox JS.
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #11  
Old May 9, 2010, 12:41 AM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
Thanks so much JD & Larry
The problem was that the popup window's close button was not visible in IE (so hard to close!), but Ihave modified the prettyphoto.css file from
.pp_nav a.pp_arrow_previous,.pp_nav a.pp_arrow_next{display:block;float: left;height:5px;margin-top:3px;overflow: hidden;text-indent: -10000px;width:14px;}
to
.pp_nav a.pp_arrow_previous,.pp_nav a.pp_arrow_next{display:block;float: left;height:35px;margin-top:3px;text-indent: -10000px;width:14px;}

and all works great now. I especially like the way it has navigation buttons to scroll to the next/previous popup.
Again thanks for your time. JD can you mark this one as 'solved' (I cant seem to find how to.
Kind regards,
Joan

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Display Post Excerpts in Grid for Author, Search &amp;amp;amp;amp;amp; Category Rashell Excerpts, Read more, Pagination 2 Apr 9, 2010 09:29 AM
[SOLVED] Edit Wordpress Category Page to just display Post titles??? dennis wilson Excerpts, Read more, Pagination 8 Mar 3, 2010 04:52 PM
cant get fancybox to work in the newer versions of Atahualpa brandon New Versions, & Updating 3 Feb 1, 2010 02:44 PM
Comment display order doesn't work(Atahualpa 3.2 + Wordpress 2.7) bishop Comments, trackbacks & pings 2 Feb 19, 2009 01:11 AM


All times are GMT -6. The time now is 02:02 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.