Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Post-Kicker, -Byline & -Footer »

ATA "Sticky Footer" and plugin conflict


  #1  
Old Mar 23, 2010, 03:00 PM
kdawes01's Avatar
kdawes01
 
96 posts · May 2009
Missoula, MT
Hi,
I'm having a problem in a site I'm doing. I want to use the ATA Sticky Footer feature... And it works just fine... *Except* on a page where I am using the "(a)Slideshow" plugin. On the page with the slideshow the footer goes back to its "normal" spot.. I'm imagining it's a jquery conflict of some sort...

I'd offer the url, but I'm working on it behind the scenes using "Test Drive".

Thanks!

Ken
  #2  
Old Mar 23, 2010, 03:05 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what plugin - could you point to the download
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 23, 2010, 03:34 PM
kdawes01's Avatar
kdawes01
 
96 posts · May 2009
Missoula, MT
Hi Juggledad,
It's the (a)Slideshow or maybe it's (a) Slideshow ... It's in the WordPress.org plugin directory

Thanks!
Ken
  #4  
Old Mar 23, 2010, 04:28 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
can you provide the link?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Mar 23, 2010, 04:46 PM
kdawes01's Avatar
kdawes01
 
96 posts · May 2009
Missoula, MT
Sorry!
Here's the link to the plugin...
http://wordpress.org/extend/plugins/a-slideshow/

Ken
  #6  
Old Mar 28, 2010, 02:42 PM
kdawes01's Avatar
kdawes01
 
96 posts · May 2009
Missoula, MT
Sounds like no luck? I have also removed the plugin and used an embedded javascript image rotator and it has the same effect of making the footer "unsticky" Once either is removed the footer goes to the bottom of the screen.

I wish I could send you to the site to see... but as I said, my client doesn't want a "less than perfect" (her words) website seeing the light of day. I am using the "Theme Test Drive", so only someone logged in can see it.... I'd be happy to give you site access so you could see it for yourself... If there's a way to do it privately.

Please let me know!

Thanks!
Ken
  #7  
Old Mar 28, 2010, 05:15 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
send me a PM with the link
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Apr 1, 2010, 06:20 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I just tried this in both wp 2.9.1 and 2.9.2
in 2.9.1 the sticky footer works fine with the slide show
in 2.9.2 the sticky footer works fine with the slide show

if you are having a problem try deactivating your other plugins
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Apr 1, 2010 at 06:25 AM.
  #9  
Old Apr 1, 2010, 09:15 PM
kdawes01's Avatar
kdawes01
 
96 posts · May 2009
Missoula, MT
Hi Juggledad,
Thank you for taking a look.... but it doesn't seem to be plugins... and I'm way confused.

The site I inherited and have converted to ATA is way bloated with plugins... So I thought I'd be smart... I have done a fresh WP test install on my own website. It's at
http://www.the-web-mechanic.com/test06

All I have installed is WP 9.2 and ATA... and a mod to the function.php to allow shortcodes in pages (this is installed on the problem site as well). It's about as bare-bones as you can get!

I made a static front page... footer is "up" in the middle of the page- as expected

I set the ATA footer to "sticky" --- Goes right to the bottom of the browser.. perfect!

I add the content from the problem site the pictures and html in the page and the javascript in the custom field.

I go back to check the published page... poof! The footer is no longer sticky. Its gone back to the middle of the page...

I'm tearing my hair out here!

I have given you access to my test site(above) with the same user and p/w that I emailed you previously. I'd appreciate it if you could take another look.

Thanks so much!

Ken
  #10  
Old Apr 1, 2010, 10:12 PM
lmilesw's Avatar
lmilesw
 
10,174 posts · Jul 2009
Central New York State USA
I was scanning through this thread and wondered why you added a mod to the function.php for shortcodes in pages. I use shortcodes all the time in pages without any mods. Also does the sticky footer come back if you don't have the slideshow from the jutehome.com site embedded?
__________________
~Larry (CNY Web Designs)
This site should be a membership site since it so full of good stuff.
Please consider donating which gives you access to even more good stuff.
  #11  
Old Apr 2, 2010, 05:27 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Ok, you have two sites that you changed functions.php and it's a problem, I have two sites without any mod and it woks fine....hmmmm

Rename your functions.php, upload a fresh copy and see what happens
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Apr 7, 2010, 02:40 PM
kdawes01's Avatar
kdawes01
 
96 posts · May 2009
Missoula, MT
Hi,
Sorry to be slow to follow up with what happened...

Well, I have cured the footer problem... Though I'll have to admit that I don't totally get the "why".

Whether the the slideshow (either the plug-in or the javascript method) or ATA is the problem, the cure was to put a "height" on the image container (div).

There are 3 images on the page, all 374 px tall, and despite the images going into a slideshow that is the height of one image, the sticky footer moved to the bottom of the "body" instead of being sticky to the bottom of the browser unless the 3 images were put in a div with a 374px height. No height declaration, no sticky.

Once I gave the container a height of 374px, the sticky footer popped down to the bottom of the browser window and works as advertised.

I don't know the "why", just that it's now working!

Thank you so much for your help! Any explanation of what's going on?

Ken

Last edited by kdawes01; Apr 7, 2010 at 02:46 PM.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to remove the "Continue reading..." link from a sticky post taylorefl Forum How-To 3 Jan 18, 2010 02:57 PM
How to remove the "Continue reading..." link from a sticky post taylorefl Forum How-To 0 Jan 15, 2010 10:49 AM
Hide sticky ( title ) on "Recent post" sidebar nautilus Post-Kicker, -Byline & -Footer 0 Dec 19, 2009 06:41 PM
[SOLVED] footer - tried to, per instructions, edit footer links to "Woodpress" and ge jorgfoto Post-Kicker, -Byline & -Footer 2 Oct 15, 2009 11:57 AM
"Remove 2nd footer link to BFA" doesn't work Flynn Atahualpa 3 Wordpress theme 0 Dec 13, 2008 04:47 PM


All times are GMT -6. The time now is 10:19 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.