Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Can I push everything over?


  #1  
Old Mar 3, 2009, 05:21 PM
eyup
 
34 posts · Mar 2009
Hi there - awesome theme!

I'm wondering if i can push everything over to the right and insert a div with some flash in it?

I've emulated it here using frames (though I want it to scroll with the rest of the page):

http://www.shavenraspberry.com/home.html

(I also set the left column to 0)

Regards
  #2  
Old Mar 3, 2009, 05:35 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
To move both sidebars to the right see http://forum.bytesforall.com/showthread.php?t=168

Moving them to the left is almost the same if you look at the code. Let me know if you get stuck

You can insert Flash anywhere but would have to provide the embed code, there is no auto flash insertion or something like that in the theme
  #3  
Old Mar 3, 2009, 06:09 PM
eyup
 
34 posts · Mar 2009
Hi Flyn,

What i mean is can 'everything' be pushed over - the whole caboodle, so i can put a column of flash down the left side stretching from top to bottom?
  #4  
Old Mar 3, 2009, 06:36 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
In header.php, find
HTML Code:
<div id="container">
and below it, add:
HTML Code:
<div style="width: 100px; float: left;">

YOUR CONTENT

</div>
Change 100px to the desired width. Also add margin-right: XXpx if you want to have space between this column and the main layout

And in style.css, find
HTML Code:
table#layout {
    font-size: 100%;
    width: 100%;
    max-width: 100%;
    table-layout: fixed;
    }
and change to

HTML Code:
table#layout {
    font-size: 100%;
    table-layout: fixed;
    }
This style.css change will most likely be in version 3.2.1, so it would not be overwritten when you update Atahualpa

Last edited by Flynn; Mar 3, 2009 at 07:04 PM. Reason: Changed "This style.css" to "This style.css change"
  #5  
Old Mar 3, 2009, 06:43 PM
eyup
 
34 posts · Mar 2009
You the man Flyn - I'll give it a bash!
  #6  
Old Mar 3, 2009, 08:28 PM
eyup
 
34 posts · Mar 2009
Soo close:

http://www.shavenraspberry.com/roamer/

The Flash doesn't load - seems it can't find the swf file though it finds the jpg at the top.

something to do with permalinks?

I've put the flash file in the same directory as header.php too.

or is it something to do with Wordpress?
  #7  
Old Mar 3, 2009, 08:38 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
You're referencing the swf as
HTML Code:
embed src="roamer.swf"
Change to
HTML Code:
embed src="/roamer.swf"
I also noticed you're referencing various images and javascript i.e. as

HTML Code:
<img src="../../../../images/shaven-logo-menu.jpg"
I'd change those to absolute paths, beginning at your domain root

HTML Code:
<img src="/images/shaven-logo-menu.jpg"
or

HTML Code:
<img src="http://www.shavenraspberry.com/images/shaven-logo-menu.jpg"
  #8  
Old Mar 3, 2009, 08:55 PM
eyup
 
34 posts · Mar 2009
Hurrah - CHEERS Flyn - sorted!

Here's the embed stuff for other peeps (I've left a few tags around them so they'll know where it is):

AC_RunActiveContent.js is in a folder called 'Scripts' at root level.

Header code:

Code:
<?php echo ($bfa_ata_html_inserts_header != "" ? apply_filters(widget_text, $bfa_ata_html_inserts_header) : ''); ?>
<script src="../../../../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
</head>
<?php
My swf is in the root folder.


Code:
<div id="wrapper">
<div id="container">
<div style="width: 349px; float: left;"><img src="http://www.shavenraspberry.com/images/shaven-logo-menu.jpg" alt="" height="135" width="349" border="0" /><br />
  <script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','349','height','1180','src','/htdocs/roamer/wp-content/themes/atahualpa/roamer','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','/roamer' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="349" height="1180">
    <param name="movie" value="/roamer.swf" />
    <param name="quality" value="high" />
    <embed src="/roamer.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="349" height="1180"></embed>
  </object></noscript>
</div>
Thanks again Flynn (this is my 1st Wordpress site ;-)

Last edited by eyup; Mar 3, 2009 at 09:01 PM.
  #9  
Old Mar 4, 2009, 11:05 AM
eyup
 
34 posts · Mar 2009
Now here's a thing...

When I go to the Comments page:

http://www.shavenraspberry.com/roame...orld/#comments

the side Flash disappears.

Weird because the jpg is there - do I have to change something?

Regards,

Eyup
  #10  
Old Mar 4, 2009, 11:40 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
The path to the Javascript probably doesn't fit anymore once you're deeper inside the site

a path like "../../../..." will always break at some point in Wordpress if you're using permalinks

Change

HTML Code:
 <script src="../../../../Scripts/AC_RunActiveContent.js"
to

HTML Code:
 <script src="/Scripts/AC_RunActiveContent.js"
and change other "../../..." paths you may have as well
  #11  
Old Mar 4, 2009, 12:40 PM
eyup
 
34 posts · Mar 2009
Sorted!

(another small donation winging your way

All times are GMT -6. The time now is 08:08 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.