Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

[SOLVED] Exec-Php not working


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Mar 10, 2010, 08:18 AM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
Hi Juggledad
My site ibooktravel.com.au is new with all the latest versions of wp 2.9.2 & Atahualpa 3.4.6, as well as EXEC-php plugin but a simple `< ?php echo "Hello World"; ?>` displays as text and is not executed. I found a fix at : http://wordpress.org/support/topic/281992?replies=7 but although this is ok for the "hello world" code it makes a complete mess of `< ?php include ('http://ibooktravel.com.au/wp-content/plugins/front-slider/front-slider.php');?> ` leaving a page of error messages.
I looked for other solutions but couldn't find anything... I would greatly appreciate any valued suggestions you might have.
  #2  
Old Mar 10, 2010, 10:29 AM
juggledad's Avatar
juggledad
 
22,245 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
there is no space between the '<' and '?php' so
HTML Code:
< ?php echo "Hello World"; ?>
should be
HTML Code:
<?php echo "Hello World"; ?>
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 10, 2010, 06:19 PM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
OMG - sorry for being soo stupid! Thank you a million times over Juggledad!
  #4  
Old Mar 11, 2010, 12:13 AM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
Oh dear Juggledad,
Seems it's not as simple as my being stupid. Something is putting an extra space in the code every time I save the post. Seems to be one of Wordpress' native functions called force_balance_tags ... Somehow exec-php is being executed in the wrong order. I have deleted & re-installed exec-php but still the problem. If you can offer any suggestion again, I'd be eternally grateful. Regards, Joan
  #5  
Old Mar 11, 2010, 03:43 AM
juggledad's Avatar
juggledad
 
22,245 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
are you using the HTML editor? I just installed exec php and put
HTML Code:
<?php echo 'hello juggledad!'; ?>
into a post and it works fine, no problem, I get 'hello juggledad'

IF however I use the visual editor, it gets transformed into
HTML Code:
&lt;?php echo 'hello juggledad!'; ?&gt;
which will then display as '<?php echo ‘hello juggledad!’; ?>' since it is no longer PHP even if it LOOKS like PHP code
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #6  
Old Mar 12, 2010, 01:26 AM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
Yes I am typing into the HTML editor, not the Visual editor. I am getting an extra space inserted into the code upon clicking the Publish- Update button. Something very weird is happening.
  #7  
Old Mar 12, 2010, 03:23 AM
juggledad's Avatar
juggledad
 
22,245 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
try disabling all your plugins but the exec-php to see if it is one of them.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Mar 16, 2010, 11:07 PM
joan
 
50 posts · Sep 2009
Brisbane, Qld, Aust
Thanks Juggledad,
I had already disabled all plugins when you suggest it. Also changed themes to the default, then I re-install the entire wordpress package, but still no luck. Finally I found it was a wordpress
"Writing Settings" setting:

[] WordPress should correct invalidly nested XHTML automatically

which I have changed to OFF, and the code no longer gets and extra space inserted in between `<?php` and the problem is fixed (the setting must be stored in the database, which was about the only thing I didn't reset). Can you make this post "Solved" ? Thanks for your time, again.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Pls help me change this code<title><?php bloginfo('name'); ?><?php wp_title(); ?></ti tobywinn Header configuration & styling 1 Nov 18, 2011 11:51 AM
php in footer.php - links to just show up on homepage chris Atahualpa 3 Wordpress theme 6 May 9, 2010 12:50 PM
[SOLVED] Error in PHP Coding Using PHP Text Widget rnimchuk Sidebars & Widgets 2 Oct 28, 2009 12:26 PM
[SOLVED] &lt;?php include ...?&gt; is not working astera Post-Kicker, -Byline & -Footer 8 Sep 21, 2009 12:52 AM
[SOLVED] messed up header.php and footer.php monochrome Header configuration & styling 0 Jun 20, 2009 02:16 PM


All times are GMT -6. The time now is 11:07 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.