Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] Problems with post_thumbnail


  #1  
Old Feb 10, 2010, 11:59 AM
Foulsham Eric
 
5 posts · Feb 2010
Hi, all of you

Fatal error: Call to undefined function the_post_thumbnail() in /homez.332/pressinf/www/wp-content/themes/atahualpa/functions/bfa_post_parts.php on line 124

This is the message I get when I clic anything else than a post
I am sorry I am not an expert in php and do not understand what it means nore how I can solve the problem. Below, the slice of code around line 124. The first "h" appears in red and at the end, the "/h" also. Please helllllp !

<h<?php echo $bfa_ata['h_posttitle']; ?>><?php

if( !is_single() AND !is_page() ) { ?>

<a href="<?php the_permalink() ?>" rel="bookmark" title="Permanent Link to <?php the_title(); ?>"><?php

}

if ( (is_single() OR is_page()) AND $bfa_ata_body_title != "" ) {

echo htmlentities($bfa_ata_body_title,ENT_QUOTES,'UTF-8');

} else {

if ( $bfa_ata_body_title_multi != '' ) echo htmlentities($bfa_ata_body_title_multi,ENT_QUOTES, 'UTF-8');

else the_title();

}

if ( !is_single() AND !is_page() ) { ?></a><?php } ?></h<?php echo $bfa_ata['h_posttitle']; ?>>

<?php echo $after;


Bonsoir, ceci est le message d'erreur que j'obtiens au clic d'un catégorie, d'une recherche, bref tout sauf un post. Je vois bien que c'est lié à post_thumbnail mais je ne vois pas de solutions ...
Ci dessus la tranche de code en cause das laquelle le premier "h" apparait en rouge comme le "</h" de l'avant dernière ligne... Au secouuurrrrs !

Merci !
  #2  
Old Feb 10, 2010, 04:40 PM
juggledad's Avatar
juggledad
 
23,545 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
please down load the latest version from http://wordpress.bytesforall.com/?p=82
there was a bug in the 3.4.5 version which has been corrected in 3.4.5.1
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Feb 11, 2010, 02:31 AM
Foulsham Eric
 
5 posts · Feb 2010
great ! Thanks a lot

Bookmarks

Tags
the_post_thumbnail

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 problems with Atahualpa Kiliana New Versions, & Updating 1 Oct 9, 2009 05:24 AM
Problems with Cyrillic Clement Languages & Translations 4 Jun 30, 2009 03:48 AM
Formbuilder problems rachkitty Atahualpa 3 Wordpress theme 3 Jun 12, 2009 04:41 PM
problems with b/g image nickcee Atahualpa 3 Wordpress theme 3 Jun 11, 2009 10:55 AM
Formating problems OldRedDragon Excerpts, Read more, Pagination 1 May 31, 2009 06:09 AM


All times are GMT -6. The time now is 07:09 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.