Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages »

Google Analytics is crashing IE8


  #1  
Old Feb 8, 2010, 08:36 AM
cleask
 
4 posts · Feb 2010
Hey everyone,

I'm using Atahualpa 3.4.5 and have noticed a strange problem. Everything about it is just perfect, of course, but it comes as no surprise that IE8 has one problem with it. Firefox, Chrome, Safari...all render it perfectly.

I can add the Goggle Analytics code, 3 different ways, but I always get an error just with IE8. I can add it via:
1. ATO --> Add HTML/CSS Inserts --> HTML Inserts: Body Bottom
2. Go straight to footer.php and paste the javascript there (right below or above the bfa_ata['html_inserts_body_bottom'] call.
3. Using the Google Analytics for WordPress plugin.

All 3 of them raise the same problem. Just with IE8, I get the following error, and a totally blank page.

"Message: HTML Parsing Error: Unable to modify the parent container element before the child element is closed (KB927917)"

Any ideas?
  #2  
Old Feb 8, 2010, 08:55 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
make sure you didn't leave any blank lines in footer.php at the end. The last line should be
HTML Code:
</html>
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Feb 8, 2010, 09:15 AM
cleask
 
4 posts · Feb 2010
Indeed, I made sure that there were no gratuitous characters of any kind. Not even line breaks!
  #4  
Old Feb 8, 2010, 09:50 AM
juggledad's Avatar
juggledad
 
23,667 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
have you tried disabling your plugins and adding the google code to see if it is a plugin conflict?
If it also fails with the google plugin, try swapping to the default theme to see if it still fails
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Feb 8, 2010, 09:54 AM
cleask
 
4 posts · Feb 2010
Hey juggledad, I sure did.

Since the site is actually live right now, I probably won't be able to swap that theme out until late tonight, but I'll certainly give it a try.

I also might spin up another WP instance on one of my test sites, pull in the same theme, and see what happens at the default of this particular theme (Atahualpa has been tweaked a bit..albeit only using the Atahualpa tools) and with the default WP theme.
  #6  
Old Feb 9, 2010, 06:01 AM
cleask
 
4 posts · Feb 2010
To follow up on this, I created a second instance of WP in a sub directory, inserted Google Analytics in all 3 manners discussed above and it worked perfectly, therefore there is definitely a problem in some of my customizations of the original site.

Thanks for your help, but it looks like this one is squarely my fault!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to add Google Analytics code TheSurvivalMom Forum How-To 3 Apr 15, 2011 02:58 AM
How, Where do I insert Google Analytics? JTBurlesque Atahualpa 3 Wordpress theme 1 Sep 10, 2009 01:02 PM
[SOLVED] Google analytics in footer ninjaraul Post-Kicker, -Byline & -Footer 3 Aug 9, 2009 01:14 AM
Another Google Analytics Question.. dilly Plugins & Atahualpa 2 May 27, 2009 08:50 AM
Google Analytics fratelli78 Atahualpa 3 Wordpress theme 1 May 21, 2009 06:12 PM


All times are GMT -6. The time now is 02:38 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.