Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

[SOLVED] jpg background image for nav menu not showing up in IE7


  #1  
Old Dec 27, 2009, 06:38 PM
rinoa3108
 
53 posts · Apr 2009
Hello,
I have a red box which i used as a background image for my nav menu area. When i view the page with IE7 though, the red box isnt displayed. ive changed it to a .jpg, it was a gif before. Does IE7 not read gifs? It is a jpeg now but still isnt there. Any help would be greatly appreciated!

www.bigmamas.com.au
  #2  
Old Dec 28, 2009, 02:27 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Why use a jpg when you can set the background with CSS?
HTML Code:
div#pages-2 {background: red; }
you can ever add the border and padding etc.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Dec 28, 2009, 07:41 PM
rinoa3108
 
53 posts · Apr 2009
thanks juggledad!
ive got it to mostly work, but is there a way to create the white space between the black border and the red box? Ive been looking around css pages online but havent found the code for it. Many thanks in advance.
  #4  
Old Dec 29, 2009, 05:02 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
the best way to do this is to code your own menu and add an extra <div>. If the site will be static and there won't be many new pages, this will work.

Instead of adding the pages widget, add a text widget with the following
HTML Code:
<div id="pages-2" class="widget widget_pages">
<div id="my-inner-box">
	<div class="widget-title"><h3> </h3></div>		
	<ul>
		<li class="page_item page-item-2 current_page_item"><a href="http://www.bigmamas.com.au" title="Welcome">Welcome</a></li>			
		<li class="page_item page-item-6"><a href="http://www.bigmamas.com.au/food" title="Food">Food</a></li>
		<li class="page_item page-item-8"><a href="http://www.bigmamas.com.au/menuwinelist" title="Menu/Wine List">Menu/Wine List</a></li>
		<li class="page_item page-item-10"><a href="http://www.bigmamas.com.au/functions" title="Functions">Functions</a></li>
		<li class="page_item page-item-12"><a href="http://www.bigmamas.com.au/reviews" title="Reviews">Reviews</a></li>
		<li class="page_item page-item-14"><a href="http://www.bigmamas.com.au/contact" title="Contact">Contact</a></li>
	</ul>
</div>
</div>
then change the CSS Insert to this
HTML Code:
div#pages-2 {
border:solid 1px #000000;
}
div#my-inner-box {
background:red;
margin:20px;
}
the outer <div> will have the border and the inner onw will have a margin and a red background. You can fiddle with the magrin size to get it the size you want.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Dec 30, 2009 at 03:44 AM.
  #5  
Old Dec 29, 2009, 07:43 PM
rinoa3108
 
53 posts · Apr 2009
thanks so much! it worked. will have a look and learn more about css.

Bookmarks

Tags
background image, ie7, internet explorer, not displayed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Background image showing up in header? gcarson Header configuration & styling 7 Oct 20, 2009 06:16 PM
repeating background image not showing up in 3.4.2 sirabi Header configuration & styling 1 Sep 13, 2009 11:12 AM
image not showing in background of page menu bar rinoa3108 Page & Category Menu Bars 5 Jul 30, 2009 07:37 AM
[SOLVED] Background Image Not Showing in IE6 Jcasteli Atahualpa 3 Wordpress theme 4 Jun 4, 2009 06:41 PM
[SOLVED] [SOLVED] Background image not showing up WebWeaver Atahualpa 3 Wordpress theme 2 May 28, 2009 05:39 PM


All times are GMT -6. The time now is 01:02 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.