Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

[SOLVED] Atahualpa corupted by plugin - HELP!


  #1  
Old Dec 19, 2009, 03:43 PM
RV Traveler
 
3 posts · Dec 2009
Anywhere my RV is located.
After deactivating ďSimple Facebook LinkĒ plugin because it stopped working, my page right sidebar disappeared and an error code at the bottom of the page appeared and all the other post below the main post are missing:

Fatal error: Call to undefined function: simple_facebook_link() in /home/content/D/a/v/Daves300WinMag/html/TRAVEL/wp-content/themes/atahualpa/functions.php(478) : eval()'d code on line 21

It appears to be calling for something that does not exist.

I communicated with the plugin developer and he has given up on helping me solve this problem.
I have been troubleshooting this for the last two days to no avail. Iíve tried everything I know and nothing has fixed it.

Iíve deleted files and folders, reinstalled WP and Atahualpa. Iíve searched for any reference to Facebook in all the files on the server and there is nothing.

The only way to make the right sidebar appear is to reinstall and activate the plugin that still does not work correctly.

Please somebody help me, my hair is falling out! It makes no sense to me.

http://GrayStarCity.info

Last edited by RV Traveler; Dec 19, 2009 at 03:50 PM.
  #2  
Old Dec 19, 2009, 04:21 PM
juggledad's Avatar
juggledad
 
23,755 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
It sounds like you added a bit of php somewhere in your settings or modfied your code somewhere. If you have reinsealled both wordpress and atahualpa (I'm assuming you just loaded fresh copies of the code) and didn't tough the database, then it must be in something (an Atahualpa option or a post) in the database.
And from the fact that the error is discovered in the functions.php of atahualpa, I'd surmize that it is in one of the theme options stored in the database.

Do this, attached is a file called 'dump.zip'. Download it, unzip it and you will see a folder called dump with one file called dump.php. Copy 'dump.php' to your Atahualpa folder then go and create a new page using the 'dump' template.

Once you have that done, we can look to see if the facebook link shows up and that may tell us which option it is in.
dump.zip
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Dec 19, 2009, 04:56 PM
RV Traveler
 
3 posts · Dec 2009
Anywhere my RV is located.
Thanks! I followed your instructions and created "Test" on my site. Sure enough, the "Share on Facebook" shows up near the middle.

Now what. I don' have a clue what to do about it. Please look at it and advise.

http://graystarcity.info/test/

Dave
  #4  
Old Dec 19, 2009, 05:31 PM
RV Traveler
 
3 posts · Dec 2009
Anywhere my RV is located.
Yahoo!!!!

My RV is rocking because I'm jumping with joy. I read the contents of your Dump.php page and it gave me the clue to look at the "Center Column Style & edit CENTER COLUMN." I found the following in the LOOP. I don't remember putting it there.

<p> <b> <a href="" onClick="window.open('<?php simple_facebook_link(''); ?>',
'Share on Facebook','width=620,height=440')">Share on Facebook</a> </b> </p>

Thank you so much.

Dave
  #5  
Old Dec 19, 2009, 05:34 PM
juggledad's Avatar
juggledad
 
23,755 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
glad I could help and I wish I was in my RV somewhere warm instead of getting ready for the 8-15 inches of snow that are about to dump on us.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atahualpa and the FeatureME Plugin erikol Plugins & Atahualpa 0 Aug 4, 2009 03:36 PM
Widget Voodoo Plugin and Atahualpa dilly Plugins & Atahualpa 3 Jun 4, 2009 08:53 PM
Atahualpa 3 and WPG2 plugin mangaman Plugins & Atahualpa 12 Apr 23, 2009 12:50 PM
Will the Keywordluv Plugin work with Atahualpa Jerry Plugins & Atahualpa 2 Apr 8, 2009 10:16 PM
Plugin management gone with Atahualpa theme Seems ok otherwise Robin Plugins & Atahualpa 1 Mar 2, 2009 09:51 PM


All times are GMT -6. The time now is 02:20 PM.


Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.