Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] Meta Description and Keywords not showing up in Google Results


  #1  
Old Nov 21, 2009, 09:13 PM
MPenguin
 
6 posts · Nov 2009
If you do a google search for "taiwan expatriate" my blog comes up on the first page (it is http://www.expatintaiwan.net).

http://www.google.com/search?hl=en&s...&aq=f&oq=&aqi=

However, there is no Meta Description or keywords. Why?

I'm using Wordpress 2.8.6, Atahualpa Theme 3.4.4, All-in-One SEO, and have all both the Description on the AIO SEO and Atahualpa theme options set correctly. But it's still not showing up.

I've also tried disabling AIO SEO and using the Atahualpa SEO options. Doesn't seem to make any difference whatsoever.

If I look at the source code of my page, I can see the meta description in the AIO SEO section (even when I have AIO SEO disabled!), but it still doesn't show up in Google. Can someone explain to me why and what I need to do to get it to show?
  #2  
Old Nov 24, 2009, 07:29 AM
sparksmex
 
56 posts · Apr 2009
Jocotepec, Mexico
Something is turning them off. When I first registered the new site with Google my site description was the footer info about Atahualpa and Wordpress. You don't even have than.

What is W3 Total Cache doing
__________________
http://sparks-mexico.com/
  #3  
Old Nov 24, 2009, 07:38 AM
MPenguin
 
6 posts · Nov 2009
W3 Total Cache appears to be OK. I have 2 boxes at the top:

Code:
Memcached nor APC appear to be installed correctly. Hide this message
Code:
Database caching is not available. Memcached server localhost:11211 is not running or is non-responsive.
Other than that, it's enabled and seems to be doing OK. Maybe I should revert back to wp-cache or a different caching plugin?

Is there anything else I should be looking at?

Last edited by MPenguin; Nov 24, 2009 at 07:40 AM.
  #4  
Old Nov 24, 2009, 08:42 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
MPenguin, first of all, I love your site. I just spat my coffee all over my desk while looking at the Japanese Oddities section. What's with the goose head item??

Your header stuff looks very odd. I'm wondering if somehow the Next Gen Gallery code is interfering, somehow. You could try deactivating the plugin and then look at the meta stuff. I do see meta description and keywords, but not in the usual spot.
  #5  
Old Nov 24, 2009, 05:02 PM
MPenguin
 
6 posts · Nov 2009
I currently have All-in-One SEO enabled, so the meta description and keywords are there in the AIO SEO section in the header.

Code:
<!-- All in One SEO Pack 1.6.8.1 by Michael Torbert of Semper Fi Web Design[442,472] -->
<meta name="description" content="An American expatriate shares his thoughts on life, language, food, and culture in Taiwan." />
<meta name="keywords" content="Taiwan, Chinese, expatriate, life, English, languages, culture, food, Taiwanese food, Mandarin, Taiwanese, Taiwanese culture, expats, expatriates" />
<link rel="canonical" href="http://www.expatintaiwan.net/" />
<!-- /all in one seo pack -->
If I deactivate AIO SEO and use the Atahualpa SEO options, then the description and keywords revert to the very top of the header (Where they are probably normally found).

Code:
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />
<link rel="stylesheet" href="http://www.expatintaiwan.net/?bfa_ata_file=css" type="text/css" media="all" />
<title>An Expatriate in Taiwan</title>
<meta name="description" content="An American expatriate shares his thoughts on life, language, food, and culture in Taiwan." />
<meta name="keywords" content="Taiwan, Chinese, expatriate, life, English, languages, culture, food, Taiwanese food, Mandarin, Taiwanese, Taiwanese culture, expats, expatriates" />
I'll try deactiving Next Gen Gallery and see if that helps the situation any.

For reference, here are the plugins that I use:
Code:
Akismet
AIO SEO Pack (Currently deactivated for testing)
cforms
Feedburner Feedsmith
Google Analytics for Wordpress
Google XML Sitemaps
IE6 No More
MDBG Chinese-English Dictionary
Next-Gen Gallery (Deactivated for testing)
Post Editor Buttons
RSS Footer
Share This
W3 Total Cache
wp-cache (Do I need this if I have W3 Total Cache?)
WP-DBManager
WP-Email
WP-flv
WP-PageNavi
WP-Print
WP-Table Reloaded
YARPP
Any feedback on what these plugins might be doing and how to solve it is greatly appreciated.

About the goose head, that's just good ol' Japanese wackiness. Apparently they think it would be funny to wear a goose head dildo on the outside of your pants or with your ballerina costume. I'm really not sure what's going on there.

Last edited by MPenguin; Nov 24, 2009 at 05:23 PM.
  #6  
Old Nov 25, 2009, 12:55 AM
MPenguin
 
6 posts · Nov 2009
I've been playing with the settings and googling, nothing seems to work.

I've read that google will ignore the meta description if it's the same for all pages (mine was), so I've gone through the pages and added custom meta descriptions in the Atahualpa Page Options. I've also checked Yahoo and Bing, and both of them list my site without any description or keywords also.

So.... what exactly am I doing wrong that all the sites seem to completely ignore my meta description and return results with no keywords or description at all? This really seems quite odd.

One thing, however: I found that I had a robots.txt (thanks Dreamhost!) in the directory that was blocking access to spiders. I suspect this had something to do with it. I have since deleted it, updated page titles, descriptions, keywords, and other meta tags and rebuilt the XML-Sitemap. If the robots.txt was the problem, is it just a matter of time until search engines start displaying the information or is it something else entirely?

Thanks for the help!
  #7  
Old Nov 25, 2009, 06:09 AM
paulae's Avatar
paulae
 
1,333 posts · Feb 2009
Wordpress 3.4.1, Atahualpa 3.7.7
Having your robots.txt set the wrong way will certainly be a problem for the crawlers!

I wonder if you need that No IE6 plugin. It's producing a lot of code I'm not sure you need.

I doubt you need 2 caching plugins, and they could conflict with each other, I would think.
  #8  
Old Nov 25, 2009, 06:58 AM
sparksmex
 
56 posts · Apr 2009
Jocotepec, Mexico
I use SEO Title Tags for pages and that helped with my categories which are page rather than blog oriented. You should have a site description but sometimes that takes a week or two with Google. I don't believe your post categories will ever come up under your main site

I don't know how MDBG Chinese-English Dictionary works - a language confusion?
__________________
http://sparks-mexico.com/
  #9  
Old Nov 25, 2009, 07:03 AM
MPenguin
 
6 posts · Nov 2009
I've deleted the IE6 No More plugin and also deactivated and deleted wp-cache, just to be safe.

I guess my next step is to wait a few weeks and see if Google and other search engines start picking up the meta tags after fixing the robots.txt file.

MDBG Chinese-English Dictionary plugin shouldn't cause any problems. I use it on my site to wrap Chinese characters and Pinyin. For Pinyin, it'll add tone marks. For Chinese characters, it will automatically link the characters to dictionary entries on MDBG. It's pretty handy as I tend to write quite a bit of Chinese on my site.
  #10  
Old Nov 25, 2009, 07:47 PM
MPenguin
 
6 posts · Nov 2009
Huzzah! It appears something has gone right.

http://www.google.com.tw/search?hl=z...meta=&aq=f&oq=

The Meta Description is now properly showing in google search results. I suspect that the Pages and posts will hopefully start appearing in the search results also. So far, searching for keywords and tags used in my posts only turns up a few search results, but that should improve over the next few weeks, right?

As an example, the Japanese oddities turn up:
http://www.google.com.tw/search?hl=z...meta=&aq=f&oq=

Thanks for the help figuring this problem out, everyone!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Meta tag description/keywords never appears - is_home is always false slimandslam Header configuration & styling 6 Nov 9, 2009 12:38 PM
Where are meta keywords and description? horsemansarts Atahualpa 3 Wordpress theme 18 Aug 28, 2009 04:23 PM
[SOLVED] Hi, I want to put a google ad in the header. google adsense vishvadeep Header configuration & styling 5 Aug 27, 2009 12:30 PM
Google Analytics not showing new visitors after 2.8 upgrade paulae Plugins & Atahualpa 2 Jul 11, 2009 07:27 AM
Umlauts in Home Page Meta Description mrz Atahualpa 3 Wordpress theme 2 May 24, 2009 09:37 AM


All times are GMT -6. The time now is 03:23 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.