Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Post-Kicker, -Byline & -Footer »

[SOLVED] How to place background image on a static page


  #1  
Old Nov 4, 2009, 11:15 PM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Frustrating! I know I know how to do this...

I'm trying to place a 300 px wide background image behind the text on just one specific static page of my test site. I've uploaded the image to

http://shepherdjim.com/wp/wp-content.../imagename.jpg

and can't get it to appear.

I'm using ATA 3.4.2 and WordPress 2.8.5.

http://shepherdjim.com

Jim
  #2  
Old Nov 4, 2009, 11:52 PM
jim
 
50 posts · Mar 2009
Hi that jim
Of the top of my head it seems like you could create a simple table http://forum.bytesforall.com/showthr...&highlight=jim and specify it to have a background image, I havent been there with an image, but it should be like coding it to have a background colour which would be.....<td bgcolor="??????">... so maybe it would be ....<td background=?????.jpg>
All the best.....this jim.
  #3  
Old Nov 5, 2009, 05:39 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Hey Jim -- like that name!

Thanks, but no. I survived the "old days" when tables were used as THE way to arrange content on web pages. Modern, new and improved!!, web design dictates that tables be used only to present "tabular data" -- I always think of that as showing an Excel spreadsheet on your site.

I know I can assign a background image to an HTML "container" (e.g. body, div, span, etc) with CSS. And I could probably do it successfully in a straight HTML/CSS website. But, I'm having trouble figuring out how to insert what's necessary into the whole WordPress/Atahualpa conglomeration.

I'm glad to see that someone was up last night later than me!

Jim, ...Shepherd Jim
(thinking: "....Bond, ...James Bond")
  #4  
Old Nov 5, 2009, 08:40 AM
juggledad's Avatar
juggledad
 
23,626 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
see http://forum.bytesforall.com/showthr...ackground+page
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Nov 5, 2009, 10:28 AM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Nope, not there yet.

Experimenting with two pages, I've put the following in the ATO CSS Inserts:

body.page-id-79 td.middle {
background: #414141;
}

body.page-id-11 td.middle {
background-image: url(/wp/wp-content/uploads/Yarn_LowWhor_300pxl.jpg);
background-repeat: no-repeat;
}


On my test site, "page-id-79" should be http://www.shepherdjim.com/info-comments

and "page-id-11" http://www.shepherdjim.com/fiber-tools/niddy-nods

and I'm not seeing anything new in the backrgounds of either page.

I've looked at the generated Page Source listing but I'm not clever enough to see what's not happening.

S'Jim
  #6  
Old Nov 5, 2009, 11:24 AM
juggledad's Avatar
juggledad
 
23,626 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
your CSS SELECTOR is messed up
use a '#' when refering to an ID= and a ',' when refering to a CLASS=
so you should have
body.page-id-79 td#middle {
background: #414141;
}

body.page-id-11 td#middle {
background-image: url(/wp/wp-content/uploads/Yarn_LowWhor_300pxl.jpg);
background-repeat: no-repeat;
}
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Nov 5, 2009, 02:40 PM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
Quote:
Originally Posted by juggledad
your CSS SELECTOR is messed up
use a '#' when refering to an ID= and a ',' when refering to a CLASS=
so you should have
body.page-id-79 td#middle {
background: #414141;
}

body.page-id-11 td#middle {
background-image: url(/wp/wp-content/uploads/Yarn_LowWhor_300pxl.jpg);
background-repeat: no-repeat;
}
Thanks! It's working ...now I'm playing with positioning -- so much to learn!

BUT, I do want to understand where it was that I'd gone wrong.

Flynn's post on the subject from a year ago that you cited read:
<body class="page page-id-21 page-template page-template-default logged-in">

Then use a CSS Insert, e.g

body.page-id-21 td.middle {
background: #414141;
}

I had thought I was following exactly what Flynn had suggested. The "page source" refs class="page...etc so I figured I was styling a class and should use a "." -- not a "#". I don't see where it's an "ID" requiring the "#".

Not to worry if my continuation of this topic is more than we need to cover here. Looking at the numbers of Forum visitors lately, betting you have your hands full! :-)

Thanks again! Atahualpa Rules!
S'Jim
  #8  
Old Nov 5, 2009, 02:48 PM
juggledad's Avatar
juggledad
 
23,626 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I think Flynn made a typo, that's all (I think we should let him do that occasionally )
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Nov 5, 2009, 06:31 PM
Shepherd Jim's Avatar
Shepherd Jim
 
301 posts · Feb 2009
Bristol, midcoast Maine USA
You won't hear me arguing that point!

...and I am happy to learn that, for once, it wasn't me that was messing up!

Tnx again Paul!!

Bookmarks

Tags
background image, page

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keeping background image static ajgibson Atahualpa 3 Wordpress theme 2 Mar 7, 2010 11:31 AM
[SOLVED] How to show 1 specific header image on a static page and on Cat. pages Sakshin Header configuration & styling 24 Oct 3, 2009 04:36 PM
[SOLVED] Static background image for page menu bar nevaratoiel Page & Category Menu Bars 6 Oct 3, 2009 02:23 AM
[SOLVED] Need static header image to display on the front page but no image on any o joaodagraca Header configuration & styling 2 Aug 10, 2009 01:45 AM
Changing repeated background image forces each page to reload background doctorrobert Atahualpa 3 Wordpress theme 8 Feb 15, 2009 06:36 AM


All times are GMT -6. The time now is 02:29 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.