Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

Atahualpa and iexplorer


  #1  
Old Feb 17, 2009, 07:57 AM
Jackie
 
3 posts · Feb 2009
I have just downloaded this theme from wp site and found instructions on how to set up as clean single page sales letter site. Everything was fine with Firefox, but when I tried to load up on internet explorer, it just shows a white rectangular box.
Can someone help me with this, as I dont have any technical knowlege on how to fix this.
Cheers
Jackie
  #2  
Old Feb 17, 2009, 08:11 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Please post a URL. (Atahualpa 3 is quite browser-safe and fully tested with IE 6/7/8, unlike many other themes)
  #3  
Old Feb 17, 2009, 01:02 PM
tepper
 
4 posts · Feb 2009
i have a similar problem.
When i view my site on Safari, i can see everything correctly (text, custom image header, layout). But when viewing via Internet explorer, Firefox and possibly other browsers, it shows up as just plain text, no images are displayed and layout is skewed.
additionally, i installed this theme with wordpress and using Cyberduck and bluehost as my host. I checked the image file path (i might have my language confused here) there are no spaces, just one word, however, it is a jpeg but i didnt read anything that said it had to be a gif.
Where does the problem lie- how i uploaded? the theme? wp? my host?

also, do you recommend using a plugin for large photo files? i.e. NextGEN?

thanks

check it out:
www.erikasabel.com
  #4  
Old Feb 17, 2009, 02:19 PM
Jackie
 
3 posts · Feb 2009
Sorry url as follows

www.keywordsexposed.com

Thanks any help would be appreciated
  #5  
Old Feb 17, 2009, 05:25 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Quote:
Originally Posted by Jackie
Sorry url as follows

www.keywordsexposed.com

Thanks any help would be appreciated
You've pasted text directly from MS Word. When pasting from Word, either use the "Past from Word" button in the Wordpress editor, or better yet, paste into a text editor first to lose the proprietary Microsoft formatting, then copy and paste from there. This means that you would have to re-aply the formatting to the text, but this time inside the Wordpress editor, not in Word.

So, delete the post or the content of the post (in HTML mode, in the WP editor), then paste the fresh unformatted text inside again, and format inside the WP editor
  #6  
Old Feb 17, 2009, 05:47 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Quote:
Originally Posted by tepper
i have a similar problem.
When i view my site on Safari, i can see everything correctly (text, custom image header, layout). But when viewing via Internet explorer, Firefox and possibly other browsers, it shows up as just plain text, no images are displayed and layout is skewed.
additionally, i installed this theme with wordpress and using Cyberduck and bluehost as my host. I checked the image file path (i might have my language confused here) there are no spaces, just one word, however, it is a jpeg but i didnt read anything that said it had to be a gif.
Where does the problem lie- how i uploaded? the theme? wp? my host?

also, do you recommend using a plugin for large photo files? i.e. NextGEN?

thanks

check it out:
www.erikasabel.com
You have not closed a CSS style with a right bracket at A. Theme Options -> Body, text & Links -> Body Style.

HTML Code:
 background: url(/wp-content/themes/atahualpa3/images/Biomach.jpg;
should be

HTML Code:
 background: url(/wp-content/themes/atahualpa3/images/Biomach.jpg);
Note the closing bracket after Biomach.jpg

Also, your path to the theme files seems to be
HTML Code:
 /wp-content/themes/atahualpa/atahualpa/
instead of
HTML Code:
 /wp-content/themes/atahualpa3/
You should change that at that CSS style above if the background image doesn't show.

And if the layout is still messed up you might have similar errors (missing brackets, missing semicolons) at other theme options.

The reason the above errors gets through in Safari but throws off other browsers is that Safari lets it go as error and ignores it whereas the others try to interpret it as something.
  #7  
Old Feb 17, 2009, 08:13 PM
Jackie
 
3 posts · Feb 2009
Thanks Flynn

You have been a great help...all is working fine now.
I learn something everyday.
  #8  
Old Feb 18, 2009, 12:10 AM
tepper
 
4 posts · Feb 2009
Flynn,
Thank you for that informative response. I understand my error, it makes sense and i wish with all my might that i could figure out how to change my file path url on my very own, but it i am not having much luck. As you pointed out in my FTP server the theme is saved within itself, like a duplicate folder so that the path reads: .../atahualpa/atahualpa/.... instead of: /atahualpa3/...
so what does that mean? why did that happen? did i upload the theme incorrectly initially? how can i change it so that all paths will read atahualpa3 instead of editing CSS style format manually (which i barely understand what that means or how to do it successfully). Also, i tried dragging and dropping content from second atahualpa folder into the first atahualpa folder to eliminate the redundancy but that just made my website go blank with no content.
please advise.
thanks for your help!
  #9  
Old Feb 18, 2009, 03:30 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
There's no problem with having the theme files in a unusual place. Just change /atahualpa3/ to /atahualpa/atahualpa/ wherever you used /atahualpa3/ in any of the settings at Atahualpa Theme Options -> ...

You'd just have to remember that you have the theme in /atahualpa/atahualpa/ whenever you want to reference images and read about /atahualpa/ or /atahualpa3/ here on the forums. There's confusion about the location anyway because I intended /atahualpa3/ to be the location of Atahualpa version 3.x, but wordpress.org changed the folder name of my theme files to /atahualpa/ so most people have /atahualpa/ now instead of /atahualpa3/ as the theme directory, and you have /atahualpa/atahualpa/. Doesn't matter really as long as you know your path

For all existing images (sticky image in sticky posts, header image(s), down and right arrows in menus) the theme figures out the path aynway. Only when you add an image on your own (like you did with a background image for the body) you'd have to remember the right path. So the only change you'd have to make is, change, at A. Theme Options -> Body, text & Links -> Body Style

HTML Code:
 background: url(/wp-content/themes/atahualpa3/images/Biomach.jpg);
to

HTML Code:
 background: url(/wp-content/themes/atahualpa/atahualpa/images/Biomach.jpg);
  #10  
Old Mar 1, 2009, 05:19 PM
EasyWizard
 
1 posts · Mar 2009
Hi downloaded the theme a few days ago.

It is awesome.

One of the sites i am managing here running the theme has issues with IE

The blog title when rolled over changes to font size to 200+%

Any ideas
  #11  
Old Mar 1, 2009, 06:13 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Quote:
Originally Posted by EasyWizard
Hi downloaded the theme a few days ago.

It is awesome.

One of the sites i am managing here running the theme has issues with IE

The blog title when rolled over changes to font size to 200+%

Any ideas
You have added this in style.css

h1.blogtitle {
display: block;
{font-size: 1.7em; font-weight: bold;}
/* more ... */
}
h1.blogtitle a:hover {
text-decoration: none;
{font-size: 1.7em; font-weight: bold;}
/* more ... */
}

1. You shouldn't have to edit style.css. Even if you don't find a theme option, you can still add your own CSS through HTML/CSS Inserts -> CSS Inserts. That way your CSS will be preserved when you update to a new theme version

2. The red brackets aren't needed here. The whole style already has brackets (blue)

3. The 1.7 em of the h1 and the 1.7 of the a:hover are adding up because they are immediately inside each other <h1><a href=...>..</a></h1>. Firefox is ignoring that because the CSS is wrong anyway, but IE apparently doesn't

To set the size of the blog title, add font-size: 1.7em; to A. Theme Options -> Header -> Blog title
  #12  
Old Mar 24, 2009, 06:52 PM
MarShe
 
6 posts · Mar 2009
As with the original poster in this thread, I am getting visitors with Internet Explorer who see 3 out of 8 pages blank with the exception of the header. http://www.mygirlsgroup.com Your response was:

"You've pasted text directly from MS Word. When pasting from Word, either use the "Past from Word" button in the Wordpress editor, or better yet, paste into a text editor first to lose the proprietary Microsoft formatting, then copy and paste from there. This means that you would have to re-aply the formatting to the text, but this time inside the Wordpress editor, not in Word.

So, delete the post or the content of the post (in HTML mode, in the WP editor), then paste the fresh unformatted text inside again, and format inside the WP editor"

I may have pasted from word, I don't remember so I made the correction as you described on the Content page to no avial. I have done it using 'paste from Word' and removing formatting in Notepad entering it into the Wordpress editor and reformatting it. Neither made any difference. Is there another possible explanation? The 3 effected pages are: CONTENT, FAQs and REGISTRATION, where some code is showing so that problem seems to be different from the other 2 pages.

Thank you in advance!
  #13  
Old Mar 24, 2009, 07:09 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
All 3 pages still have a lot of MS Word code. Copy the text right from the browser window, paste it into notepad or another editor that doesn't apply any formatting. Now either delete those 3 pages and create them fresh (safest) or, if you rather delete their contents, make sure you grab all the MS code as well. To do this go into "HTML" mode an delete all the post content. Finally copy and paste the text from the text editor into the newly created or cleaned, blank post
  #14  
Old Mar 26, 2009, 06:22 PM
Mrs. Smith
 
1 posts · Mar 2009
Hi Flynn,

im so glad i found this thread. i have been having problems with how my site displays on i.e.

http://thats-all-folks.com

at first nothing was showing but the header and left column. i somehow managed to show the articles but im still missing the right column and the footer.

please let me know how i can fix this.
  #15  
Old Mar 27, 2009, 05:35 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
You pasted from MS WORD which is usually causing issues in IE because IE tries to follow those MS fromatting tags whereas other browsers ignore it

Re-create the posts by copying them again, from Word or from your site, then paste the text int a text editor first, and copy and paste from there. Apply formatting inside the WP editor, if any
  #16  
Old Mar 31, 2009, 09:43 PM
vinniev
 
22 posts · Mar 2009
Hey Flynn, I'm having a similar issue with the display in IE.

My issue specifically has to do with an Aweber form on the Left sidebar. It's displaying properly in Firefox but when viewing in IE the form doesn't close on the right side. It stretches into the body of the site and is cut off.

I haven't used MS Word for any of the text and I copied it directly from the Aweber site.

I'd appreciate if you could take a look http://phoenixexteriors.net/index/

Thanks in advance!
  #17  
Old Mar 31, 2009, 10:18 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Add a CSS Insert:

HTML Code:
div#text-380383901 table {
width: 180px;
}
To further shrink it you'd have to style the submit button, too, as its width doesn't allow the table to shrink much further. For this, first edit the text widget and add an ID, i.e. "mybutton", to the button:

Change:

<input type="submit" name="submit" value="Send My FREE Report">

to:

<input id="mybutton" type="submit" name="submit" value="Send My FREE Report">

Then use this CSS Insert instead of the one above:

HTML Code:
div#text-380383901 table {
width: 160px;
}
input#mybutton {
overflow: visible; /* IE hack to remove the extra padding that IE puts on buttons */
}

Last edited by Flynn; Mar 31, 2009 at 10:28 PM. Reason: Typo: Changed div.text-380383901 to div#text-380383901
  #18  
Old Apr 1, 2009, 10:12 AM
vinniev
 
22 posts · Mar 2009
Thanks Flynn, I still need some help. I'm afraid CSS Inserts are still pretty foreign to me. I replaced the HTML code as you described but I wasn't sure where to add the CSS insert.

I added it to the HTML/CSS Inserts tab but it's still not showing up properly in IE.

When you get a sec could you please take another look and let me know what I'm doing wrong?

Thanks Flynn!

-vinnie-
  #19  
Old Apr 1, 2009, 10:49 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
You've put it into the right place, at Atahualpa Theme Options -> HTML/CSS Inserts -> CSS Inserts

but only a part of the code. This is what you have now:

HTML Code:
}
input#mybutton {
overflow: visible; /* IE hack to remove the extra padding that IE puts on buttons */
}
And that part is already working in IE, even though the single } on top should be the closing bracket of the first style, see below.

Change the above code that you've put into CSS Inserts to

HTML Code:
div#text-380383901 table {
width: 160px;
}
input#mybutton {
overflow: visible; /* IE hack to remove the extra padding that IE puts on buttons */
}
Edit the width: 160px; part to get another width for that table



P.S.: The number text-380383901 is the ID that WordPress gave this specific text widget. If you remove that text widget and add it again, this number might change. In that case you'd have to look into the source code of your page and see what the new number is, and edit the CSS insert accordingly. This is how the number appears in the source code (Browser -> View Source code)

<div id="text-380383901" class="widget widget_text">
  #20  
Old Apr 1, 2009, 10:57 AM
vinniev
 
22 posts · Mar 2009
Flynn....dude....you are the man! If you were here I would totally give you a hug!

Thank you!!!
  #21  
Old Apr 1, 2009, 10:23 PM
vinniev
 
22 posts · Mar 2009
Flynn, can you take another look at my code? I added my Google Analytics code and adjusted the fonts on the widgets and I somehow blew out my Aweber table again in IE.

Thanks in advance Flynn.
  #22  
Old Apr 2, 2009, 07:20 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
This is caused by the missing quote at the end of the table style. Also various invalid tags (as per XHTML strict).

Replace

<table style="border:1px solid black;padding:0px;background-color:light-yellow[closing quote missing here]>
<tr><td colspan=2><center><div align="center"><strong><font color="#ff0000">"10 Ways To Increase The Value Of Your Home!"</font></strong></div></center></td></tr>

with

<table style="border:1px solid black;padding:0px;background-color:light-yellow">
<tr><td colspan="2" style="text-align: center; font-weight: bold; color: #ff0000">"10 Ways To Increase The Value Of Your Home!"</td></tr>
  #23  
Old Apr 2, 2009, 09:41 AM
vinniev
 
22 posts · Mar 2009
Why does IE hate me? I replaced my code with yours and it's still not closing that table. Am I retarded?
  #24  
Old Apr 2, 2009, 09:03 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
My bad, IE rears its ugly head here.

Add to the CSS insert from above a width for the button

div#text-380383901 table {
width: 150px;
}
input#mybutton {
overflow: visible; /* IE hack to remove the extra padding that IE puts on buttons */
width: 140px;
}
  #25  
Old Apr 2, 2009, 09:32 PM
vinniev
 
22 posts · Mar 2009
Thanks again Flynn! I thought I jacked up the code somehow.

You may have noticed that I edited my footer link to remove the Powered By Wordpress words but I definitely kept your link in there. It just wouldn't be right to remove it!!!

I'm gonna pimp your site the next time I'm on Sherman Hu's Half Hour Huddle (http://bitiptv.com/show/halfhourhuddle)

I'm also going to recommend you and your theme in my next tweet.

You rock man!!!

Last edited by vinniev; Apr 2, 2009 at 09:33 PM. Reason: spelling

All times are GMT -6. The time now is 01:48 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.