Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Languages & Translations »

Small bug in comments.php


  #1  
Old Oct 19, 2009, 02:29 AM
VesaT
 
534 posts · Oct 2009
Helsinki, Finland
Hi,

I'm maintaining a multinlingual website (www.tiirikaine.fi), with Finnish as default (newest versions of WP & Atahualpa not fully translated into Finnish.

If have come across a small bug which appears in the comment form. Text relating to e-mail seems not translate e.g. into Finnish - other texts do. I haven't had a look whether this is a php coding problem (hard-coded) or if the text is omitted from the .po -file.
See the excerpt from "comments.php":
<input class="text email" type="text" name="email" id="email" value="<?php echo $comment_author_email; ?>" size="30" tabindex="2" />&nbsp;
<label for="<?php _e('email','atahualpa'); ?>"> <strong>
<?php _e('Mail</strong> (will not be published) ','atahualpa');
if ($req) _e('(required)','atahualpa'); ?></label>
</p>

<p>
<input class="text url" type="text" name="url" id="url" value="<?php echo $comment_author_url; ?>" size="30" tabindex="3" />&nbsp;
<label for="<?php _e('url','atahualpa'); ?>">
<?php _e('Website','atahualpa'); ?></label>
</p>

I also would like to have a possibility to omit "website" box totally from the comment form; easy done with hard-coding.

Hope the development team finds ways to fix these soonest!

Regards,
Vesa
  #2  
Old Oct 20, 2009, 04:06 AM
VesaT
 
534 posts · Oct 2009
Helsinki, Finland
Hi again,

it seems indeed a php programming bug as the Finnish translation file is ok.

I had a look at the php code, and found out the <strong> </strong> tags somehow mess up the function. Removing these from the comments.php results in proper translation (have a look at http://www.visualmanagement.net/?p=1428), php code is currently as follows:
---------------- <p>
<input class="text email" type="text" name="email" id="email" value="<?php echo $comment_author_email; ?>" size="30" tabindex="2" />&nbsp;
<label for="<?php _e('email','atahualpa'); ?>">
<?php _e('Mail (will not be published) ','atahualpa');
if ($req) _e('(required)','atahualpa'); ?></label>
</p>
------------

Previously this part of code (current Atahualpa release) is as follows:
-------------------
<p>
<input class="text email" type="text" name="email" id="email" value="<?php echo $comment_author_email; ?>" size="30" tabindex="2" />&nbsp;
<label for="<?php _e('email','atahualpa'); ?>"> <strong>
<?php _e('Mail</strong> (will not be published) ','atahualpa');
if ($req) _e('(required)','atahualpa'); ?></label>
</p>

-------------------

I have no time at work to play with this to also get "Mail" showing in bold, but seems to work otherwise ok. Anyone with more time, please make changes to comments.php for the next release of Atahualpa.

Regards,
Vesa

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
BUG: php warning when postmeta is empty buzink Post-Kicker, -Byline & -Footer 0 Oct 12, 2009 05:53 AM
XHTML Strict Validation Error, Possibly from comments.php cyboc Comments, trackbacks & pings 0 Sep 9, 2009 01:57 PM
Comments on "Page" pages bug ricky119 Comments, trackbacks & pings 6 Jul 22, 2009 04:39 PM
BUG: %comments(' ',' ',' ',' ') no longer works in FOOTER of Multi/Single Post(3.3.2) ianuy Post-Kicker, -Byline & -Footer 2 Apr 15, 2009 12:26 AM
Bug: with /wp-content/themes/atahualpa3/style.css.php chris Atahualpa 3 Wordpress theme 6 Dec 13, 2008 01:00 AM


All times are GMT -6. The time now is 01:42 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.