Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

JS Facebook Badge Doesn't display in IE


  #1  
Old Feb 14, 2009, 11:51 PM
leslamb
 
12 posts · Feb 2009
I pasted the code for my Java Facebook badge into a text widget on left sidebar. Displays in Firefox, but not IE. I'm running WP 2.7.1. Site: http://leslamb.ca
  #2  
Old Feb 15, 2009, 09:12 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Looks like IE isn't executing part of the Javascript. Could you turn on the "default theme" for a moment and see if it's working there, to verify whether this is IE alone or a combination of Atahualpa & IE?
  #3  
Old Feb 16, 2009, 07:09 PM
leslamb
 
12 posts · Feb 2009
Turned it on, and it works fine in the default theme, as well as Inove.
  #4  
Old Feb 16, 2009, 07:50 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Those two are XHTML transitional, Atahualpa is strict, it may be related to that

It's working on my test site, see http://wp27.bytesforall.com/

Change the content in the Facebook text widget to the correct version

HTML Code:
 <script type="text/javascript" src="http://badge.facebook.com/badge/514693422.570.1242595448.js"></script><noscript><a href="http://www.facebook.com/people/Les-Lamb/514693422">Les Lamb's Facebook profile</a></noscript>
(Note the added "type=...")

You also have a wrong <br> tag at the top of the twitter tag

</br> should be <br />

If this doesn't help, try changing at the top of header.php
HTML Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
to
HTML Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
     "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
just to see if this would help. This should make IE less picky about other errors that may be on your site
  #5  
Old Feb 16, 2009, 09:48 PM
leslamb
 
12 posts · Feb 2009
Thanks, Flynn. I did all this, but it's still not working, despite the fact that my badge appears fine in IE on your test blog from my computer.

About the twitter break tag, I actually don't want a break there anyway, so I just removed it altogether. Thanks for going above and beyond.

Any other solutions for my Facebook badge? By the way, now that I've pasted the revised code for my badge from this page, could you please remove it? I'm concerned someone may be able to use my ID number from that code and gain access to my Facebook account with it. Not sure if that's possible, but I wouldn't want to find out.

Thanks!
  #6  
Old Feb 16, 2009, 10:06 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I removed your badge from my page. Could you try to remove the twitter plugin/widget and see if your Facebook badge works then? Also try removing other plugins or Javascript code you've inserted somewhere for a moment to help tracking it down.
  #7  
Old Feb 16, 2009, 11:28 PM
leslamb
 
12 posts · Feb 2009
Thanks. I've removed the text widget containing twitter code. I'm not aware whether any of the other widgets would operate on Java or not. At this point, the facebook badge still doesn't display properly in IE. Let me know if there are any other widgets you'd like me to remove.
  #8  
Old Feb 19, 2009, 06:15 PM
leslamb
 
12 posts · Feb 2009
Hey, Flynn....just checking in with you on this, as there was no reply to my last message. As I mentioned, I did remove the text widget containing twitter code, and nothing changed. No other widgets that I have control over are using Java, to the best of my knowledge.

Bookmarks

Tags
facebook badge

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Share Post on FaceBook without any use of plugins (( Atahualpa )) irvin Atahualpa 3 Wordpress theme 5 Dec 18, 2010 07:04 AM
Problems With Facebook Sharing iLeonardo Post-Kicker, -Byline & -Footer 6 Oct 7, 2009 03:00 AM
Is Facebook Profitable? Ahsen New Versions, & Updating 1 Jul 7, 2009 08:10 AM
? Why doesn't my site display in Internet Explorer 8 jcouse Installing & running WordPress 6 Jun 17, 2009 10:42 AM
Comment display order doesn't work(Atahualpa 3.2 + Wordpress 2.7) bishop Comments, trackbacks & pings 2 Feb 19, 2009 02:11 AM


All times are GMT -6. The time now is 02:28 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.