Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

WAMP local server giving 404s for pages


  #1  
Old Oct 7, 2009, 10:17 AM
StudioGal
 
177 posts · Feb 2009
Palm Beach Gardens FL
Hi, I'm using WAMP to develop a client website on my computer before I go live with it.

I've set the server up correctly and have no trouble getting the dashboard and my changes to the Atahualpa settings to work.

I'm using a static page for the home page, and am using pages rather than posts for the rest of the site.

However, when I click on the page links (other than the home page), I'm getting 404 errors. Any idea what's going wrong here?

Thanks!
  #2  
Old Oct 7, 2009, 11:17 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what have you got your permalinks set to? if other than default, try switching back to default.
Also try it with the default theme
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Oct 7, 2009, 11:36 AM
StudioGal
 
177 posts · Feb 2009
Palm Beach Gardens FL
I followed the procedure in the Codex at

http://codex.wordpress.org/Creating_a_Static_Front_Page

so in step 3, I set the permalinks to /%pagetitle%

though I admit to totally guessing what that tag should be since I can't find any reference to it! (You'd think they'd tell you on that page, right?)

So do you still recommend I go back to the default settings? I don't want to mess up the static pages.

Thanks!
  #4  
Old Oct 7, 2009, 02:34 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
go back to dashboard->settings->permalinks->Common Settings and select "Default' and try it that way.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Oct 7, 2009, 02:49 PM
StudioGal
 
177 posts · Feb 2009
Palm Beach Gardens FL
Yes, that got the pages to come up. Thanks.

However, the default setting for permalinks isn't so good for SEO purposes. Any chance we can get around that?

Another thing that I don't "get" is that the page "name" comes up as the title (H1) on the page - which also looks odd. But I do want a title on the page, just not the name of the page.

Really appreciate your help! THANKS.
  #6  
Old Oct 7, 2009, 03:13 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try creating an htaccess file
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Oct 7, 2009, 03:41 PM
StudioGal
 
177 posts · Feb 2009
Palm Beach Gardens FL
Okay, I just created an empty .htaccess file.

What should I do next?
  #8  
Old Oct 7, 2009, 07:16 PM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
on my MAMP server I have the htaccess file in the wordpress directory - it should be wrtiabel so wordpress can change it when you change the permalinks. Below is what I have in mine - this is copied from the web I do not know HTACCESS so I can't explain it all to you - check the web for that info

I run on a mac so the '/~userid/yoursite/index.php' is pointing to the folder 'yoursite' that is in the 'sites' folder of my user 'userid' (it's actually not 'userid', it is myname)

here is the htaccess file
HTML Code:
# ==========================================================
# protect the htaccess file
# ==========================================================
<files .htaccess>
order allow,deny
deny from all
</files>

# ==========================================================
# disable the server signature
# ==========================================================
ServerSignature Off
# limit file uploads to 10mb
LimitRequestBody 10240000

# ==========================================================
# protect wpconfig.php
# ==========================================================
<files wp-config.php>
order allow,deny
deny from all
</files>

# ==========================================================
# who has access who doesnt
# ==========================================================
order allow,deny
#deny from 000.000.000.000
allow from all

# ==========================================================
# custom error docs
# ==========================================================
ErrorDocument 404 /notfound.php
ErrorDocument 403 /forbidden.php
ErrorDocument 500 /error.php

# ==========================================================
# disable directory browsing
# ==========================================================
Options All -Indexes
#redirect old to new
Redirect 301 /old.php http://www.yourdomain.com/new.php

# ==========================================================
# block referring domains
# ==========================================================
RewriteEngine on
RewriteCond %{HTTP_REFERER} digg\.com [NC]
RewriteRule .* - [F]

# ==========================================================
# disable hotlinking of images with forbidden or custom image option
# ==========================================================
RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?yoursite.org/.*$ [NC]
#RewriteRule \.(gif|jpg)$ - [F]
#RewriteRule \.(gif|jpg)$ http://www.yoursite.org/stealingisbad.gif [R,L]

# ==========================================================
# php compression - use with caution
# ==========================================================
#<ifmodule mod_php4.c>
#php_value zlib.output_compression 16386
#</ifmodule>

# ==========================================================
# set the canonical url
# ==========================================================
RewriteEngine On
RewriteCond %{HTTP_HOST} ^yoursite\.org$ [NC]
RewriteRule ^(.*)$ http://www.yoursite.org/$1 [R=301,L]
# protect from spam comments
RewriteEngine On
RewriteCond %{REQUEST_METHOD} POST
RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
RewriteCond %{HTTP_REFERER} !.*yoursite.org.* [OR]
RewriteCond %{HTTP_USER_AGENT} ^$
RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /~userid/yoursite/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule .   [L]
</IfModule>

# END WordPress
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Oct 7, 2009, 07:38 PM
StudioGal
 
177 posts · Feb 2009
Palm Beach Gardens FL
YIKES - that's pretty scary! ;-)

I'll have a look at this in the morning and see if I can make any sense of it - I TRULY appreciate your reply and I will be back ...

Cheers and best.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Transfer Atahualpa site to a new server gungo Atahualpa 3 Wordpress theme 4 Oct 3, 2009 05:35 PM
Tables Work in Firefox But Giving Me Nightmares In IE mhighste Atahualpa 3 Wordpress theme 0 Sep 2, 2009 09:06 PM
How to move customized Atahualpa from one server to another... dennisfreud Atahualpa 3 Wordpress theme 1 Aug 26, 2009 07:57 PM
[SOLVED] Forum Server plugin mjg Plugins & Atahualpa 2 Jul 26, 2009 05:20 PM
New server for forum coming soon Flynn Forum How-To 1 Apr 20, 2009 09:10 AM


All times are GMT -6. The time now is 10:14 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.