Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Languages & Translations »

How change language


  #1  
Old Feb 11, 2009, 10:47 AM
Diego Velazquez
 
1 posts · Feb 2009
Please help me:

How I can change the Ataualpa Theme`s language ?
  #2  
Old Feb 11, 2009, 03:14 PM
xmaster
 
3 posts · Feb 2009
Good question

in order to change your language you must edit wp-config.php files and find line:
define ('WPLANG', 'fr_FR');

Replace fr_FR by your language.


BUT.

i still have a problem on my atahualpa them: date is in english! I dont know why. If somebody can help me on this ...

example : 10 february 2009 ...should be in french 10 février 2009 ..
Weird since all other stuff is translated.
  #3  
Old Feb 11, 2009, 07:01 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
The default values inside the theme options are localized yet but you can fully customize them in the theme options.

Moving this thread to language forum
  #4  
Old Feb 12, 2009, 07:06 AM
artiflo
 
4 posts · Feb 2009
Hello,

In my french officiel Wordpress 2.7 or 2.7.1.

I have "define ('WPLANG', 'fr_FR');" (without "") in my wp-config.php but Atahualpa 3 is still in english. I have fr_FR.mo and fr_FR_2.mo in wp-content/themes/atahualpa/
  #5  
Old Feb 12, 2009, 10:22 AM
plantagoo
 
1 posts · Feb 2009
Hi!

Hmmmm... This seems to be a common problem.

I installed WP 2.7.1 today (fresh install), downloaded the de_DE.mo. Set up the wp-config.php accordingly - now WP works fine in german language.

But the theme is still completely in english?! What can I do to solve this? Maybe a guide for dummys may help...

TIA

Greetings
plant
  #6  
Old Feb 13, 2009, 08:16 AM
Ramoonus
 
4 posts · Feb 2009
Same probleme here with 2.7.1 and Atahualpa 3.2.0
  #7  
Old Feb 14, 2009, 05:56 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Are all of you checking the sticky thread in this language forum? http://forum.bytesforall.com/showthread.php?t=362
  #8  
Old Feb 14, 2009, 09:48 AM
Nairolf
 
1 posts · Feb 2009
Quote:
Originally Posted by Flynn
Are all of you checking the sticky thread in this language forum? http://forum.bytesforall.com/showthread.php?t=362

Hello Flynn

Well, even though we go and look this sticky thread, I'm sorry to say it doesn't help us much.

Wordpress is set up to write French, so should your theme.
The "leave a reply" is in French for me but it seems we still have to translate the theme and go into the hard-coded theme. Is it so ?

Thank you
  #9  
Old Feb 18, 2009, 12:27 AM
outside
 
1 posts · Feb 2009
I didn't know how to change language. Can you help me? translation
  #10  
Old Feb 19, 2009, 02:19 AM
mgroenne
 
2 posts · Feb 2009
Quote:
Originally Posted by Nairolf
Hello Flynn

Well, even though we go and look this sticky thread, I'm sorry to say it doesn't help us much.

Wordpress is set up to write French, so should your theme.
The "leave a reply" is in French for me but it seems we still have to translate the theme and go into the hard-coded theme. Is it so ?

Thank you
I do have the same problem - all things in wp-config configured correctly: atahualpa still not in de_DE on wordpress 2.7.1.

i think that's a real bug (not a feature *g*).

any solutions yet?

yours
marc

http://www.ferien-in-vorauf.de
  #11  
Old Feb 25, 2009, 06:07 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
As mentioned in this thread http://forum.bytesforall.com/showthread.php?t=362 only the hard coded parts of the theme are localized, the default terms in the theme options are not, but you can fully customize those through the theme options any way (without any file edits).

But, in 3.2.1 the default terms in the theme options will be localized as well, and once the translators have updated their files, this kind of confusion should be gone.
  #12  
Old Feb 25, 2009, 07:11 AM
gaitje
 
1 posts · Feb 2009
Same problem here, I just installed WordPress 2.7.1, then installed the Dutch language for it, the admin part is translated. But the theme part not.

The text 'Leave a reply' is still in English, so the translation does not work.

I have changed in wp-config.php: define ('WPLANG', 'nl_NL');

In the theme pad, there is /themes/atahualpa/nl_NL.mo same file.

Still not translated, any other setting to do?

Thanks in advance!
  #13  
Old Feb 27, 2009, 09:22 AM
mgroenne
 
2 posts · Feb 2009
Quote:
Originally Posted by Flynn
As mentioned in this thread http://forum.bytesforall.com/showthread.php?t=362 only the hard coded parts of the theme are localized, the default terms in the theme options are not, but you can fully customize those through the theme options any way (without any file edits).

But, in 3.2.1 the default terms in the theme options will be localized as well, and once the translators have updated their files, this kind of confusion should be gone.
Hi flynn, of course i have read this thread before - and i understood what you mean. But that is not the reason why people here write of problems with the translation files.

In fact, there will be nothing translated into german - i just removed the parts in the frontend now, that are needed for our use. but the translation function ist not working at all in 3.2.1 with wp2.71.

I have looked into the german pot-file. Even parts that are translated there, are not working in the theme.
  #14  
Old Feb 27, 2009, 11:02 AM
dilago
 
14 posts · Feb 2009
I have manually translated the theme in dutch because i couldn't get it to work, but i cannot change it in comments, wich is the last that i want to change. Can anyone tell me where i can localise the problem? And how can i make the date appear on the bottom and bold the authors name?

http://www.zegwatjewil.nl/?p=265

This is my site.
  #15  
Old Feb 27, 2009, 03:35 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
Look into bfa_comment_walker.php if you're using WP 2.7+
  #16  
Old May 9, 2009, 08:14 PM
rmribeiro
 
17 posts · May 2009
I have the same problem... I can change "leave a comment" to my language
  #17  
Old May 10, 2009, 05:21 PM
rmribeiro
 
17 posts · May 2009
this is a real problem flynn, so much people with the same problem. Any solution?
  #18  
Old May 11, 2009, 02:58 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I am using a pretty standard functions/custom-comments.php since version 3.3.4, please try that

Also, a language file made for 3.3.2 will only work on 3.3.2 - not on 3.3.3 or 3.3.4

I will change this in a later theme version

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Other language Newgamer Languages & Translations 13 May 24, 2010 12:10 PM
Language Switcher and Atahualpa 3 arnaud Plugins & Atahualpa 19 Sep 17, 2009 07:57 AM
xili-language plugin atunoa Plugins & Atahualpa 1 Jul 14, 2009 06:06 PM
How can I change the language in Romanian?? antimatrix Languages & Translations 1 Mar 20, 2009 03:45 PM
change in romanian language c32v Languages & Translations 0 Feb 11, 2009 11:58 AM


All times are GMT -6. The time now is 03:33 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.