Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Sidebars & Widgets »

CSS for Widget list items not working (bullets)


  #1  
Old Aug 31, 2009, 05:56 AM
mlamkin
 
5 posts · Apr 2009
I was using an earlier fix that enabled me to have circles, discs, or squares on list items in widgets for WP 2.8 and Atahualpa 3.4.2. The site is www.crtrail.org/CRT-design.

HTML Code:
div.widget ul li a:link,
div.widget ul li a:visited,
div.widget ul li a:active,
div.widget ul li a:hover {
border-left: 0 !important;
padding-left: 0 !important;
}
div.widget ul {
/* for other styles, try "disc" and "square" instead of "circle" */
list-style-type: disc !important;
padding-left: 0;
margin-left: 0;
}
div.widget ul li {
/* 1.35 or more required for Safari or bullets too wide on the left */
margin-left: 1.35em;
/* overwrite existing display:block Firefox */
display: list-item;
}
However, when I try the more flexible CSS code for using images, I get no images before the list item, hovering or not. When I view source code, I do not see any reference to the button icon images in the CSS code.

HTML Code:
div.widget ul li a:link,
div.widget ul li a:visited,
div.widget ul li a:active,
div.widget ul li a:hover {
border-left: 0 !important;
padding-left: 0 !important;
}

div.widget ul li {
border-left: 0 !important;
padding-left: 15px !important;
background: url(/wp-content/themes/atahualpa342/images/icons/green-button.gif) no-repeat 0 3px;
}

div.widget ul li:hover,
div.widget ul li.sfhover {
border-left: 0 !important;
padding-left: 15px !important;
background: url(/wp-content/themes/atahualpa342/images/icons/blue-button.gif) no-repeat 0 3px;
}
Any ideas as to what I'm doing wrong?
  #2  
Old Aug 31, 2009, 10:25 AM
juggledad's Avatar
juggledad
 
23,631 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
put a '.' before the url - ie 'url(./wp-content.......'
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Aug 31, 2009, 01:46 PM
mlamkin
 
5 posts · Apr 2009
Thank you very much. Adding the "." worked.

But I don't understand why

background: url(./wp-content/themes/atahualpa342/images/icons/blue-button.gif)

is needed in my situation but the block everyone is instructed to cut and paste is

background: url(/wp-content/themes/atahualpa342/images/icons/blue-button.gif)

Bookmarks

Tags
atahualpa 3.4.2, list items, widgets

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Widget list style (bullets) not working after upgrade paulae Sidebars & Widgets 9 May 1, 2013 06:41 PM
[SOLVED] Space between Widget List Items configurable? upscho Sidebars & Widgets 10 Jul 3, 2012 05:15 PM
[SOLVED] Bullets, Circles, Icons instead of left border on widget list items MacMacGA Sidebars & Widgets 62 Jul 30, 2010 11:46 AM
How to change the spacing of list items Webmason Atahualpa 3 Wordpress theme 5 Aug 4, 2009 02:33 PM
"Widget List Items" Settings Are Not Persisted bseppa Sidebars & Widgets 1 Dec 13, 2008 12:34 PM


All times are GMT -6. The time now is 07:08 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.