Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

Atahualpa 3.4.3 slow because of call to old theme folder files?


  #1  
Old Aug 14, 2009, 04:45 PM
extremecarver
 
105 posts · Jul 2009
While trying to debug my server and finding out why it's so slow (empty atahualpa page needs 1.7 seconds to generate .... however only around 20% of CPU use, and plenty RAM Free) even though I have mysql and apache tuned for high performance (mysql mylare.cnf, xcache php accelerator, running wp-supercache-plus in full on mode...)

I see on my server status page several calls to old images from atahualpa 3.2 theme folder - which has long ago been deleted from my server....

They take quite a lot of time and I assume that maybe these calls are responsible for the slow loading of my page (most users won't notice as they get served static pages). I have around 2000 unique visits each day, and 15 minute CPU load maxes out at around 0.3-0.5 during the evening, while being well below 0.2 the rest of the day, plenty of free ram too....

Today I activated mod_server-status and I noticed that quite often calls are taking up to 2000ms CPU times for old images of atahualpa theme, based in folders that don't exist any more....

like this (sorry formattting broken):
Srv PID Acc M CPU SS Req Conn Child Slot Client VHost Request
0-0 7924 0/3/68 _ 2.53 47 2160 0.0 0.00 1.74 91.33.85.10 openmtbmap.org GET /wp-content/themes/atahualpa.3.2/atahualpa/images/sticky.gi


Is it possible that there are problems with atahualpa rewriting the database after bumping up the theme version? (since 3.2 I have allways updated)

see my server-status here (is this a security risk to leave this open? - link obstructed so no crawler follows it)
http:// xxx 77.236.97.248 xxx /server-status

Last edited by extremecarver; Aug 14, 2009 at 04:47 PM.
  #2  
Old Aug 15, 2009, 02:25 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
You may have static page copies created by WP Super Cache that still reference old images?
  #3  
Old Aug 15, 2009, 04:44 PM
extremecarver
 
105 posts · Jul 2009
No I thought about that and deletet the complete cache folder (already quite often) -- with 342 I still used wp supercache. Since 3.4.3 I use wp supercache plus and had to delete all cache files (on top I often switched between half on (xcache only) and full on (xcache and disk cache) mode - and on each change cache gets deleted.

However there might be residues in the mysql database - however I don't know in which table they are....

I simply do note that those calls to nonexistant files take a lot of time.
  #4  
Old Aug 15, 2009, 10:57 PM
js9600
 
29 posts · Dec 2008
Would these 2 plugins help:

Debug Queries http://wordpress.org/extend/plugins/debug-queries/
Debug Objects http://wordpress.org/extend/plugins/debug-objects/
  #5  
Old Aug 19, 2009, 04:54 AM
extremecarver
 
105 posts · Jul 2009
I already used debug_queries from while to while, but neither (also debug_objects) helped me to find out why the call to old objects happens.....

Only clean database and wordpress new install would help....

Except for that slow call (adds 2 seconds) if it happens (not on all posts/pages) it's qtranslate that really slows down pageloadtime. Pageloadtimes are like the following:

fresh wordpress install, standard theme: 0.1 second
imported posts/pages and activated all plugins I use except qtranslate: 0.3-0.5 seconds (the main slowdown is not the plugins but the imported posts/pages/comments)
activated atahualpa: 0.7-2.5 seconds
activated atahualpa and qtranslate 1.7-5 seconds.

again fresh install/fresh database and imported posts/pages
default theme and all plugins incl. qtranslate activated: 0.6-3.5 seconds

So essentially qtranslate and atahualpa don't play well together at all.

The slowdown because of requests to inexistant pictures is quite annoying nevertheless.

If the call to inexistant files does not happen, my old install with old database (optimized) is as quick as the new test installations.
  #6  
Old Aug 20, 2009, 05:13 AM
juggledad's Avatar
juggledad
 
23,682 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
If you want to check the Atahualpa options to see if there are links to old folders, try this.

1) Use the code described here (http://forum.bytesforall.com/showpos...95&postcount=5) and do the export. This will give you an file of the Atahualpa options.
2) Examine the file for links to the old file structure and change them.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atahualpa SLOW to load! rackphoto Atahualpa 3 Wordpress theme 6 Feb 27, 2012 03:12 AM
Search for langage files Ger Languages & Translations 1 Jul 16, 2009 03:01 PM
[SOLVED] Errors: Invalid argument supplied for foreach() Call to undefined function skyline Atahualpa 3 Wordpress theme 1 Jun 4, 2009 12:41 AM
Japanese Atahualpa 3.3.3 language files needed TGsoft Languages & Translations 0 May 11, 2009 06:29 AM
Fatal error: Call to undefined function is_front_page() kyuen New Versions, & Updating 4 Mar 1, 2009 06:19 PM


All times are GMT -6. The time now is 10:34 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.