Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Page & Category Menu Bars »

Child Page Menu items appear all same colour


  #1  
Old Aug 14, 2009, 11:52 AM
aebrigham
 
35 posts · Aug 2009
I am stuggling with the colours on the Menu bar. I have attached a sample of how I want the menu bar to appear when hovering.

Click image for larger version

Name:	untitled.JPG
Views:	604
Size:	9.4 KB
ID:	223

But when you hover over a menu item that is your parent, you get a different result.

Click image for larger version

Name:	untitled2.JPG
Views:	569
Size:	12.2 KB
ID:	224

How do I make it so the Green appears only when hovering, instead of the entire list of child pages?

Thanks...
  #2  
Old Aug 15, 2009, 05:00 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What version of Atahualpa are you on?
At ATO->Page Menu Bar
If you set 'Background color' to a GRAY color
'Background color: Hover' to a GREEN color
and 'Background color: Parent' to a BLACK color
this should do what you want
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Aug 16, 2009, 06:38 PM
aebrigham
 
35 posts · Aug 2009
Click image for larger version

Name:	Untitled.jpg
Views:	588
Size:	20.5 KB
ID:	227

As you can see, I have specified what you implied above. It is doing exactly what I want, accept for when you are in one of the child pages. The parent menu item and subsequent child menu items show of different.
  #4  
Old Aug 17, 2009, 09:42 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I'm not sure what your question is, could you restate it?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Aug 20, 2009, 09:06 AM
aebrigham
 
35 posts · Aug 2009
Normally, when you are hovering over a menu items the item that you are on is a dark green, if you hover over a child-page of that menu item, the parent-menu item turns black and so on... If the menu item has 5 children, the and you hover down to item 5, the menu item would black, the 4 other children would be grey and the last would be green.

The problem I am having is, if you select the parent menu item. All childrens become green, instead of having the hovered green and the rest grey.
  #6  
Old Aug 20, 2009, 09:22 AM
aebrigham
 
35 posts · Aug 2009
Quote:
Originally Posted by juggledad
I'm not sure what your question is, could you restate it?
goto www.jessandandy.com and click on "Guest Info" menu item. Than hover over it again and you will see what I am talking about.

You will notice this website http://jerzzy.co.uk/ works slight different if you select "Active Holidays in Jersey"

Last edited by aebrigham; Aug 20, 2009 at 09:36 AM.
  #7  
Old Aug 20, 2009, 09:42 AM
aebrigham
 
35 posts · Aug 2009
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022; MS-RTC LM 8; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Thu, 20 Aug 2009 15:46:14 UTC


Message: 'J.parentNode' is null or not an object
Line: 5
Char: 1913
Code: 0
URI: http://jessandandy.com/wp-includes/j...ect.js?ver=2.1

I wonder if this has something to do with it. How do I fix this?
  #8  
Old Aug 20, 2009, 09:54 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
that sounds like a javascript error. Try deactivating all your plugins and see if it works
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Aug 20, 2009, 04:26 PM
aebrigham
 
35 posts · Aug 2009
Quote:
Originally Posted by juggledad
that sounds like a javascript error. Try deactivating all your plugins and see if it works
unfortunately this was not the error, after searching on google, this was realted to a MP3 Plugin that I had installed that I have subsequently removed. So I am still stuck with this problem.
  #10  
Old Aug 21, 2009, 05:55 AM
AnneTanne
 
40 posts · Jan 2009
Belgium
Quote:
Originally Posted by aebrigham
So I am still stuck with this problem.
When I look to the page you pointed to, I see exactly the behaviour you wanted:
Hovering over a child-item changes only the color of that child to green, the rest is grey and the parent is black.
Does this mean you found a solution, or could it be that your problem is somewhere browser-related?

I'm now working on a Windows machine with IE 8, and don't see the problem.
Yesterday, while I was on my own Linux-laptop with FF 2.5, I did see the problem you described. (But on my site, the color of the page-menu is behaving like it should, also on my laptop.)
  #11  
Old Aug 21, 2009, 08:36 AM
aebrigham
 
35 posts · Aug 2009
Quote:
Originally Posted by AnneTanne
When I look to the page you pointed to, I see exactly the behaviour you wanted:
Hovering over a child-item changes only the color of that child to green, the rest is grey and the parent is black.
Does this mean you found a solution, or could it be that your problem is somewhere browser-related?

I'm now working on a Windows machine with IE 8, and don't see the problem.
Yesterday, while I was on my own Linux-laptop with FF 2.5, I did see the problem you described. (But on my site, the color of the page-menu is behaving like it should, also on my laptop.)
Hi AnneTanne,

I only get the behaviour I want when hovering. If I actually select/click for ex. "Guest Info", the behaviour goes away and all child items become green without any hover effects. I am using IE8 on two computers and I get the same behaviour.
  #12  
Old Aug 21, 2009, 08:38 AM
aebrigham
 
35 posts · Aug 2009
Quote:
Originally Posted by AnneTanne
When I look to the page you pointed to, I see exactly the behaviour you wanted:
Hovering over a child-item changes only the color of that child to green, the rest is grey and the parent is black.
Does this mean you found a solution, or could it be that your problem is somewhere browser-related?

I'm now working on a Windows machine with IE 8, and don't see the problem.
Yesterday, while I was on my own Linux-laptop with FF 2.5, I did see the problem you described. (But on my site, the color of the page-menu is behaving like it should, also on my laptop.)
The thing that is different on your website is, you don't allow Parent Menu-Item clicks. I forget what that option is in the config. I on the other hand can click on Parent Items.
  #13  
Old Aug 21, 2009, 10:17 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
see if the info in this post will help http://forum.bytesforall.com/showthread.php?t=2372
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #14  
Old Aug 21, 2009, 02:42 PM
aebrigham
 
35 posts · Aug 2009
Quote:
Originally Posted by juggledad
see if the info in this post will help http://forum.bytesforall.com/showthread.php?t=2372
Thank-you so much, this link did send me down the right path. It wasn't my end result solution... See below how I as able to achieve my desired result.

Code:
/* For HOVER */
ul.rMenu-hor li.current_page_item ul li a:link,
ul.rMenu-hor li.current_page_item ul li a:visited,
ul.rMenu-hor li.current_page_item ul li a:active {
background: #777777 !important;
color: #FFFFFF !important;
},
ul.rMenu-hor li.current_page_item ul li a:hover {
background: #618300 !important;
color: #FFFFFF !important;
}
I feel like this is a small bug. Unless I am completely off the deep-end

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Page Menu Bar - space between items Tamas Page & Category Menu Bars 12 Apr 13, 2010 06:52 AM
Aligning Page Menu items joaodagraca Page & Category Menu Bars 1 Aug 8, 2009 04:13 AM
Space between page menu items nymana Page & Category Menu Bars 7 Jul 28, 2009 07:42 AM
[SOLVED] Page Menu Bar - Strange Space Occurring Between Menu Items NealSchaffer Page & Category Menu Bars 2 Jun 20, 2009 10:18 AM
Page Menu Drop Down Only Showing First 6 Child Pages LabbyRoad Page & Category Menu Bars 4 Mar 11, 2009 11:40 AM


All times are GMT -6. The time now is 04:27 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.