Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

[SOLVED] Page Navigation Issues


  #1  
Old Aug 6, 2009, 01:06 AM
Zeus
 
7 posts · Aug 2009
Singapore
Dear Flynn,

Thank you for providing such a great theme. Need some assistance from your goodself or experts out there, I have recently tried using a plugin by Lester Chan, WP-Page Navi.

Unfortunately, the page navigation shows out twice near the footer of my site: http://www.genlifeblog.com/.

Have read some threads about the plugin in this forum and understand that the plugin should work fine together with Atahualpa theme.

Any help will be much appreciated.

Cheers!
  #2  
Old Aug 6, 2009, 05:04 AM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Where did you insert the plugin code into Atahualpa?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Aug 6, 2009, 09:26 AM
Zeus
 
7 posts · Aug 2009
Singapore
Dear juggledad,

Thank you for your quick response. I have inserted the codes into footer.php, line 2 before the paragraph.

Hope to hear from you.

<!-- Footer -->
<td id="footer" colspan="<?php echo $bfa_ata['cols']; ?>">

<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>
<p>
<?php echo bfa_footer($bfa_ata['footer_style_content']); ?>
</p>
<?php if ($bfa_ata['footer_show_queries'] == "Yes - visible") { ?>
<p>
<?php echo $wpdb->num_queries; ?><?php _e(' queries. ','atahualpa'); ?><?php timer_stop(1); ?><?php _e(' seconds.','atahualpa'); ?>
</p>
<?php } ?>

<?php if ($bfa_ata['footer_show_queries'] == "Yes - in source code") { ?>
<!--
<?php echo $wpdb->num_queries; ?><?php _e(' queries. ','atahualpa'); ?><?php timer_stop(1); ?><?php _e(' seconds.','atahualpa'); ?>
-->
<?php } ?>

<?php wp_footer(); ?>

</td>
<!-- / Footer -->
  #4  
Old Aug 6, 2009, 11:33 AM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what options do you have set for PageNavi? Please list them all
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Aug 8, 2009, 04:05 AM
Zeus
 
7 posts · Aug 2009
Singapore
Dear juggledad,

The various options are as follows:

Page Navigation Text
Text For Number Of Pages - Page%CURRENT_PAGE% of %TOTAL_PAGES%
%CURRENT_PAGE% - The current Page Number
%TOTAL_PAGES% - The total number of pages

Text For Current Page - %PAGE_NUMBER%
%PAGE_NUMBER% - The page number

Text For Page - %PAGE_NUMBER%
%PAGE_NUMBER% - The page number

Text For First Post - &laquo; First
%TOTAL_PAGES% - The total number of pages

Text For Last Post - Last&raquo;
%TOTAL_PAGES% - The total number of pages

Text For Next Post - &raquo;

Text For Previous Post - &laquo;

Text For Next...

Text For Previous...

Page Navigation Options

Page Navigation Style - Normal

Number of pages to Show? - 5

Always Show Page Navigation? - No

Number of Larger Page - 0
Larger page numbers are in additional to the default page numbers. It is useful for authors who is paginating through many posts.

Show Larger Page Numbers In Multiples - 0

Thank you!
  #6  
Old Aug 8, 2009, 05:13 AM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
what version of Atahualpa are you running?
if its 2.4.x - what do you have at ATO->Add HTML/CSS Inserts->HTML Inserts: Body Bottom?
did you put '<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>' there in addition to in footer.php?

if so, this would cause exactly the issue you are having. The placement in footer.php will put the navi display after the last post - above the footer of the page area, while the occurance in 'ATO->Add HTML/CSS Inserts->HTML Inserts: Body Bottom?' will put it in the footer of the page area.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Aug 8, 2009, 10:05 AM
Zeus
 
7 posts · Aug 2009
Singapore
Dear juggledad,

Thank you for your clear explanation. I am currently using version 3.3.3 and did not insert the same codes via ATO HTML/CSS Inserts, I have inserted only in footer.php.

I have managed to resolve this issue by removing '<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } ?>' from footer.php and now everything seems to work fine.

I have since made a donation. Hope you do not mind but I have an additional question:

When upgrading to a later version of Atahualpa, I have always maintained the previous version (in this case is 3.3.2) and theme folder.

1) If I will to delete the previous folder (3.3.2) now, will this affect any of my past ATO settings?

2) During the time when I was using version 3.3.2, I have placed the same set of wp_pagenavi codes in footer.php (codes still exist in footer.php of 3.3.2). Does this have any effects if I will to place similar codes in footer.php (of 3.3.3)?

Thank you!
  #8  
Old Aug 8, 2009, 12:35 PM
juggledad's Avatar
juggledad
 
23,597 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
You can think of Atahualpa as having two parts: the CODE, and your SETTINGS. The code sits in the ataahualpa folder in the themes folder. Yoou can have multiple themes or copies of a theme in the themes folder. For example, I have
wp-content
--themes
---atahualpa32
---atahualpa333
---atahualpa340
---atahualpa341
---atahualpa342
---default

each of the themes folders is a seperate entity. if you make code changes to a theme, it will only effect the execution when that theme is active, so changes I make to the atahualpa code in the atahualpa333 folder, will have no effect if I activate teh 342 version of the theme. If I switch back to the 333 version, then the code changes will be in effect.

The SETTINGS are stored in the wordpress daatabase in the wp_options table. This table holds lots of options from themes, plugins and wordpress itself. Swapping versions of the theme won't effect the options, each version of the theme will use the same options (unless you go from a newer release to an older release and there is an option that the older release didn't know about.) This is why you can switch to the default theme and then back to atahualpa and your options still exist.

Most themes do not remove their settings even when you delete the theme, they are still there in the database.

Hope this answers your questions and thanks for the donation.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Aug 9, 2009, 10:15 AM
Zeus
 
7 posts · Aug 2009
Singapore
Dear juggledad,

Once again, thank you for your detailed explanation. I have managed to learn a lot from your replies.

Keep it going!

Cheers.

Bookmarks

Tags
navigation, page

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Showing Logo Next To Page Menu Navigation? mannitol Page & Category Menu Bars 6 Jul 28, 2011 11:43 AM
Page Navigation Issues Zeus Forum How-To 2 Aug 8, 2009 10:07 AM
Page Creating/Editing Issues Indog-I Atahualpa 3 Wordpress theme 1 Jul 26, 2009 10:09 AM
Page navigation link colors pltrace Post-Kicker, -Byline & -Footer 4 Mar 9, 2009 09:42 AM
Centering Page Navigation cks Page & Category Menu Bars 1 Feb 6, 2009 04:23 PM


All times are GMT -6. The time now is 03:02 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.