Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Center area post/pages » Post-Kicker, -Byline & -Footer »

[SOLVED] Error: Warning: implode() [function.implode]: Invalid arguments passed in .


  #1  
Old Aug 4, 2009, 03:42 PM
grasshopper
 
20 posts · Jun 2009
Hi -

Sorry to post twice in one day but having to recreate my website has led to all sorts of problems:

I am getting the following error in posts:

Warning: implode() [function.implode]: Invalid arguments passed in /home/...../...../wp-content/themes/atahualpa333/functions/bfa_postinfo.php on line 14


Line 14 contains: $meta_values = implode(", ", get_post_custom_values($meta_key));

And is part of this function:

// Callback function for post meta replacement
function meta_values($matches) {
$meta_key = $matches[1];
// "get_post_custom_values" returns an array. Turn it into a string, separated by commata
$meta_values = implode(", ", get_post_custom_values($meta_key));
return $meta_values;

How do I fix this?

Thanks so much.
  #2  
Old Aug 4, 2009, 06:02 PM
grasshopper
 
20 posts · Jun 2009
Hi All -

I was trying a bunch of fixes while I was waiting for a response and I found my problem and its solution, so I wanted to post it here in case anyone else ever has this problem.

As I mentioned in another thread, I had to reload the theme and start my customization from scratch. but, I had saved my somewhat extensive %meta('field name')% calls from the post/page info items of the theme options in a notepad on my harddrive. I had pasted them back into the post/page info items opton when I started redoing my website, before assigning or creating any custom fields, figuring it didn't matter what order I did things in. Apparently that is a big no no. So, I deleted all of the meta call tags out of postinfo page options and voila. the error went away. I've since reentered a few %meta('field name')% after creating a few custom fields and everything is working.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error in excerpt function? If cut-off point is <em> jankph Excerpts, Read more, Pagination 4 Jul 16, 2009 01:41 PM
[SOLVED] Errors: Invalid argument supplied for foreach() Call to undefined function skyline Atahualpa 3 Wordpress theme 1 Jun 4, 2009 12:41 AM
Was it checked with WP 2.7.1? I am getting multiple message like: Warning ... gm10 New Versions, & Updating 3 May 17, 2009 08:01 PM
Error warning status bar page bottom JBWhite Atahualpa 3 Wordpress theme 0 Apr 21, 2009 11:53 AM
Fatal error: Call to undefined function is_front_page() kyuen New Versions, & Updating 4 Mar 1, 2009 06:19 PM


All times are GMT -6. The time now is 12:31 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.