Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » New Versions, & Updating »

[SOLVED] Yikes! Upgraded to wp 2.8.3 & got MySQL error

Old Aug 3, 2009, 11:43 PM
88 posts · Jul 2009
Cleveland, OH
I auto-upgraded about 3 minutes ago and got this error when I refreshed my site (http://theagnonschool.org):

WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'order ASC' at line 1]
SELECT t.*, tt.* FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON t.term_id = tt.term_id WHERE tt.taxonomy IN ('category') AND ( t.term_id <> 1 AND t.term_id <> 9 AND t.term_id <> 46 AND t.term_id <> 48 ) ORDER BY order ASC
And, OK, I was an idiot. Because every other upgrade I've done has gone super smoothly, for some reason I thought it would be OK not to back up (although I do have autobackups from yesterday).

So then I tried:
Reinstalled the earlier the previous version of WP. Still got the error message.
Restored my database to a version from a couple days before the upgrade. Still got error message.
Repaired my database from cPanel. Still got error message.
Tried again to upgrade to 2.8.3. Still got error message.

I don't know anything about MySQL. I did sent a support ticket to my host, Hostgator, and posted the problem on the Auto upgrade 2.8.2 to 2.8.3 "Installation Failed" forum at WP.org.

It doesn't seem that likely to me that Atahualpa is involved in the problem at all, but please, does anyone have any ideas about what went wrong or suggestions about what I should do?
Old Aug 3, 2009, 11:50 PM
88 posts · Jul 2009
Cleveland, OH
I just heard back from Hostgator:

Greetings and Salutations!

Looks like this was caused by the my-category-order plugin. I moved the directory (/home/shem/public_html/wp-content/plugins/my-category-order/ to /home/shem/public_html/wp-content/plugins/my-category-order.old) and this resolved the error at the top of the screen. I went and downloaded the newest version of WordPress but was still getting this error. It seems this part of the query "ORDER BY order ASC" is incorrect (where oder ASC needs to be tt_order ASC or something similar).

In the mean time, the website is no longer displaying any errors, but you may want to get a hold of the plugin author to resolve this issue. Youc an more information here:


Hope this helps! Please do not hesitate to contact us if you are in need of further assistance.

Have a wonderful day!
So this is resolved, but anyone else who uses My Category Order might want to beware when upgrading.


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error in excerpt function? If cut-off point is &lt;em&gt; jankph Excerpts, Read more, Pagination 4 Jul 16, 2009 02:41 PM
[SOLVED] Emiting custom &lt;ul&gt;...&lt;/ul&gt; menu HTML gesman Header configuration & styling 2 Jul 15, 2009 07:14 PM
[SOLVED] Page Menu Dropdowns Have Disappeared - YIKES! krystyna Page & Category Menu Bars 1 May 29, 2009 05:18 PM
How to enable 3-letter-words in Vbulletin w/ MySQL fulltext search Flynn Forum How-To 0 Apr 21, 2009 06:41 AM
Rrs & comments parsing error zenfull RSS, Feeds & Subscribing 2 Apr 13, 2009 10:16 AM

All times are GMT -6. The time now is 11:21 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.