Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » Running WordPress » Installing & running WordPress »

My index file is messed up... please help!


  #1  
Old Aug 3, 2009, 02:21 PM
plzhelp
 
3 posts · Aug 2009
Hi,

In trying to follow the arcane instructions for "Giving Wordpress Its Own Directory", I severely messed things up.

I thought I followed every step, but clearly missed something. I'm new to programming, so I should have just left well enough alone.

Well, now when I go to my old url, I see the sidebar, header image, and footer, but everything else is missing. The title says "Page not found." And I cannot log in to Wordpress.

One more thing, if it helps: I did change "require('./wp-blog-header.php');" to "('./wordpress/wp-blog-header.php');" and got this message:

Quote:
Warning: require_once(admin.php) [function.require-once]: failed to open stream: No such file or directory in /dailyas1/wordpress/wp-admin/edit.php on line 2

Fatal error: require_once() [function.require]: Failed opening required 'admin.php' (include_path='.:/usr/local/php5/lib/php') in /dailyas1/wordpress/wp-admin/edit.php on line 2
After some more attempts at restoring it, I got line 17 (instead of 2), once.

So I just switched back to "require('./wp-blog-header.php');". And now here I am.

Is there any way to restore or locate the old index and all the customizations I made? I don't want to lose everything!!

aaah!

Thanks for any help!

-frustrated newbie

Last edited by plzhelp; Aug 3, 2009 at 02:27 PM.
  #2  
Old Aug 3, 2009, 02:23 PM
plzhelp
 
3 posts · Aug 2009
By the way, here is my current, half-empty index page: http://www.dailyasker.com/Wordpress/

In case that info is useful to anyone who could help me out.

Many thanks.
  #3  
Old Aug 3, 2009, 04:12 PM
juggledad's Avatar
juggledad
 
23,684 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Did you fix it? It looks good to me first post is
Quote:
Welcome to DailyAsker 2.0! (formerly known as thedailyasker.blogspot.com)
| Send to a friend!
What I love about this new site: Everything!! Itís designed to be interactive. Itís created for comments, since you can answer each other and I get instant emails whenever you write something. You also can announce what youíve asked for, get advice from me or readers, slap my dapper new logo on whatever your heart desires (check out the shop!) or activate the ďasker tracker,Ē which uses GPS technology to inform readers where negotiations are unfolding live across the planet. (Ok, still working on the last one. But everything else is good to go.)
Take a look around, let me know what you think, and join me in Year Two of asking!

July 7th, 2009 | Category: Uncategorized | No comments
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Aug 4, 2009, 01:03 AM
plzhelp
 
3 posts · Aug 2009
Sadly, I did not fix it.

What you see there is a backup from a few weeks ago I asked my host server to restore. The other files, the files with all the content and tweaks, are still missing. I've put the entire old site in a subdirectory (oldsite), and now I'm sorting through that to try to find the most recent version of my blog.

Even if it's a small setback, I can always do over the customizations to the theme. What I'm most bummed about is the content. Do you know in which file or folder the blog page content is held? If I could restore/salvage that most recent material, the format I can redo.

Thanks again.
  #5  
Old Aug 4, 2009, 05:14 AM
juggledad's Avatar
juggledad
 
23,684 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The posts are stored in the wordpress database. If that was restored then, safely you are out of luck. It sounds like this is the case since the theme settings are gone since they are stored in the same database.

The blog is made up of the WordPress code, including the theme code and plugins, any media (photos, video etc) you uploaded, and the database. The database contains all your data ( user i'd's, theme settings, posts, plugin/widget settings). I hope you have a recent backup of it.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Tags
index, installation, wordpress

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Messed up in Internet explorer jorund Installing & running WordPress 11 Dec 5, 2009 01:28 AM
[SOLVED] 3.4.2: where to make changes that used to be in index.php? bcorrigan New Versions, & Updating 2 Jul 13, 2009 11:52 AM
[SOLVED] Where are the Pages I create in Atahualpa, stored on the file index configur Leoni Atahualpa 3 Wordpress theme 2 Jun 11, 2009 09:08 PM
How to not have Google index my sidebar data? gabrielnovo Atahualpa 3 Wordpress theme 5 May 6, 2009 07:46 AM
Replace posts on index page with a plugin vincotek Plugins & Atahualpa 3 Apr 5, 2009 05:40 PM


All times are GMT -6. The time now is 01:53 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.