Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

One thread - many questions


  #1  
Old Jul 30, 2009, 04:06 AM
Slush
 
8 posts · Jul 2009
Hi

Let me start by saying that the Atahualpa theme is simply amazing. I'm a WordPress n00b, but Atahualpa has really helped me a lot already.

I've been using this forum to search for answers, since people seem to run into the same sort of questions along the way. Now I'm stuck, though, so I hope people here can help me with these last issues.

I refer to my website at www.danesonthemoon.com - remember, it's work in progress.

1. I'm not happy with the page navigation bar. At the very least I would like the menu options to have the same spacing, but I don't know how to set it. What I'd really like to do is to set a background image for each menu option, so I could make it look like tabs. Is that possible with Atahualpa?

2. The dotted line at the sidebar should go. I'd like to let the faded background show through, but it seems I can only set a fixed colour for the border bar. Any ideas?

3. I looked through the image folder of Atahualpa but can't find the grey bullet points used in the sidebar. I would like to change them and make them smaller so the line spacing is the same as for the body copy in the main column. How do I do that?

4. I know I can move the RSS feed in to the sidebar, but when I do it shows up with email and comment feed as well. I don't want those. Any idea on how I can move just the RSS feed button?

Thanks!

Holger aka Slush
  #2  
Old Aug 7, 2009, 07:20 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
You can do all this with CSS Inserts, and the RSS settings are at Theme Options -> RSS Settings
  #3  
Old Aug 10, 2009, 02:59 AM
Slush
 
8 posts · Jul 2009
Thank you for your answer. Do you think you could elaborate it?

As for the RSS Settings, I've obviously tried that. They do not enable me to do what I asked for in the OP.

rgds/slush
  #4  
Old Aug 10, 2009, 03:00 PM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
I thought the Subscribe widget allowed to display only one of the buttons, but apparently it doesn't, sorry. I suggest that you install and use one instance of http://wordpress.org/extend/plugins/php-code-widget/, place it in a sidebar and into the widget put

PHP Code:
<a href="<?php bloginfo('rss2_url'); ?>" rel="nofollow">
<img src="<?php echo get_bloginfo('template_directory'); ?>/images/your-rss-graphic.gif" style="YOUR CSS STYLES HERE IF ANY" alt="Subscribe to <?php bloginfo('name'); ?>" /></a>
Upload a your-rss-graphic.gif to /atahualpa342/images/ or replace your-rss-graphic.gif in the code above with post-feed.gif to use the existing default image

1. Use an existing menu bar from the web i.e. http://www.dynamicdrive.com/style/cs...ors-tabs-menu/, add its CSS through Atahualpa's CSS Inserts, and at Style & Edit HEADER AREA -> Configure Header Area, instead of using %pages, create your own menu bar with HTML and PHP:

PHP Code:
<?php wp_page_menu('menu_class=slidetabsmenu&show_home=true&link_before=<span>&link_after=</span>'); ?>
 <br style="clear: left;" />
See http://codex.wordpress.org/Template_Tags/wp_page_menu to customize the output of wp_page_menu

In the CSS insert, reference the two images correctly, and upload them to the right place, i.e. /atahualpa342/images/

background:url(/wp-content/themes/atahualpa342/images/tab-right.gif) no-repeat right top;

background:url(/wp-content/themes/atahualpa342/images/tab-left.gif) no-repeat right top;


Or see http://forum.bytesforall.com/showthread.php?t=2837

2. You can use "transparent" instead of color code, or set the border width to 0 instead of 1px

3. These aren't images but borders, and can be set at Theme Options -> Page Menu Bar. To replace them with graphics see http://forum.bytesforall.com/showthread.php?t=1149
  #5  
Old Aug 10, 2009, 04:08 PM
Slush
 
8 posts · Jul 2009
Thanks a lot! I'm going to give it a try tomorrow and post back here.

cheers/slush
  #6  
Old Aug 11, 2009, 08:51 PM
yumiko7
 
8 posts · Apr 2009
Hi Flynn, Hi Slush,

Excuse me for interrupting. I wanted to ask the same question about placing only RSS feed buttons on sidebar.

I installed the php-code-wedget and activated it, but I am not sure what you mean by "place it in a sidebar." I went ahead and put the PHP code into the widget, but the image link is broken (I tried it with post-feed.gif). When I click on the alt text, I get 404 file not found error.

Thank you so much for your help!
  #7  
Old Aug 12, 2009, 07:30 AM
Flynn's Avatar
Flynn
 
3,768 posts · Oct 2008
Munich, Germany
"Place it in a sidebar": See Site Admin -> Widgets

Re: Image: If your Atahualpa directory on the web server is /atahualpa/ then the path to the image would be /wp-content/themes/atahualpa/images/post-feed.gif instead of /wp-content/themes/atahualpa342/images/post-feed.gif.
  #8  
Old Aug 12, 2009, 11:21 PM
yumiko7
 
8 posts · Apr 2009
Hi Flynn,
I got it work!
I needed to add "PHP Code" in Wedgets. I was using Text.
Thank you so much!
  #9  
Old Aug 19, 2009, 04:30 AM
Slush
 
8 posts · Jul 2009
Hi Flynn

Sorry for the late reply, work caught up with me.

Thank you for your kind help! There's still a lot of tinkering to do, but moving the RSS feed and changing the menu was a big step in the right direction and very easy to do with your excellent instructions.

cheers/slush
  #10  
Old Aug 19, 2009, 07:13 AM
Slush
 
8 posts · Jul 2009
I'm afraid I'm still a bit at a loss here.

The menu bar works, as you can see here: www.danesonthemoon.com

But only on the landing page, as soon as I navigate to another page the tab graphics disappear, while the bold text during mouse-over remains. I looked at the source code for the individual pages and could find no apparent cause.

The HTML code, I've inserted into the Configure Header Area looks like this:

Quote:
<div id="slidetabsmenu">
<ul>
<li><a href="http://www.danesonthemoon.com/about" title="About"><span>About</span></a></li>
<li><a href="http://www.danesonthemoon.com/clients" title="Clients"><span>Clients</span></a></li>
<li><a href="http://www.danesonthemoon.com/work.htm" title="Work"><span>Work</span></a></li>
<li><a href="http://www.danesonthemoon.com/news" title="News"><span>News</span></a></li>
<li><a href="http://www.danesonthemoon.com/contact" title="Contact"><span>Contact</span></a></li>
</ul>
</div>
<br style="clear: left;" />
When it works on the index page/landing page it should work on all pages, right?

rgds/slush
  #11  
Old Aug 21, 2009, 05:55 AM
Slush
 
8 posts · Jul 2009
I tried with this instead of %menu in the Style & Edit HEADER AREA:

Quote:
<?php wp_page_menu('menu_class=slidetabsmenu&show_home=t rue&link_before=<span>&link_after=</span>'); ?>
<br style="clear: left;" />
The result was a bullet point list with no graphics.

rgds/slush
  #12  
Old Aug 24, 2009, 04:24 AM
Slush
 
8 posts · Jul 2009
Quote:
Originally Posted by Slush
I tried with this instead of %menu in the Style & Edit HEADER AREA:



The result was a bullet point list with no graphics.

rgds/slush
Okay, I figured this one out myself. I should have put it between a <DIV> tag.

The problem seems to be that all other pages but the landing page do not call the images. I'm really at a loss trying to figure out why that is.

rgds/slush
  #13  
Old Aug 25, 2009, 03:09 AM
Slush
 
8 posts · Jul 2009
SOLVED!

It turned out the index page and the sub pages are in different directories, and since the graphics refered to a relative directory instead of an absolute, the sub pages looked in the wrong one.

A bit of http:// ... and everything works. Sometimes the simplest things are the easiest to overlook.

rgds/slush

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
where is the H1 H2 thread faigekobre Page & Category Menu Bars 1 Jun 21, 2009 11:21 PM
Make thread stickey kevjazz Post-Kicker, -Byline & -Footer 0 Apr 26, 2009 06:16 PM
A Few Questions.... paulharrisjr Atahualpa 3 Wordpress theme 1 Mar 31, 2009 09:52 PM
2 Questions HowlingScribe Atahualpa 3 Wordpress theme 6 Mar 23, 2009 04:20 PM
Some general format questions Nielsp Atahualpa 3 Wordpress theme 4 Jan 15, 2009 11:00 AM


All times are GMT -6. The time now is 02:47 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.