Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

Question about excerpts in postformat


  #1  
Old Apr 28, 2016, 08:45 PM
flyboy's Avatar
flyboy
 
115 posts · Sep 2010
I recently finished two sites which use <?php the_excerpt(); ?> in postformat.php, but I'm having conflicting behavior on them.

One site creates an excerpt from content if excerpt window is left empty, but gives priority to content in the excerpt window when filled. The other simply ignores all content and only looks at the excerpt window. So when the excerpt window is left empty, no content shows in postformat.

Which of the two is the expected behavior of <?php the_excerpt(); ?>?
  #2  
Old Apr 28, 2016, 11:50 PM
CrouchingBruin's Avatar
CrouchingBruin
 
299 posts · Aug 2010
Santa Monica, CA
That second behavior sounds strange. I would think something would get displayed. According to the Wordpress Codex, the_excerpt() is supposed to output the contents of the Excerpt field if present, otherwise it outputs a trimmed down version of the post content:
Quote:
It uses get_the_excerpt() to first generate a trimmed-down version of the full post content should there not be an explicit excerpt for the post.
This is the behavior that I see on my test site, i.e., I see either the content of my Excerpt field, if populated, or the first 55 words of the post content.
__________________
My Montezuma-themed sites: ESHS Girls Basketball Team, Venice Hongwanji Buddhist Temple
Please consider making a donation to BytesForAll for their great themes!
  #3  
Old Apr 29, 2016, 05:05 AM
juggledad's Avatar
juggledad
 
23,545 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
CrouchingBruin is right in the way it should work

Have you (debugging 101) disabled ALL plugins?
Does the issue happen for every post?
If you create a manual excerpt does it show up?

if none of these questions pushes you to a solution, please export your Monetzuma settings and attach them to a reply
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #4  
Old Apr 29, 2016, 12:02 PM
flyboy's Avatar
flyboy
 
115 posts · Sep 2010
Quote:
Originally Posted by juggledad
Have you (debugging 101) disabled ALL plugins?
Funny how that goes - that's a question that I'd immediately ask someone else.

To answer it - I did not, at least not before posting the question (facepalm). But now that I did, I found the offending plugin.

The downside (and the upside) is that the culprit plugin is one of ours, lol

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Question on Excerpts vs Full Posts on a Custom Template Page riw777 Excerpts, Read more, Pagination 2 Apr 8, 2013 11:48 AM
Homepage name and link & postformat-aside question josie Montezuma Theme 8 Jan 15, 2013 09:03 AM
Replacing bfa_excerpt() with the_content() in postformat.php causes mismatch Jonathan Harford Montezuma Theme 5 Jan 7, 2013 02:16 PM
postformat.php question lightbringer Montezuma Theme 6 Dec 20, 2012 01:23 PM
[SOLVED] Configure EXCERPTS set to excerpts shows code in posts in 3.4.9 Jrdpa Excerpts, Read more, Pagination 14 Jan 19, 2011 12:36 PM


All times are GMT -6. The time now is 07:24 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.