Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Installation/Upgrade Issues »

Safety issue: accessability of all folders


  #1  
Old Mar 8, 2016, 02:28 AM
annsworld
 
140 posts · Mar 2010
Hi, I just sent a- rss-feed-newsletter around which contained a video. Not entirely surprisingly the video does not show up in the mail - just the link.

As I was testing this, I realized that each part of the folders can be accessed by anyone!

http://www.dievogelschule.com/wp-con...Verpaarung.mp4

That is http://www.dievogelschule.com/wp-con...loads/2016/03/
www.dievogelschule.com/wp-content/uploads/2016/ etc. Allowing anyone access to all contents

I frantically started pasting index.html into the most current and obvious folders. But I have a lot of folders in there as my website has been running for years.

This cannot be right. Is it a setting I have missed? A bug in the program? I am really concerned.

Thanks for your help.

Ann.
  #2  
Old Mar 8, 2016, 06:17 AM
juggledad's Avatar
juggledad
 
23,492 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
You should review the permissions you have for the folders - see Permission Scheme for WordPress
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 8, 2016, 08:31 AM
annsworld
 
140 posts · Mar 2010
They are all 755. I take it that is bad. What should they be?
  #4  
Old Mar 8, 2016, 09:17 AM
annsworld
 
140 posts · Mar 2010
Actually, after mucking around with bluehost ... apparently they can only do 755 for folders and 644 for files. Thus, I reseearched a bit more and it turns out, it was an issue with the .htaccess files which need at the bottom the following line inserted:

Options -Indexes

I have not had that issue before. Was something altered?

Anyhow, thank you for getting me on the way to fixing this, even if it was not the solution. I'll be sendung you a little donation for your time. Thanks.
  #5  
Old Mar 8, 2016, 09:19 AM
annsworld
 
140 posts · Mar 2010
ps. your donation form is not working. The drop down does not show any $$ amount and you cannot manually insert it. When left empty it refuses to forward to the paypal page. Would you please check this. I am using Safari.
  #6  
Old Mar 8, 2016, 09:36 AM
juggledad's Avatar
juggledad
 
23,492 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Quote:
Was something altered?
Not with the theme.

If you want to donate to me, select the 'donate to juggledad' button
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Mar 8, 2016, 09:52 AM
annsworld
 
140 posts · Mar 2010
Argh ... that's what happens when trying to do stuff in a mad rush ... donation on the way. :-)

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can't edit posts - edits vanish - Virus? Theme Issue? WP Issue? jfrenaye Atahualpa 3 Wordpress theme 1 Aug 4, 2009 07:14 AM
IE issue c32v Atahualpa 3 Wordpress theme 1 Feb 11, 2009 05:16 AM


All times are GMT -6. The time now is 05:11 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.