Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

[SOLVED] preformatted text not placed where should be


  #1  
Old Mar 5, 2016, 01:41 PM
esbrinartot
 
31 posts · Nov 2012
I'm have a problem with the preformatted text. Happens what you can see in the next image:




http://i.imgur.com/4KV6GD4.png[

This happens with Firefox and Chrome. Any suggestion to fix this problem.
  #2  
Old Mar 5, 2016, 06:24 PM
juggledad's Avatar
juggledad
 
23,511 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
What's the url?
Please export your Montezuma settings and attach them to a reply
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 6, 2016, 02:07 AM
esbrinartot
 
31 posts · Nov 2012
Hi Juggledad

URL is next:
http://geekland.eu/redimensionar-y-c...lotes-en-xfce/

Here you can find the settings.
montezuma-geekland.txt

More information that can be useful:

- I'm using the versión 1.2.8 of montezuma theme
- I'm using the last version of wordpress 4.4.2

As far as I remember I always had this problem with Firefox and never with Chrome. Now I have the problems in both of them (Desktop version).

With mobile devices I checked it with Safari in iOS 7.1.2 and I don't have the problem. With chrome I don't have it and With Firefox I have the problem. If this infomration is valuable for you I can check other browsers

Regards

Last edited by esbrinartot; Mar 6, 2016 at 02:09 AM.
  #4  
Old Mar 6, 2016, 05:23 PM
juggledad's Avatar
juggledad
 
23,511 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The <pre> tag defines preformatted text.

Text in a <pre> element is displayed in a fixed-width font (usually Courier), and it preserves both spaces and line breaks.

It seems that it was not working properly before and now it is.

If you want that text to wrap you could change the <pre> to <p>
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Mar 9, 2016, 04:07 AM
esbrinartot
 
31 posts · Nov 2012
Hi

If I use p instead of pre I obtained the next result:

Click image for larger version

Name:	Captura.PNG
Views:	164
Size:	62.1 KB
ID:	2740

As you can see grey square disappears and typography (letters) are also different. Is there any way to fix that?

In addition I know how to apply the changes one by one, but what I would need is Apply the changes to the theme and fix all the problems in 1 action. Do you know where I should go to do that?
  #6  
Old Mar 9, 2016, 04:46 AM
juggledad's Avatar
juggledad
 
23,511 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Quote:
As you can see grey square disappears and typography (letters) are also different. Is there any way to fix that?
currrently you have this CSS (very bottom of 'custom.css')
HTML Code:
pre {
    border: 1px dashed #cccccc;
    padding: 10px;
}
you need to change it to
HTML Code:
p, pre {
    border: 1px dashed #cccccc;
    padding: 10px;
}
Quote:
In addition I know how to apply the changes one by one, but what I would need is Apply the changes to the theme and fix all the problems in 1 action. Do you know where I should go to do that?
There is nothing in the theme that will do this. How do you go about creating the boxes around the code? You might look for a plugint that would allow a global change or you could export the database and try a global change then re import it (BACK IT UP FIRST)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Mar 9, 2016, 08:12 AM
esbrinartot
 
31 posts · Nov 2012
Thks again for your reply

I checked all the CSS files inside the montezuma options and I can't find the file custom.css

Even I checked file by file like for example various.css, cleafix.css.... etc and I can't find any sentence like the one you mentioned. I also checked all the files css files in the security copy and I can't find it.

So where the problem that I have now is to find out where is the location of the file to modify.

Then According your reply means that each time that I use preformatted text with the wordpress editor I will have to modify the code... This doesn't seem so practic.

Regards and thks
  #8  
Old Mar 9, 2016, 09:36 AM
juggledad's Avatar
juggledad
 
23,511 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Ahhh fumble brain it's content.css not custom.css (need more coffee....)

Quote:
Then According your reply means that each time that I use preformatted text with the wordpress editor I will have to modify the code... This doesn't seem so practic.
Themes don't control the wordpress post editor. If you use <pre>....</pre> in your post, then teh browser interperates it not the theme. What is interesting is that Safari will treat the contents of <pre>....</pre> like you want - i.e. the chile elements stay inside the pre element - but FireFox and Chrome seem to adhear to the strict interpretation of how <pre. should work.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Mar 9, 2016 at 09:41 AM.
  #9  
Old Mar 9, 2016, 09:57 AM
esbrinartot
 
31 posts · Nov 2012
The solution that you propose I see that have some issues. Typography it's not the correct one

Click image for larger version

Name:	Captura.PNG
Views:	150
Size:	16.2 KB
ID:	2741

One typography seems courier. When you replace pre by p then it's not courier.

In addition if you replace pre by p then if you write "--list" the result is "-list"

So if you write commands or code... this solution is not suitable.
  #10  
Old Mar 9, 2016, 10:02 AM
esbrinartot
 
31 posts · Nov 2012
and if I do CSS modification that you propose then when you write bold letter then you also have the square... so this is not a good solution for me.

To fix the problem maybe we should add properties like

margin-right: 10px;
margin-left: -20px;

Inside the content.css

Last edited by esbrinartot; Mar 9, 2016 at 10:09 AM.
  #11  
Old Mar 9, 2016, 10:24 AM
esbrinartot
 
31 posts · Nov 2012
Hi

the problem is fixed.

What works for me is next.

HTML Code:
pre {
	padding:				10px;
	border:				dashed 1px #cccccc;
  	white-space:           		pre-wrap;
}
If you do this the content displays perfect in any browser.
  #12  
Old Mar 9, 2016, 10:50 AM
juggledad's Avatar
juggledad
 
23,511 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Good to know, I haven't seen 'white-space' before. You learn something new every day!
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Image size and ALT text do not show up in sidebar text widget Shama Sidebars & Widgets 2 Mar 3, 2013 07:06 AM
[SOLVED] How can I insert a preformatted table avoiding Atahualpa to override its sty danidemi Header configuration & styling 3 Apr 1, 2010 12:10 AM
Changing the style of 'pre' Preformatted text? jraymonds Center area post/pages 6 Mar 8, 2010 06:49 AM
I erased the text in the TEXT WIDGET and saved. But text and imgs still appear? gwpad Sidebars & Widgets 7 Mar 2, 2010 04:27 PM
[SOLVED] Change color of title text in sidebar text widget Andante Sidebars & Widgets 3 Feb 1, 2010 06:12 PM


All times are GMT -6. The time now is 08:28 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.