Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » RSS, Feeds & Subscribing »

Full Item Issue with RSS feed to Mailchimp


  #1  
Old Jan 8, 2016, 06:50 AM
annsworld
 
137 posts · Mar 2010
I would like to have the full article sent within a mailchimp RSS campaign.

Looking at two websites I have, both with WP-Atahualpa 3.7.24. For one website (www.anncastro.net) the full article gets pulled into the mailchimp campaign exactly as wanted, for the other (www.dievogelschule.com) it does not. And I don't have a clue why. The code in the mailchimp campaign and the ATO RSS settings are identical.

Mailchimp's help pages state the <content:encoded> tags must be set. But WP-Help pages warn that that can be a problem. besides why should I need to manually paste those into articles when for the other WP site it is not neccessary?

I cannot figure out, what I am doing on the one site that is making the full article feed work and which I am not doing on the other site. Have any of you encountered this problem and can tell me where I should be looking?

Thanks,
Ann.

Last edited by annsworld; Jan 8, 2016 at 06:52 AM. Reason: info missing
  #2  
Old Jan 8, 2016, 06:26 PM
juggledad's Avatar
juggledad
 
23,457 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Is there any difference in the settings at ATO->Configure EXCERPTS?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 9, 2016, 03:22 AM
annsworld
 
137 posts · Mar 2010
Hey, There were some differences on the working vs. not-working site:
  • Show the first X posts on HOME page as full posts? 0 vs. 1
  • Custom read more: &nbsp;. . .&nbsp;&nbsp;<a href="%permalink%">=> %title%</a> vs. <span style="color:#777"> . . . &rarr; mehr: <a href="%permalink%">%title%</a></span>
  • Excerpt length: 45 vs. 55

I changed them step by step. Unfortunately ... no difference. Still not working. So strange.
  #4  
Old Jan 9, 2016, 03:27 AM
annsworld
 
137 posts · Mar 2010
I just noticed something odd: On the working site I have Atahualpa version 3.7.24. The not-workign site has 3.7.23 BUT it claims that all themes are up to date. Thus I cannot update. Can this be a German/English issue? The working site is an English version the non-working site a German version.

It get's weirder, yet (albeit I don't know, whether this is the culprit): In the Design/Themes section it says that my current Theme is Atahualpa 3.7.24 BUT in the ATO it says I am using 3.7.24. It also states that 3.7.24 is now available, but nowhere am I able to upgrade it. I suppose because the Themes section "thinks" it is upgraded.

Last edited by annsworld; Jan 9, 2016 at 03:33 AM.
  #5  
Old Jan 9, 2016, 03:38 AM
annsworld
 
137 posts · Mar 2010
So I downloaded and switched to "Twenty Sixteen" and then back to Atahualpa which was supposed to be 3.7.24. Guess what. I still have the issue that in the Theme section it says I have 3.7.24 active, but in the ATO it still says it is 3.7.23 Arghghghghg ... what is happening here?
  #6  
Old Jan 9, 2016, 04:13 AM
annsworld
 
137 posts · Mar 2010
I also tried:
  • upgraded to php 5.4
  • Disable plugin "WP Super Edit"
  • Disable plugin "Site Layout Customizer"
  • Changed ATO/Configure EXCERPTS/Excerpt length to 50000
The last one did the trick. but I really do not understand why. In the working site the excerpt length is just 45 and it works totally without problems ...
  #7  
Old Jan 9, 2016, 07:15 AM
juggledad's Avatar
juggledad
 
23,457 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
you could try this:
1) download a fresh copy of Atahualpa to your pc
2) swap back to 'Twenty Sixteen'
3) go to Dashboard->Appearances->Themes and delete the Atahualpa theme (hover on the theme, click 'Details' delete is in the bottom right corner)
4) Click the 'Add New' and the 'Upload Theme' button and select the zip you downloaded in step (1)
5) activate the theme.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Jan 9, 2016, 09:57 AM
annsworld
 
137 posts · Mar 2010
Hi, if I do that won't I risk losing all my atahualpa settings?
  #9  
Old Jan 9, 2016, 01:40 PM
juggledad's Avatar
juggledad
 
23,457 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Nope, all the atahualpa settings are stored in the database. The only things you have to worry about would be
1) if you have header images, a logo or favicon and you are NOT using the ATO->Image Location to put them in the wp-contents/xxxx/ folder (see the option for explanation)
2) if you have any hard coded edits to any of the atahualpa files.

There is one patch for version 3.7.24 you should apply. you can find in the 'New Versions & Updating' forum
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by lmilesw; Jan 10, 2016 at 02:00 PM.
  #10  
Old Jan 12, 2016, 08:37 AM
annsworld
 
137 posts · Mar 2010
Sorry ... am so swamped with work. I'll have a look at this in the next few days ... will let you know how it went. :-)
  #11  
Old Mar 8, 2016, 03:32 AM
annsworld
 
137 posts · Mar 2010
Hi,
So I finally got around to carrying out your suggestion and to test it. The images are now showing up but all html formatting still does not.

Mailchimp says the following about this. Do you have any ideas on how to fix this?

Thanks, Ann.

"Hi Ann,

I'm really sorry to hear that the live sent campaigns aren't rendering as desired, and I can certainly take a detailed look into this matter to see what could be the cause, and also how to fix this.

Taking a look into the feed coding, I was able to see that the coding tag for *|RSSITEM:CONTENT_FULL|* is contained within the <Description> tags within the feed. Although the actual website coding is custom coded to include the table and h1 and h2 element tags, I was not able to see these tags coded into the feed itself, http://www.dievogelschule.com/feed/. If you run a search for the entire feed page pressing control+F, and then searching <h1>, <h2>, and <table>, you'll be able to see that those elements haven't been coded into the feed coding.

Because our system will only pull in the content as it is coded into the feed, there wouldn't be a way for us to pull that formatting into the actual email. With this in mind, what I would recommend is reviewing the feed coding and re-working the code so that it includes those h1,h2, and table tags.

Please do let me know if I've been unclear on anything at all, and I can provide some additional insight.

Thank you,
Olivia"
  #12  
Old Mar 8, 2016, 03:43 AM
annsworld
 
137 posts · Mar 2010
... and ... just noticed: Similar issue when posting to facebook:

https://www.facebook.com/DieVogelsch...77421615674488
  #13  
Old Mar 9, 2016, 05:30 AM
juggledad's Avatar
juggledad
 
23,457 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I think what is happening is the feed is getting an excerpt and not the full post and by default, HTML is stripped from the excerpts.

Please go to both sites and look at what you have at ATO->Configure EXCERPTS->Don't strip these tags
if they are the same, for the site that doesn't work, can you do an export of your atahualpa settings (ATO->Export/Import) and attach them to a reply.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #14  
Old Mar 21, 2016, 10:12 AM
annsworld
 
137 posts · Mar 2010
Hi, thank you. I did that and it almost works.

Still have a problem with the [video] tag. Can it be that Ata. only recognises <> styled tags?
  #15  
Old Mar 21, 2016, 05:47 PM
juggledad's Avatar
juggledad
 
23,457 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Atahualpa follows WordPress's lead and strips HTML tags <...>

[video] is not an HTML tag, it is a Wordpress shortcode

so the question is: is it being stripped or do you need it stripped?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #16  
Old Mar 23, 2016, 01:57 AM
annsworld
 
137 posts · Mar 2010
Hi & thank you for sticking with me trying to help,

the [video] tag is stripped, meaning in the RSS feed it shows the full link to the video which is a) not pretty and b) counter productive for a vlog-newsletter.

Mailchimp claims it recognises video tags and puts in a thumbnail which is sadly not happening for my vlog articles.

I have tried adding [video] as well as <video> to the ATO ... configure excerpts section to no avail

Any ideas of any workarounds I could try?

Thank for your help,
Ann.
  #17  
Old Mar 23, 2016, 04:17 AM
juggledad's Avatar
juggledad
 
23,457 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Since WordPress converts the [video] shortcode into a link (<a>) try adding <a> to the ATO->Configure EXCERPTS->Don't strip these tags option and see what happens.

One other thing you could try. Create a manual excerpt on the post edit page...
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Mar 23, 2016 at 06:29 AM.
  #18  
Old Mar 23, 2016, 10:38 AM
annsworld
 
137 posts · Mar 2010
Hi there, tried adding <a> - no difference

Regarding excerpt. I don't know what you mean. I want the full post to show in the newsletter. Even if not: Where would I enter a manual excerpt? Do you mean adding the "more ..." at the end of my post?
  #19  
Old Mar 24, 2016, 06:45 AM
juggledad's Avatar
juggledad
 
23,457 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
sorry, I forgot that you are sending the full posts. The ATO->Configure EXCERPTS->Don't strip these tags option only applies to excerpts.

How are you telling mailChimp to mail the articles?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] 1st level parent item menu link issue rackphoto Atahualpa 3 Wordpress theme 4 May 8, 2012 09:21 AM
[SOLVED] Mailchimp sign-up form in text widged not triggering success message annsworld Sidebars & Widgets 5 Jun 22, 2011 09:22 PM
[SOLVED] RSS feed delvers full posts rather than excerpts AlanD RSS, Feeds & Subscribing 5 Sep 29, 2009 03:59 PM


All times are GMT -6. The time now is 07:57 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.