Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

iPad width


  #1  
Old Nov 10, 2015, 07:42 AM
kingjonesy
 
11 posts · Oct 2015
Hi,

I've been racking my brains on this for ages!

My website www.ukwildcamping.com doesn't display properly on my iPad, it only displays 3/2's of the screen's width. I've tried using the developer tools to diagnose it but without luck.

Can you of clever lot tell me what I'd doing wrong?

Many thanks

Rich
  #2  
Old Nov 10, 2015, 09:36 AM
juggledad's Avatar
juggledad
 
23,649 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
try removing all the widgets from the right widget area.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Nov 10, 2015, 02:29 PM
kingjonesy
 
11 posts · Oct 2015
Hi,

I've tried removing each widget and removing the lot but no joy. One thing I've noticed is that the page loads correctly but resizes at the end.

I've reset all settings and it looks fine so it must be a custom setting I've set somewhere.
  #4  
Old Nov 10, 2015, 04:40 PM
juggledad's Avatar
juggledad
 
23,649 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
I noticed that on my iPad the tag cloud (right sidebar), the twitter feed (left sb) and some of your galleries seem to exceed their alloted space - ie they bleed thru their columns.

Here is what I would do
1) change the # posts displaed to 1 and add a new test post (50 words or so)
2) remove all the widgets from both sidebars

and see what that does. If it goes full screen, then add thing back in till you find the culpret.

I just looked at a site of mine and it is fine so it has to be content or ossibly one of your settings. If the removing widgets/images from posts doesn't work, export yout settings and attach them to a reply and I'll see if it effects my site.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Nov 10, 2015 at 04:45 PM.
  #5  
Old Nov 11, 2015, 01:40 AM
kingjonesy
 
11 posts · Oct 2015
Hi,

I tried both suggestions and no difference, I have noticed that if I refresh the page every so often it displays ok.

Config attached.

R
Attached Files
File Type: txt ata-wwwukwildcampingcom-20151111.txt (16.5 KB, 397 views)
  #6  
Old Nov 11, 2015, 05:00 AM
juggledad's Avatar
juggledad
 
23,649 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
ok, it's now time to learn some debugging.

since you have an export of your settings - hit the gray 'Reset ALL theme options' at the bottom of any page and then look at your site on your iPad. it should look fine.

Now import the settings (I always hit the green save button after the import)
next go thru each option page and hit the RED 'Reset Setting' button and go look at the page on the iPad.

When there is finally a change - you know the option page that is causing the issue. So you re-import your original settings (hitting save after the import) and go to the troublesome option page and look at each option. For any that are different from the default, you can set them back to teh default, hit save and test and repeat till you find the offending option.

Now you can look at that option and see if you can determine what the issue is.

And yes I know what the issue amd will be interesting in seeing what you discover yourself.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Nov 11, 2015, 07:48 AM
kingjonesy
 
11 posts · Oct 2015
Thanks v much!

So I've tracked it down to the Body Style settings:

font-family: tahoma, arial, sans-serif;
font-size: 0.8em;
color: #000000;
background: #000000;

If I set the font size to 0.8 then it looks ok, if I increase the font size it breaks it.
  #8  
Old Nov 11, 2015, 08:24 AM
kingjonesy
 
11 posts · Oct 2015
I can't seem to get it to work, each time i alter the text sizes it move things about and breaks the spacing.
  #9  
Old Nov 11, 2015, 09:04 AM
juggledad's Avatar
juggledad
 
23,649 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
nope, that's the wrong theme option causing the problem - it is NOT the Body Style setting
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #10  
Old Nov 11, 2015, 02:17 PM
kingjonesy
 
11 posts · Oct 2015
Can I have a clue?
  #11  
Old Nov 11, 2015, 04:23 PM
juggledad's Avatar
juggledad
 
23,649 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Try resetting the areas under 'Header Area' and see what happens.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #12  
Old Nov 12, 2015, 12:56 AM
kingjonesy
 
11 posts · Oct 2015
OK so I now have:

padding: 10px;
float:none;
margin-left:auto;
margin-right:auto;
text-align:center;

In the Blog Title Style, however I can't get it to centre?
  #13  
Old Nov 12, 2015, 02:07 AM
kingjonesy
 
11 posts · Oct 2015
OK so I think I've cracked it!

Width:100% seems to have sorted it!


padding: 20px;
text-align:center;
float:none;
margin-left: auto;
margin-right: auto;
width: 100%;
  #14  
Old Nov 12, 2015, 04:21 AM
juggledad's Avatar
juggledad
 
23,649 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
did you happen to reset the look at the settings in ATO->Header Image page?
or look at the settings in ATO->Header Image->Overlayed Blog Title/Tagline Style?
see anything odd?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #15  
Old Nov 12, 2015, 04:57 AM
kingjonesy
 
11 posts · Oct 2015
Yes that's where I made the changes to the width etc, which now looks like:

Header Area> Header Image> Overlayed Blog Title/Tagline Style

padding: 20px;
text-align:center;
float:none;
margin-left: auto;
margin-right: auto;
width: 100%;

Just need to sort out the Twitter timeline width now!
  #16  
Old Nov 12, 2015, 09:54 AM
juggledad's Avatar
juggledad
 
23,649 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
yeah, having 'width: 80em' could mess things up a bit
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
iPad and ATO>>> Custom CSS swimflyfast2 Atahualpa 3 Wordpress theme 3 Feb 27, 2014 01:37 PM
New Wordpress app for iPhone/iPad paulae Installing & running WordPress 5 Mar 8, 2011 11:58 PM
Atahualpa and iPad paulae New Versions, & Updating 8 Apr 11, 2010 03:05 PM


All times are GMT -6. The time now is 10:59 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.