Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

[SOLVED] wp_list_categories accepts no parameters


  #1  
Old Mar 29, 2015, 08:42 AM
Carqueville
 
8 posts · Apr 2012
Hi,



ID=1 is my test-ID for this

HTML Code:
<?php wp_list_categories('show_count=0&use_desc_for_title=0&child_of=1'); ?>
This should only show the children of that category according to http://codex.wordpress.org/Function_...ist_categories, yet what id does when I include it via the Montezuma-Options is it shows the whole tree like this

* Categories
> Testcategory
>>Name 1
>>Name 2

Only the names should show, obviously.

And not only this. Also, none of the other parameters that should be possible seem to work. I am puzzled.

My goal:
I've been looking for a way to include several authors for each post/article if necessary.

Since I was unable to handle the famous Co-Authors-Plugin (the php-code would not work in Montezuma and get partially display the page of a post), I thought I could just include Authors in my categories. I managed to do that with Atahualpa, but with Montezuma, I seem unable to.

What am I doing wrong?
  #2  
Old Mar 29, 2015, 09:24 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
where are you using this?
do an export of yout montezuma settings and attach to a response (MTO->Export/Import)
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Mar 29, 2015, 09:56 AM
Carqueville
 
8 posts · Apr 2012
Thank you for your answer. See attachment:
Attached Files
File Type: txt montezuma_settings_txt.txt (75.4 KB, 786 views)
  #4  
Old Mar 29, 2015, 10:12 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
you need to use the array format for the options, so instead of using
HTML Code:
<?php wp_list_categories('show_count=0&use_desc_for_title=0&child_of=1'); ?>
you ned to code it like this
HTML Code:
<?php wp_list_categories(array(
'show_count' => 0,
'use_desc_for_title' => 0,
'child_of' => 1
));   ?>
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Mar 29, 2015, 10:15 AM
Carqueville
 
8 posts · Apr 2012
Great, it worked. Thank you.

That is the second time you helped me (my last question being several years old, but nonetheless)!

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Custom Parameters for a post. keysle Installing & running WordPress 1 Dec 20, 2011 02:37 PM
[SOLVED] Help modifying the loop with several parameters Tim F Center area post/pages 3 Jul 23, 2011 08:58 AM
SQL queries for option parameters gejba Atahualpa 3 Wordpress theme 5 Jan 20, 2010 11:58 AM


All times are GMT -6. The time now is 10:59 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.