Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme »

[SOLVED] New User, Background Color Doesn't Change


  #1  
Old Jan 29, 2015, 08:12 AM
Atam
 
6 posts · Jan 2015
I'm new to Atahualpa, new to Wordpress, new to websites and blogging, and this is my 4th theme in 10 days - long story. So while the message is loud and clear that the Atahualpa developers want people to pay for support, I need to know the theme and the support are good first. Once that is established, sign me up! Meanwhile, I appreciate any help others can offer.

I'm using the WP Academy Atahualpa theme styling tutorials on YouTube to configure my site, they are extremely helpful but not everything is working on my end. I know things may differ from version to version (I have the latest 3.7.22), but the steps seem pretty straightforward for the changes I'm trying to make and should work regardless of the version.

The current, most immediate problem is that the background color doesn't change.
Steps:
1. Theme options, Body, Text & Links
2. In Body Style section, change background: #FFFFFF to preferred color (#87A660).
3. I refresh the site, nothing changes, no background color.

Previous problem resolved, but not understood.
Last night I had a problem changing the header. I removed the stock images in my Header directory and replaced it with my own jpg (with no spaces in the title). When I refreshed the page (in both Chrome and Firefox), the header area was totally white, no image. I Reset Settings, repeated the steps, nothing. I spent an hour trying to get the header to appear and finally gave up. When I came into work this morning and checked, the header is suddenly there.

Same problem with the site title and tagline. Steps in the video showed to change the Header Image settings to OverLay Blog Title/Tagline over the Header Image. But when I refreshed, there was no title/tagline at all. None, disappeared. Today, they appear.

Any thoughts about why some changes don't work at all (background color) or don't appear until hours later (header, title/tagline) in multiple browsers?

I turned off maintenance mode so you can see the site as is (without the desired green background) at designsage.net.
  #2  
Old Jan 29, 2015, 08:19 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Welcome to the forums and Atahualppa!

you probably have a caching plugin active and you don't see the results till the cache expires. Shut it off during development.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jan 29, 2015, 08:30 AM
Atam
 
6 posts · Jan 2015
Thanks for the welcome! Actually after problems with the other themes I deactivated all plugins (WP SuperCache included) while I try to build the site. The only thing that has been active was a maintenance mode app, which is deactivated while I seek support.
  #4  
Old Jan 29, 2015, 08:46 AM
Atam
 
6 posts · Jan 2015
Update - So I have no plugins on. I cleared the cache in both Firefox and Chrome and also viewed the site on my iPad. Here are the results.

Firefox - shows maintenance mode (even though the plugin is deactivated)
Chrome - shows no background color still
iPad - shows the background color
  #5  
Old Jan 29, 2015, 09:25 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
it shows maintenance mode in all three browsers - might you be logged in in the browser you can see the site?

Did you clear the cache in Wordpress - ie the wp super cache cache before you disabled the plugin?
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jan 29, 2015 at 10:12 AM.
  #6  
Old Jan 29, 2015, 11:09 AM
Atam
 
6 posts · Jan 2015
You solved it! I reactivated the plugin, deleted the cache and refreshed - it works! Thanks so much for the help, I would have never guessed a deactivated plugin could be holding things up like that.
  #7  
Old Jan 29, 2015, 11:17 AM
Atam
 
6 posts · Jan 2015
Although the original background change finally shows, I just tried changing the color again and it still doesn't show in any of the browsers when I refresh. is this typical of Atahaulpa? In the other themes changes updated immediately when I refreshed the page.

In spite of this, the thread can probably be marked resolved though I don't see a way to do that myself.
  #8  
Old Jan 29, 2015, 02:16 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
One thing to remember is that the page is built of many thin gs. Think of taking a bunch of transparent sheets and stacking them. When you add a background to the BODY, that is the bottom sheet. If all the other layers are transparent, you will see that color.

Right now, your body has a 'background: none repeat scroll 0 0 #5f882c;'

And it is still showing the wp-super-cache page. This is taken from the botton of the source of your home page.
Quote:
<!-- Dynamic page generated in 1.268 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2015-01-29 21:08:40 -->
You should not use a caching plugin while in development.
1) activate 'wp super cache'
2) go to it's options and flush every cache
3) deactivate 'wp super cache'
4) do your development.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #9  
Old Jan 29, 2015, 02:57 PM
Atam
 
6 posts · Jan 2015
Based on your email, I went back in to search for other places to clear the cache and came upon a video on this topic. According to the video, it's best not to deactivate the caching plugin, but instead just switch the setting to "Caching Off". I did that, and am now able to change the background color in Atahualpa with immediate results.

Thank you again, and once I get this sucker working I will definitely think about sending a donation your way.

Bookmarks

Tags
background color

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change Background color? 07knev Montezuma Theme 11 Oct 13, 2014 02:13 PM
[SOLVED] how to change the entire background color, not the body color? crobertl Forum How-To 24 Sep 12, 2010 10:00 AM
[SOLVED] color next to page menu doesn't change hannamargolien Header configuration & styling 3 Jun 28, 2010 02:18 PM
Why won't my background color change? timecatcher Atahualpa 3 Wordpress theme 3 Jul 28, 2009 05:25 AM
How do you change the background color? theyankeeblog Header configuration & styling 2 May 13, 2009 12:09 PM


All times are GMT -6. The time now is 04:32 AM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.