Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » eCommerce & Atahualpa »

Reporting a problem with ATA and WORDPRESS 4.1 and BuddyPress


  #1  
Old Jan 20, 2015, 10:02 PM
mrspudgun
 
7 posts · Jan 2015
I know you are not helping out people unless they are gold members but this isnt really help i need, this is a problem with ATA and wordpress 4.1 with buddypress that needs fixing in general.

As i mentioned to juggledad early last week i have found a problem with wordpress 4.1 and ATA running Buddypress, Now considering that Buddypress is indeed a MAJOR plugin used alongside wordpress i will give you step by step what i have done to make sure it was ATA causing this problem. This means people running Buddypress and ATA are at a security risk if they cannot update wordpress in future.

1. First i have installed Wordpress 4.0 and buddypress with no other plugins on fresh databases and ATA newest version and previous versions to make sure everything worked fine on previous versions as well as the newest update (result = everything works as expected)

2. Update to wordpress 4.1 ( the problem mentioned below these steps arises )

3. Fresh install of wordpress 4.1 with fresh database and buddypress + ATA ( Problem still arises )

4. revert back to wordpress 4.0 ( problem goes away )

5. tested all versions of buddypress on wordpress 4.1 + ATA to make sure it wasnt buddypress. (result= still same problem with all versions )

OK so what is this problem? well when updating or installing wordpress 4.1 with ATA and buddypress all comments made sitewide by every user made in blog posts or custom post types shows up under each buddypress pages, so if you have a busy blog and alot of comments by thousands of users under each buddypress related page ATA decides to load every single comment ever made sitewide.

Please see screenshots below to explain, first screenshot show how it is before updating to 4.1 and second and third screenshot show how it is after updating to 4.1.





  #2  
Old Jan 21, 2015, 06:32 PM
juggledad's Avatar
juggledad
 
23,560 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
After spending several hours looking at this, I've discovered that this is caused by what I believe is a BuddyPress bug. I have been able to reproduce the conditions that lead to this issue using TwentyFifteen and it happens in the current release 2.1.1 and in the current 2.2 beta 2 release.

I have opened a bug ticket with BuddyPress (https://buddypress.trac.wordpress.org/ticket/6153).

In addition I have created a patch for Atahualpa to get around the problem. I will make the patch available to anyone for $25 to cover a fraction of my time spent. If you are interested in the patch you can send the money by going to the donations page and using the 'Donate to Juggledad' button. Then send me a PM with your email address and I will send you the patch.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jan 22, 2015 at 03:24 AM.
  #3  
Old Jan 23, 2015, 06:05 PM
mrspudgun
 
7 posts · Jan 2015
Hey Juggledad ty for your post on the buddypress forums for the bug report, this comes from me and the devs there as they was happy you gave them such a good debug report on replicating it and they have proposed a fix either for the 2.2 update or the next update , they have also released a patch until its in the update, so once again ty for your time and all ATA users building a buddypress site with this theme will not have to worry about this problem, as i have said earlier last week i will be donating on this forum juggledad when i have the funds available to do so, im kinda waiting for a big pay cheque arriving and until i cannot, i will donate to these forums and also throw you a small donation for your efforts mate when i can, and ty once again
  #4  
Old Jan 28, 2015, 02:51 AM
Jam's Avatar
Jam
 
1,112 posts · Mar 2011
Perth, Western Australia
Am I the only one who thinks it is extremely rude that people, who are completely within their rights to ask for assistance, but when JD has obviously put in hours of work, not even a thankyou juggledad?? Not prepared to part with a lousy $25? Add to that the possibility you might require assistance with installing the patch, which no doubt JD would give?

Good on you JD for the new rules. It obviously means a lot less work for you guys, so I hope you are getting more quality time with the grand kids
__________________
May the learning curve never plateau... Thanks Larry for teaching me heaps.
My Themeframe built sites

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Buddypress 1.9 and Atahualpa problem lordi Plugins & Atahualpa 10 Jan 7, 2014 02:42 AM
I'm having a problem with WordPress Connect plugin Eric Bobrow Plugins & Atahualpa 2 Oct 26, 2010 02:01 AM
New to wordpress. problem with my API Key castrosebo Installing & running WordPress 1 Apr 27, 2010 07:35 AM
Might be more a wordpress problem ;-( hospitalera Sidebars & Widgets 4 Mar 25, 2009 04:03 PM


All times are GMT -6. The time now is 08:48 AM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.