Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Header configuration & styling »

[SOLVED] Problems with Scalable Background Image in Firefox Only


  #26  
Old Jan 22, 2015, 04:12 PM
Alan_OldStudent's Avatar
Alan_OldStudent
 
46 posts · Oct 2013
Northwest United States
Quote:
Originally Posted by juggledad
Alan could you do an export of your settings and attach them to a reply (use the paper clip icon)

I got the same results in both cases on my site - I did have to make the body style have 'background: transparent' and set the layout width to 80%.

I'd like to see what you have.
I sent it in a PM

Regards,

Alan OldStudent
The unexamined life is not worth living—Socrates
Gracias a la vida, que me ha dado tanto—Violeta Parra
  #27  
Old Jan 22, 2015, 06:55 PM
juggledad's Avatar
juggledad
 
23,626 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Did you by any chance put comments arround the code when you put it in the CSS Inserts? If you had used
HTML Code:
<!--Responsive BG image-->
in teh CSS Insert code it ignores anything after it.

without the comments the two example you show work fine for me. Oh Well, must be one of those things.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #28  
Old Jan 22, 2015, 08:31 PM
Alan_OldStudent's Avatar
Alan_OldStudent
 
46 posts · Oct 2013
Northwest United States
Quote:
Originally Posted by juggledad
Did you by any chance put comments arround the code when you put it in the CSS Inserts? If you had used
HTML Code:
<!--Responsive BG image-->
in teh CSS Insert code it ignores anything after it.

without the comments the two example you show work fine for me. Oh Well, must be one of those things.
Hi JD,

I went to "ATO>Export/Import Settings>Export Atahualpa settings as file" and pushed the button that said "Export & Download Atahualpa Settings File". The resulting file dump has no line feeds. That makes it hard to read for mere mortals like you and me.

I'll send you another PM with cut and paste clearly showing what I have. As you can see, I have several things in my code, all commented, and all seeming to work.

Regards,

Alan OldStudent
The unexamined life is not worth living—Socrates
Gracias a la vida, que me ha dado tanto—Violeta Parra
  #29  
Old Jan 23, 2015, 04:10 AM
juggledad's Avatar
juggledad
 
23,626 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Quote:
I went to "ATO>Export/Import Settings>Export Atahualpa settings as file" and pushed the button that said "Export & Download Atahualpa Settings File". The resulting file dump has no line feeds
it's not supose to have line feeds,. It's in the JSON format

There is a major reason that you shouldn't add
HTML Code:
<!--Responsive BG image-->
<html style="[
      background: url(http://MySite/wp-content/.../MyBackgroundImage.gif) no-repeat fixed;
      -webkit-background-size: cover;
      -moz-background-size: cover;
      -o-background-size: cover;
      background-size: cover;
";>
<!--Shamelessly stolen from a website I lost track of, modified with Juggledad's suggestion-->
to the 'HTML Inserts: Body Top' option: You now have a page with two <html> sections - this may not validate and may cause a problem in a browser (moble or desktop) at some point.

That said, what you have done with that code is applied styling to an element - you can do the same by moving the element's 'style=...' into a CSS style sheet - which is what happens when you put it into the CSS Inserts. Now there is a slight change in the syntax, but not much.

If, when you experimented with adding the code to the CSS Inserts option you used this
HTML Code:
<!--Juggledad's suggestion-->
html {
      background: url(http://15nowtacoma.info/wp-content/ata-images/ata-background/background_Logo_c_fromJD.jpg) no-repeat fixed;
      -webkit-background-size: cover;
      -moz-background-size: cover;
      -o-background-size: cover;
      background-size: cover;
}
<!--End of Juggledad's suggestion-->
it would not work because the '<!--Juggledad's suggestion-->' is not a valid comment in CSS.
Quote:
A CSS comment starts with /* and ends with */. Comments can also span multiple lines
So that line would have casued a syntax error in the CSS processor casuing it to ignore the remaining CSS (Depending on the browser since they handle things differently)

Sooooo, try again
1) remove the code from the 'HTML Inserts: Body Top' option
2) add the following to the 'CSS Inserts' option
HTML Code:
/* Juggledad's suggestion */
html {
      background: url(http://15nowtacoma.info/wp-content/ata-images/ata-background/background_Logo_c_fromJD.jpg) no-repeat fixed;
      -webkit-background-size: cover;
      -moz-background-size: cover;
      -o-background-size: cover;
      background-size: cover;
}
/* End of Juggledad's suggestion */
3) test it and see if it works.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Jan 23, 2015 at 03:46 PM.
  #30  
Old Jan 23, 2015, 03:30 PM
Alan_OldStudent's Avatar
Alan_OldStudent
 
46 posts · Oct 2013
Northwest United States
Quote:
Originally Posted by juggledad
.....
............
...........Sooooo, try again
1) remove the code from the 'HTML Inserts: Body Top' option
2) add the following to the 'CSS Inserts' option
HTML Code:
/* Juggledad's suggestion */
html {
      background: url(http://15nowtacoma.info/wp-content/ata-images/ata-background/background_Logo_c_fromJD.jpg) no-repeat fixed;
      -webkit-background-size: cover;
      -moz-background-size: cover;
      -o-background-size: cover;
      background-size: cover;
}
/* End of Juggledad's suggestion */
3) test it and see if it works.
I tried it again, and now it works!

I really appreciate your hanging in there and helping me resolve this frustrating problem.

Regards,

Alan OldStudent
The unexamined life is not worth living—Socrates
Gracias a la vida, que me ha dado tanto—Violeta Parra

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
I need a scalable header image, but how? tobi81 Header configuration & styling 1 Mar 19, 2012 10:00 AM
HOWTO: Make a scalable background image juggledad Header 15 Mar 16, 2012 01:28 PM
ThemeFrame and scalable background images smcurtis ThemeFrame Presales 3 Jun 11, 2011 12:06 PM
Can I make my Background Image Scalable jimzook Atahualpa 3 Wordpress theme 1 Dec 16, 2010 12:50 PM
Identifying background image with Firefox. Help ontrackdesignz Atahualpa 3 Wordpress theme 1 Dec 10, 2010 11:24 AM


All times are GMT -6. The time now is 09:20 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.