Wordpress Themes - WP Forum at BFA
Click Here To DONATE! Support the theme development, get more attention and additional benefits based on your donation level. Your forum name will be highlighted.

Wordpress Themes - WP Forum at BFA » Running WordPress » Installing & running WordPress »

Iepngfix.php


Build custom WP THEMES, without
coding.
Click here for THEMEFRAME

From the author of Atahualpa, the #1 most
downloaded (700,000+) theme @ wordpress.org
  #1  
Old Jul 7, 2009, 07:51 AM
Holger
 
4 posts · Jul 2009
Hello Everybody!

After upgrading from Atahualpa 3.3.3 to Atahualpa 3.4.01 i have a strange bug. It only occurs, when somebody uses the IE. With the Version 8 of IE its impossible to load the page the Version 7 loads only after a error-message. With ALL other browsers the HP is fully functional.

And the most strange thing is, that I installed WP with Atahualpa 3.4.01 on another subdomains with exact the same plugins and all the same preferences AND IT WORKS there WITHOUT a problem.

To help you to help me, here is, what the "Error-Report" says:

Quote:
Benutzer-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 1.1.4322; FDM; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Zeitstempel: Tue, 7 Jul 2009 13:42:56 UTC

Meldung: Access is denied to: http://www.partyservice-yvonne.de/pr...s/iepngfix.php
Zeile: 0
Zeichen: 0
Code: 0
URI: http://www.holgernietgen.de/privat/
  #2  
Old Jul 7, 2009, 10:42 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
check the permissions of the file
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jul 7, 2009, 11:52 PM
Holger
 
4 posts · Jul 2009
Yeah, did that thing first. I read the error-report, turned my FTP-Porgramm on and switched the permission of that file to 777, so everthing should be allowed on that file. But that didnt solved the problem...
  #4  
Old Jul 8, 2009, 03:57 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
I just tried on IE8 and the first time I got an error (no explaination, just an error) I tried again and the page came up. If I clear everything (history, cache, cookies, form data etc) I again get an error the first time and the page comes up the second time.

Hope this helps
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Last edited by juggledad; Aug 23, 2009 at 05:02 AM.
  #5  
Old Jul 8, 2009, 02:19 PM
Holger
 
4 posts · Jul 2009
Yeah, thats a workaround for the problem, but not an solution. Ok, Im really NO LOVER of the IE, but sadly here in Germany 50% till now use the piece of sh**! So it would be nice, if someone would now an solution for that strange behavior.
  #6  
Old Jul 8, 2009, 02:52 PM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
This may be related to the CSS Internal/External issue. Flynn won't be back till Friday.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #7  
Old Jul 8, 2009, 11:52 PM
Holger
 
4 posts · Jul 2009
OK, Ill wait, have posted a "warning message" on my startpage for IE-Users!
  #8  
Old Aug 23, 2009, 01:13 AM
tzahi
 
1 posts · Aug 2009
Hi guys,

I have the same problem. I use Atahualpa 3.4.1 on wordpress 2.8.4. On IE6 I get the following error:

Error: Access is denied to: http://etmob.com/wordpress/wp-conten...s/iepngfix.php
Code: 0
URL: http://blog.etmob.com

on IE7 and IE8 it looks OK.
How can I fix the problem?
Best,
Tzahi

Last edited by juggledad; Aug 23, 2009 at 05:03 AM.
  #9  
Old Aug 23, 2009, 12:32 PM
Flynn's Avatar
Flynn
 
3,765 posts · Oct 2008
Munich, Germany
I am replacing that multi file setup with a single file PNG script in the next version. For now try setting the Javascript to external or the opposite if you have it at external
  #10  
Old Aug 27, 2009, 01:35 AM
khubab1
 
1 posts · Aug 2009
You can find 100% working and tested iepngfix at http://www.nobleatom.com
  #11  
Old Aug 27, 2009, 07:53 PM
Flynn's Avatar
Flynn
 
3,765 posts · Oct 2008
Munich, Germany
There's much more to do than that to integrate it in a fully automated way into a WP theme. The location of the various files and the gif need to be figured out dynamically, and the WP options aren't available in just any file. But as mentioned I am dropping the whole Twinhelix way with another single javascript without gif file, which works pretty well
  #12  
Old Sep 8, 2009, 09:49 AM
kais
 
1 posts · Sep 2009
From what I can tell, the your currently used iepngfix doesn't work on the background image in the post container. Any idea why?
Is the implementation broken altogether, and that's why you're changing it?
Thanks for a great theme.
  #13  
Old Jan 2, 2010, 06:47 AM
adri
 
23 posts · Sep 2009
Hi

I just did a web page analysis...

http://www.webpagetest.org/result/10...etails/cached/

it's giving a 404 on iepngfix.php

is there a way I can fix this?

TIA

Adri
  #14  
Old Jan 2, 2010, 07:08 AM
juggledad's Avatar
juggledad
 
22,263 posts · Mar 2009
OSX 10.8.5 WP 3.8.x Atahualpa 3.7.x Safari 6.x Firefox 25 XP
What version of Atahualpa are you using?
see http://forum.bytesforall.com/showthr...light=iepngfix
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #15  
Old Jan 2, 2010, 07:20 AM
adri
 
23 posts · Sep 2009
3.4.4

off to read that thread.
  #16  
Old Jan 2, 2010, 07:55 AM
adri
 
23 posts · Sep 2009
Hi

I've made the change to the css.php.

Trouble is when I try to run the webpagetest again it's still saying the call to that file is still there...

How so and what can I do to ensure it's all as it should be.

Many thanks

Adri
  #17  
Old Jan 2, 2010, 08:16 AM
adri
 
23 posts · Sep 2009
OK working now.

Not very keen on changing php code in the theme though...oooer...

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
php in footer.php - links to just show up on homepage chris Atahualpa 3 Wordpress theme 6 May 9, 2010 12:50 PM
make index.php be a "page" and blog postings go to different php page zhidoni Atahualpa 3 Wordpress theme 0 Jun 21, 2009 04:25 PM
[SOLVED] messed up header.php and footer.php monochrome Header configuration & styling 0 Jun 20, 2009 02:16 PM


All times are GMT -6. The time now is 06:39 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.