Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Montezuma Theme »

Rendering old pages randomly....


  #1  
Old Aug 29, 2014, 06:17 AM
jms5017's Avatar
jms5017
 
112 posts · Jul 2010
NY/NJ Metro area
Attached are 2 versions of the home page, both rendered using Firefox within seconds of each other.
The are very different, as one represents the code as it was around 2 yesterday afternoon, the other is the code as of 5 PM yesterday. I can see the difference in firebug:
the two oclock version is:

<div id="logo-area" class="col4">
<a href="http://thestrapsaver.com">
<img class="trueleft col4 logo-top" alt="The Strap Saver Logo" src="http://www.thestrapsaver.com/wp-content/uploads/logo.png">
</a>
</div>

the five oclock version is:
<div id="banner" class="row">
<div id="logo-area" class="col12">
<a href="http://thestrapsaver.com">
<img class="trueleft logo-top" alt="The Strap Saver Logo" src="http://www.thestrapsaver.com/wp-content/uploads/logo990.png">
</a>
</div>

note that the image used for the logo is different as well. These screen shots were taken seconds apart. and if I render the pages again, I may get one or the other. The code in question is from the header.php template and the home page uses a custom template, assigned to it. The custom template was created by copying page.php, removing the sidebar widget and adding three widgets/columns at the bottom of the page.

Yes, I have cleared cache, many times, yes, I have contacted my hosting provider to report problems (they see none.) Yes, there is only one page named "home" and yes it is assigned to custom-home.php

Has anyone ever seen anything like this before?
  #2  
Old Aug 29, 2014, 06:49 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
Attach your Montezuma settings (MTO->Export/Import) to a reply
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Aug 29, 2014, 07:55 AM
jms5017's Avatar
jms5017
 
112 posts · Jul 2010
NY/NJ Metro area
Thanks for looking at this.

Last edited by jms5017; Oct 11, 2014 at 02:54 PM.
  #4  
Old Aug 29, 2014, 08:14 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
You have a caching plugin active.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Aug 29, 2014, 08:59 AM
jms5017's Avatar
jms5017
 
112 posts · Jul 2010
NY/NJ Metro area
I saw WP super cache show up in "developer tools" on chrome...the plugin is not now, nor was it ever activated...what are you seeing as on? It gets installed by default but I never
turn it on til I am done with the site. I discounted the caching issue because:
  • a computer that I had never used to view the page produced the 2:00PM yesterday version this morning.
  • if it were caching, once the browser updated the cache the problem would be forever gone. it would not be random and show up again.
  #6  
Old Aug 29, 2014, 09:04 AM
jms5017's Avatar
jms5017
 
112 posts · Jul 2010
NY/NJ Metro area
One more point....when I contacted the hosting company this am, they sent me an image of the page
showing the version of the code from yesterday afternoon at 2:00PM and said "everything works on our end!"
  #7  
Old Aug 29, 2014, 11:18 AM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
The caching plugin does the caching on the host not on your computer. It works by caching the page for some length of time determined by the plugin settings.

If you go to the site and view the source and scroll to the bottom you will see that the plugin is active and the date/time it last cached the page.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #8  
Old Aug 29, 2014, 01:06 PM
jms5017's Avatar
jms5017
 
112 posts · Jul 2010
NY/NJ Metro area
Even if the plugin was never enabled?
I'm uninstalling it now.
  #9  
Old Aug 29, 2014, 02:11 PM
juggledad's Avatar
juggledad
 
23,655 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
all I can tell you is that it was in the source of the page. It is now gone.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! H3 rendering outside it's boundaries. dmkjr Montezuma Theme 17 Mar 18, 2013 06:04 PM
Montezuma/Woocommerce - pages rendering w/out <head> or meta data. DoverTim Montezuma Theme 12 Feb 18, 2013 04:41 AM
Images Rendering Unusually in IE6 anonuser Atahualpa 3 Wordpress theme 1 Aug 7, 2009 07:03 PM


All times are GMT -6. The time now is 07:20 PM.


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.