Wordpress Themes - WP Forum at BFA
Click here to register or to donate.
Auto self-registration is not available here - far too many spammers. This forum has many, many backlinks and because of that there is an intense desire among spammers to drop their links here.

Wordpress Themes - WP Forum at BFA » WordPress Themes » Atahualpa 3 Wordpress theme » Plugins & Atahualpa »

All-in-one-event-calendar + Atahualpa V3.7.15 - Widget drop-down issue


  #1  
Old Jun 9, 2014, 10:20 PM
cefiar
 
24 posts · Jun 2014
Melbourne, Australia
Got an issue with the Agenda Widget in the All-in-one-event-calendar plugin, since V2.0.10 of Ai1ec.

The changed some of the buttons to a drop-down arrangement, which works fine with the TwentyThirteen/TwentyFourteen themes, but not with Atahualpa.

Basically the button on the widget always stays activated, so the (hidden) options are always visible.

I've tracked it down to:

Code:
div.widget ul,div.textwidget{display:block;width:auto}
Using a Browser plugin (WebDeveloper) I've found that completely removing
Code:
display: block;
from the above completely solves the issue.

I found that this is 'sort of' settable in Dashboard->Appearance->Atahualpa Theme Options under the tab Widget Styles section under Widget Content Box. I say sort of, as I can't remove the default CSS that's in that, I can only add additional CSS to it. No matter what 'display:' value I use, it never works, and I can't change those two values in the settings anywhere I look.

Any ideas where I should be looking? Is there a way to completely clear that from the CSS output, or do I need to resort to editing the code?

Note: I'm using a child theme of Atahualpa to simply add some site-specific images, so I can do any overrides in that to solve the issue, if necessary.

PS: If I set
Code:
display: none;
then it appears to work, however a bfa widget area I've defined (in the header) breaks and doesn't display.

PPS: I have a test site that exhibits the issue, but since it's on my home DSL connection I'd rather not post it in public (last time I did, I got indexed by so many bots I was with sub-par internet for a month, even after shutting down the port on my router).

BTW: Related post(s) on the Ai1ec forum: https://time.ly/forums/topic/subscri...lways-pressed/
  #2  
Old Jun 10, 2014, 05:10 AM
juggledad's Avatar
juggledad
 
23,457 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
sooo... just target that widget with a detailed CSS Selector
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #3  
Old Jun 10, 2014, 06:59 PM
cefiar
 
24 posts · Jun 2014
Melbourne, Australia
Do you mean target the Ai1ec widget, or do you mean target the BFA widget?

Sorry, CSS is not my forte. I know enough to usually be able to chop up existing CSS and find a problem, but not enough to write it from scratch.

(That said, I'm digging about trying my best to figure out stuff).
  #4  
Old Jun 10, 2014, 07:40 PM
juggledad's Avatar
juggledad
 
23,457 posts · Mar 2009
OSX 10.11.5 WP 4.x Atahualpa(all) Safari, Firefox, Chrome
It would probable be easier to target the ai1ec widget. Look for the ID of the widget, it should be unique.
__________________
"Tell me and I forget, teach me and I may remember, involve me and I learn." - Benjamin Franklin
Juggledad | Forum Moderator/Support
  #5  
Old Jun 11, 2014, 11:57 PM
cefiar
 
24 posts · Jun 2014
Melbourne, Australia
I'm pushing it back on Time.ly, the authors of Ai1ec to see if they can fix this properly in their widget.

I found that adding
Code:
div.widget ul{display:none;width:auto}
to my CSS seems to solve it without affecting the bfa widget, but anything that adds a unordered list to the sidebar is then hidden by default. Fortunately for my site, that's not an issue (at least currently).

Narrowing it down using the ID of the widget, or even the ID or the sidebar leads to weird effects that cause the code, which is a jQuery dropdown menu triggered by a
Code:
<button>
, not to work. Specifically if I use the ID of the ai1ec widget, the dropdown stops working completely, rather than appearing when you press the button and going away again (the intended behaviour).

Something screwy going on in that jQuery dropdown, but I don't know what. Found the same problem with another theme (Bankokpress) so hopefully Time.ly might fix the widget to handle this case.

Many thanks!
  #6  
Old Sep 6, 2014, 10:47 AM
oyster3000
 
1 posts · Sep 2014
Baltimore, MD, USA
I had the same issue. This CSS solves it:

Code:
div.ai1ec-subscribe-container ul{display:none;width:auto}
Add it to the "Add HTML/CSS Inserts" section of Atahualpa theme options.

All-in-one events calendar 2.1.5
Atahualpa 3.7.18
WordPress 4.0
  #7  
Old Jan 24, 2015, 11:14 PM
cefiar
 
24 posts · Jun 2014
Melbourne, Australia
Just an update on this.

I'm testing a beta of the next All-in-one-event-calendar and I've had the behaviour of this change.

I'm now using the following CSS in place of what Oyster3000 suggests:

Code:
div.ai1ec-subscribe-container ul { display:none; width:auto; }
div.ai1ec-btn ul { display:none; width:auto; }
Hope this helps.

Note: I suspect that we won't need the first line with the new version, but it just avoids issues if you step-back/forwards between versions, etc.

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Similar Threads
Thread Thread Starter Forum Replies Last Post
Default Upcoming Event message even if no event possible for calendar? shalinisridhar Plugins & Atahualpa 2 Nov 29, 2010 11:20 PM
problem with plugin event calendar 3 ciocchi Sidebars & Widgets 0 Feb 28, 2010 12:16 PM
Event Calendar???? marineceo Plugins & Atahualpa 4 Nov 17, 2009 09:12 PM
[SOLVED] Event Calendar 3 Per Lund Plugins & Atahualpa 0 Sep 5, 2009 02:06 PM
Help installing event calendar widget in sidebar echamings Sidebars & Widgets 2 May 7, 2009 05:55 AM


All times are GMT -6. The time now is 02:27 PM.


Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.